[Rozw.] Slack 13.1 stable + ATI Catalyst 10.5 ;/

Gdy jakieś urządzenie nie chce w Slackware działać...

Moderatorzy: Moderatorzy, Administratorzy

Awatar użytkownika
darkroad
Użytkownik
Posty: 21
Rejestracja: 2009-02-08, 11:41
Lokalizacja: Cieszyn
Kontakt:

[Rozw.] Slack 13.1 stable + ATI Catalyst 10.5 ;/

Post autor: darkroad » 2010-05-29, 13:16

Witam.
Zainstalowałem sobie najnowszego Slackware'a i mam następujący problem. Otóż podczas instalacji sterowników ze strony ATI wywala mi następujący następujący błąd:

Kod: Zaznacz cały

bash-4.1# ./ati-driver-installer-10-5-x86.x86_64.run --buildpkg Slackware/All
Created directory fglrx-install.gVdoOP
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.732.......
==================================================
 ATI Technologies Linux Driver Installer/Packager 
==================================================
Generating package: Slackware/All
 
ATI SlackBuild Version 1.4.1 
-------------------------------------------- 
by: Emanuele Tomasi <tomasiATcli.di.unipi.it> 
    Ezio Ghibaudo <ekxiusATgmail.com>
 
Found internal patch:
        patch-8.73x-2.6.33+
applied
 
patching file drmP.h
patching file firegl_public.c
patching file kcl_acpi.c
patching file kcl_agp.c
patching file kcl_io.c
patching file kcl_osconfig.h
patching file kcl_pci.c
patching file kcl_str.c
patching file kcl_wait.c
patching file make.sh
AMD kernel module generator version 2.1
Error:
kernel includes at /lib/modules/2.6.33.4-smp/build/include do not match current kernel.
they are versioned as ""
instead of "2.6.33.4-smp".
you might need to adjust your symlinks:
- /usr/include
- /usr/src/linux
ERROR: i don't have make module
Removing temporary directory: fglrx-install.gVdoOP


Czy to oznacza że te sterowniki nie są kompatybilne z jądrem 2.6.33.4 ?
Moja karta grafiki to Mobility Radeon HD4570 a laptop to Dell Studio 1555.
Ostatnio zmieniony 2010-06-02, 23:09 przez darkroad, łącznie zmieniany 1 raz.
Slackware - Linux for subgenius :)

Awatar użytkownika
marco70
Moderator
Posty: 1105
Rejestracja: 2006-10-26, 19:03
Lokalizacja: K...l

Re: Slack 13.1 stable + ATI Catalyst 10.5 ;/

Post autor: marco70 » 2010-05-29, 14:21

Wydaje mi się że instalujesz nie taką wersję masz system x86_64 ?
Slackware 14.2 kde 4.14.38
i5-6500 CPU @ 3.20GHz

Awatar użytkownika
darkroad
Użytkownik
Posty: 21
Rejestracja: 2009-02-08, 11:41
Lokalizacja: Cieszyn
Kontakt:

Re: Slack 13.1 stable + ATI Catalyst 10.5 ;/

Post autor: darkroad » 2010-05-29, 15:37

marco70 pisze:Wydaje mi się że instalujesz nie taką wersję masz system x86_64 ?
Nie mam wersję 32 bit, sterowniki na 100% ściągnąłem na x86.
Dodam do tego że na Slackware Current ostatnio miałem identyczny problem tylko że na catalyst 10.4.
Z tego co zauważyłem podany problem ze sterami ATi wystepuje na kernelach 2.6.33.X, na starszych kernelach nie było problemu :/
Slackware - Linux for subgenius :)

makron
Użytkownik
Posty: 151
Rejestracja: 2007-05-30, 21:28
Lokalizacja: Kraków
Kontakt:

Re: Slack 13.1 stable + ATI Catalyst 10.5 ;/

Post autor: makron » 2010-05-29, 22:35

w jakiej wersji masz kernel-headers? Powinny być dopasowane do wersji kernela. Ściągnij sobie kernel-headers z currenta. Jak kernel masz smp, to nagłówki też pobierz smp.
[quote]UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity.[/quote]

Awatar użytkownika
darkroad
Użytkownik
Posty: 21
Rejestracja: 2009-02-08, 11:41
Lokalizacja: Cieszyn
Kontakt:

Re: Slack 13.1 stable + ATI Catalyst 10.5 ;/

Post autor: darkroad » 2010-05-30, 12:33

makron pisze:w jakiej wersji masz kernel-headers? Powinny być dopasowane do wersji kernela. Ściągnij sobie kernel-headers z currenta. Jak kernel masz smp, to nagłówki też pobierz smp.
Mam zainstalowanego kernela z smp, a na płycie ze Slackiem (jak i na FTP) w katalogu extra/linux-2.6.33.4-nosmp-sdk jest tylko kernel-headers-2.6.33.4-x86-1.txz bez smp :neutral:
Acha dodam do tego że na Ubuntu 10.04 LTS na kernelu 2.6.32 sterowniki działały bez problemu, natomiast na Slacku jest kernel 2.6.33.4 i zaczynają się schody ;/ W starszych wersjach Slack'a jak instalowałem stery ATI to nie musiałem instalować kernel-headers, działały "od strzału".
Slackware - Linux for subgenius :)

makron
Użytkownik
Posty: 151
Rejestracja: 2007-05-30, 21:28
Lokalizacja: Kraków
Kontakt:

Re: Slack 13.1 stable + ATI Catalyst 10.5 ;/

Post autor: makron » 2010-05-30, 21:05

fragment wyniku slapt-ge --search kernel:

Kod: Zaznacz cały

kernel-firmware-2.6.33.4-noarch-1 [inst=yes]: kernel-firmware (Firmware installed by the kernel)
kernel-generic-2.6.33.4-i486-1 [inst=no]: kernel-generic (a general purpose single processor Linux kernel)
kernel-generic-smp-2.6.33.4_smp-i686-1 [inst=no]: kernel-generic-smp (a general purpose SMP Linux kernel)
kernel-headers-2.6.33.4-x86-1 [inst=yes]: kernel-headers (Linux kernel include files)
kernel-headers-2.6.33.4_smp-x86-1 [inst=no]: kernel-headers (Linux kernel include files)
kernel-huge-2.6.33.4-i486-1 [inst=no]: kernel-huge (a fully-loaded single processor Linux kernel)
kernel-huge-smp-2.6.33.4_smp-i686-1 [inst=yes]: kernel-huge-smp (a fully-loaded SMP Linux kernel)
kernel-modules-2.6.33.4-i486-1 [inst=no]: kernel-modules (single CPU Linux kernel modules)
kernel-modules-smp-2.6.33.4_smp-i686-1 [inst=yes]: kernel-modules (SMP Linux kernel modules)
kernel-source-2.6.33.4_smp-noarch-1 [inst=yes]: kernel-source (Linux kernel source)

Link do nagłówków ftp://ftp.slackware.pl/pub/slackware/sl ... -x86-1.txz
Link do źródeł ftp://ftp.slackware.pl/pub/slackware/sl ... arch-1.txz
[quote]UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity.[/quote]

Awatar użytkownika
darkroad
Użytkownik
Posty: 21
Rejestracja: 2009-02-08, 11:41
Lokalizacja: Cieszyn
Kontakt:

Re: Slack 13.1 stable + ATI Catalyst 10.5 ;/

Post autor: darkroad » 2010-06-02, 23:08

@makron - Jestes wielki dzieki za pomoc :-)
Slackware - Linux for subgenius :)

Awatar użytkownika
webster
Użytkownik
Posty: 1266
Rejestracja: 2009-10-06, 11:58
Lokalizacja: Gdańsk
Kontakt:

Re: [Rozw.] Slack 13.1 stable + ATI Catalyst 10.5 ;/

Post autor: webster » 2010-06-03, 09:01

darkroad, Daj jeszcze [Rozw.] w temacie
††† Chaos Of The Mirror - Valheru †††
††† I ♥ SlackWare RuLeZ †††

Slackware Poland FaceBook

ElNinijo
Użytkownik
Posty: 98
Rejestracja: 2006-11-15, 12:30

Re: [Rozw.] Slack 13.1 stable + ATI Catalyst 10.5 ;/

Post autor: ElNinijo » 2010-06-03, 18:57

zeby nie pisac kolejnych watkow:
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
AMD kernel module generator version 2.1
Error:
kernel includes at /lib/modules/2.6.33.4-smp/build/include do not match current kernel.
they are versioned as ""
instead of "2.6.33.4-smp".
you might need to adjust your symlinks:
- /usr/include
- /usr/src/linux
[Error] Kernel Module : Failed to compile kernel module - please consult readme.
ale ja juz mam wszystko w smp

i teraz pytanie problem lezy po stronie ati(nie pierwszy raz)
czy u mnie cos nie halo?

makron
Użytkownik
Posty: 151
Rejestracja: 2007-05-30, 21:28
Lokalizacja: Kraków
Kontakt:

Re: [Rozw.] Slack 13.1 stable + ATI Catalyst 10.5 ;/

Post autor: makron » 2010-06-06, 19:43

zainstaluj pakiet kernel-headers.
[quote]UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity.[/quote]

ODPOWIEDZ