Strona 1 z 1

Slackware14 i problem z dyskiem.Proszę o pomoc

: 2012-11-18, 19:31
autor: adamek30
Witam wszystkich.Zainstalowalem na swoim juz dosc starym 5-letnim sprzęcie Slacka14 i wyskoczyło mi troche błędów po uruchomieniu w czasie ładowania.

Kod: Zaznacz cały

Nov 12 18:03:59 ITB043 kernel: [    8.984140] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 254
Nov 12 18:03:59 ITB043 kernel: [    8.984155] Raw EDID:
Nov 12 18:03:59 ITB043 kernel: [    8.984160]  ^Iff ff ff ff ff ff ff ff 22 64 c2 00 4e 1b 00 00
Nov 12 18:03:59 ITB043 kernel: [    8.984166]  ^I34 10 01 03 0a 26 1e 78 ea c5 56 a4 54 4a 9d 24
Nov 12 18:03:59 ITB043 kernel: [    8.984172]  ^I14 4f 54 bf ef 80 81 80 81 c0 81 40 71 4f 61 46
Nov 12 18:03:59 ITB043 kernel: [    8.984178]  ^I01 01 01 01 01 01 30 2a 00 98 51 00 2a 40 30 70
Nov 12 18:03:59 ITB043 kernel: [    8.984183]  ^I13 00 78 2d 11 00 00 1e 00 00 00 fd 00 38 4b 1e
Nov 12 18:03:59 ITB043 kernel: [    8.984189]  ^I50 0e 00 0a 20 20 20 20 20 20 00 00 00 ff 00 36
Nov 12 18:03:59 ITB043 kernel: [    8.984195]  ^I35 32 47 46 33 4e 41 30 36 39 39 30 00 00 00 fc
Nov 12 18:03:59 ITB043 kernel: [    8.984201]  ^I2e 48 61 6e 6e 73 47 20 48 43 31 39 34 44 00 07
Nov 12 18:03:59 ITB043 kernel: [    9.087225] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 254
itp itd 

Kod: Zaznacz cały

Nov 12 18:03:59 ITB043 kernel: [   16.728537] ata5.00: BMDMA stat 0x65
Nov 12 18:03:59 ITB043 kernel: [   16.730831] ata5.00: failed command: READ DMA
Nov 12 18:03:59 ITB043 kernel: [   16.733098] ata5.00: cmd c8/00:40:57:63:09/00:00:00:00:00/e4 tag 0 dma 32768 in
Nov 12 18:03:59 ITB043 kernel: [   16.733100]          res 51/40:31:67:63:09/00:00:00:00:00/e4 Emask 0x9 (media error)
Nov 12 18:03:59 ITB043 kernel: [   16.737621] ata5.00: status: { DRDY ERR }
Nov 12 18:03:59 ITB043 kernel: [   16.739864] ata5.00: error: { UNC }
Nov 12 18:03:59 ITB043 kernel: [   18.598297] ata5.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
Nov 12 18:03:59 ITB043 kernel: [   18.600495] ata5.00: BMDMA stat 0x65
Nov 12 18:03:59 ITB043 kernel: [   18.602652] ata5.00: failed command: READ DMA
powtarza sie to jeszcze pare razy
i 3-ci błąd:

Kod: Zaznacz cały

Nov 12 18:03:59 ITB043 kernel: [   26.105889] Buffer I/O error on device sda5, logical block 6291512
Nov 12 18:03:59 ITB043 kernel: [   26.107496] Buffer I/O error on device sda5, logical block 6291513
Nov 12 18:03:59 ITB043 kernel: [   26.109088] Buffer I/O error on device sda5, logical block 6291514
Nov 12 18:03:59 ITB043 kernel: [   26.110641] Buffer I/O error on device sda5, logical block 6291515
Nov 12 18:03:59 ITB043 kernel: [   26.112168] Buffer I/O error on device sda5, logical block 6291516
Nov 12 18:03:59 ITB043 kernel: [   26.113644] Buffer I/O error on device sda5, logical block 6291517
Nov 12 18:03:59 ITB043 kernel: [   26.115109] Buffer I/O error on device sda5, logical block 6291518
Sys dziala mimo tych bledow, sprawdzilem o co chodzi z dyskiem programem HDTune i wykrylo mi jeden bad sector, jeden czerwony kwadracik reszta zielona (szybki test dal wszystkie zielone) w zakladce Health w tym programie wszystko jest niby w porzadku (zero podkreslen i wszedzie oki).Podejrzewam ze te errory maja zwiazek z tym jednym bad sectorem zwlaszcza ze ten czerwony kwadracik byl w okolicach na oko 1-szej partycji linuksowej (sda5) i ze jest ono raczej logicznym uszkodzeniem.Bo program mnie nie poinformowal gdzie to lezy dokladnie ten bs.Dysk jest dosc stary ma juz 6 lat Samsung 250 GB ale jeszcze dosc sprawny jak na swoje lata.Znacie jakis sposob zeby to naprawic? Pomijajac kupno nowego dysku bo mimo 6 lat na karku nie jest z nim tak zle jakby sugerowaly te errory (chyba?) i jeden bad sector to ponoc nie jest tragedia jeszcze.A ten system chodzi jak rakieta na tym moim starawym juz sprzecie mimo tych errorow.Prosze o pomoc co z tym fantem zrobic.Bede wdzieczny.Pozdrawiam

Re: Slackware14 i problem z dyskiem.Proszę o pomoc

: 2012-11-18, 19:39
autor: maho
Zainstaluj smarta. Błąd wygląda mi na jakiś problem sprzętowy. Dysk na ATA/SATA?

Re: Slackware14 i problem z dyskiem.Proszę o pomoc

: 2012-11-20, 16:54
autor: adamek30
Dzieki za odpowiedz, dysk ATA oczywiscie.Dodam ze wczesniej czegos takiego nie mialem, gdy instalowalem linuksa, wyskakiwaly informacje przy ladowaniu typu "not valid" czyli wszystko oki.Jesli fizyczne uszkodzenie to chyba tylko ze starosci (chyba ze kurz itp) podejrzewam bo nic z tym dyskiem nie robilem zeby go uszkodzic, albo to jest po prostu logiczne uszkodzenie.Wiele systemow juz sie przemknelo na tym dysku.SMARTA radzisz, nigdy nie uzywalem tego programu ale moze sprobuje cos nim poradzic.Procz linuksa mam tez Windowsa XP na kompie, jest mi potrzebny do EWMAPY i geodezyjnych zadan.Dlatego zalezalo by mi bardziej na pominieciu po prostu tego uszkodznego sektora niz kasacji wszystkiego,wiem ze musze zlokalizowac dokladnie ten bs i pewnie to smartem bdzie mozna zrobic, a pozniej najwyzej zainstalowalbym ponownie Slacka i instalujac pominal bym jakos ten sektor.. tylko pytanie czy da sie to zrobic za pomoca instalatora Slacka?

Re: Slackware14 i problem z dyskiem.Proszę o pomoc

: 2012-11-20, 18:41
autor: maho
Sprawa może być też trochę inna. Miałem dużo podobnych problemów, a po wymianie taśmy do dysku problemy znikały :)

Re: Slackware14 i problem z dyskiem.Proszę o pomoc

: 2012-11-20, 22:56
autor: Pajaczek
adamek30 pisze:gdy instalowalem linuksa, wyskakiwaly informacje przy ladowaniu typu "not valid" czyli wszystko oki.
A co w tym takiego "oki"??

Re: Slackware14 i problem z dyskiem.Proszę o pomoc

: 2012-11-22, 18:20
autor: adamek30
w zasadzie to nic oki.Okazalo sie ze ten bad block jest na partycji windowsowej a nie na pierwszej linuksowej.Pomylily mi sie partycje.A instalator Slacka to wyczul przy montowaniu tych partycji.Ale ten problem rozwiaze smartem.Ewentualnie za jakis czas kupie nowy dysk i bbedzie po klopocie.
Skoro juz tu pisze i zeby nie zakladac nowego tematu to mam nieco inny problem tez.Z monitorem.
Posiadam karte grafiki Nvidie GeForce 520 i naturalnie po instalacji linuksa zainstalowalem sterowniki do tej karty ze strony nvidii.Korzystam z fluxboxa i sie wszystko uruchamia tylko rozdzielczosc mi sie zmienila na 2300X12coś i nie moge zmienic.Za kazdym razem musze wpisywac polecenie w terminalu xrandr-s 1280x1024.Kombinuje w nvidia-settings w Xorgu dopisuje modes z rozdzielczosciami i nic to nie daje.Ba.Po tym wpisie w Xorgu i restarcie X-sow wywala mi blad No screen found i musze zahaszyc w xorgu zeby znow wejsc na X-sy.Dodatkowo akceleracja jest tez cos nie ten tego bo wynik glxgears daje mi ledwo 60.000 fps.Na poprzednim Slacku 13.37 i starszym sterowniku mialem normalne juz wartosci ponad 1200 a tutaj ledwie 60, 59 itp.. wiec pewnie tez cos odswiezanie monitora nie bardzo chce dzialac (mam ustawione na 85 Hz)
Wiec moje pytanie jak zmusic monitor do tego zeby po odpaleniu fluxboxa mial na stale rozdzielczosc 1280x1024? zebym nie zmienial za kazdym razem recznie poleceniami? Bo po poleceniach xrandr rozdzielczosc sie ustawia, tylko jak to miec na stale.I zeby ten monitor dzialal jak nalezy przy wyzszym odswiezaniu..

Re: Slackware14 i problem z dyskiem.Proszę o pomoc

: 2012-11-27, 19:37
autor: jacol
Witam.
Nawet leciutki fluxbox ma autostart. Stwórz skrypt umieść w katalogu z którego pobierane są polecenia podczas uruchomiania fluxboxa i po kłopocie. Plik konfiguracyjny Xorg to przeszłość... Pozdrawiam jacol

Re: Slackware14 i problem z dyskiem.Proszę o pomoc

: 2012-12-11, 10:15
autor: s2c
Wpisz xrandr w konsoli, zobacz jakie rozdzielczości masz dostępne. Następnie do .xinitrc dopisz sobie:
xrandr -s 1280x1024 -r 60
Więcej dowiesz wię wpisując `man xrandr`. Ja mam to właśnie w ten sposób skonfigurowane i chodzi bez zarzutu.

Edit: zasada jest taka, że najpierw wklepujesz takie rzeczy jak setxkbmap, xrandr, conky, a na samym końcu, w ostaniej linii pliku polecenie uruchamiające dane środowisko graficzne (eg. `fluxbox`, `startxfce4`). Inaczej środowisko się uruchomi, a kolejne polecenia nie zostaną wykonane.