Instalacja karty WIFI WN 851ND

Gdy jakieś urządzenie nie chce w Slackware działać...

Moderatorzy: Moderatorzy, Administratorzy

kicker
Użytkownik
Posty: 4
Rejestracja: 2015-04-08, 10:55

Instalacja karty WIFI WN 851ND

Post autor: kicker » 2015-04-08, 11:23

Witam, jestem początkującym użytkownikiem. Mam zainstalowany Slackware 13. Chce zainstalować kartę WIFI TP-LINK WN-851ND. Od czego zacząć?

Awatar użytkownika
dienet
Moderator
Posty: 2106
Rejestracja: 2007-07-24, 18:58
Lokalizacja: Racibórz/Rybnik
Kontakt:

Re: Instalacja karty WIFI WN 851ND

Post autor: dienet » 2015-04-08, 19:51

1. Sprawdzić jaki chipset w niej siedzi (komenda lspci). Google mówią, że: AR9227.
2. Sprawdzić czy Slackware ma jakiś moduł kernelowy, który obsługuje ten chipset. Google mówi, że moduł nazywa się ath5k.
3. Załadować ten moduł.
4. Sam przebieg połączenie to już w zakresie własnych preferencji. Ja np. używam wicd.
Pozdr0
dienet
[img]http://i164.photobucket.com/albums/u19/slawek15/kotekeo0lq3.jpg[/img]

Pajaczek
Użytkownik
Posty: 1441
Rejestracja: 2006-08-03, 13:16
Lokalizacja: Winny Gród

Re: Instalacja karty WIFI WN 851ND

Post autor: Pajaczek » 2015-04-09, 19:29

dienet pisze: Ja np. używam wcid.
Typo: wicd. (ale jak wpisać w google powyższe to też podpowiedzą ;) ).

kicker
Użytkownik
Posty: 4
Rejestracja: 2015-04-08, 10:55

Re: Instalacja karty WIFI WN 851ND

Post autor: kicker » 2015-04-21, 14:42

Po modprobe mam FATAL ERROR Inserting............. invalid modules format.

Awatar użytkownika
dienet
Moderator
Posty: 2106
Rejestracja: 2007-07-24, 18:58
Lokalizacja: Racibórz/Rybnik
Kontakt:

Re: Instalacja karty WIFI WN 851ND

Post autor: dienet » 2015-04-21, 18:13

kicker pisze:Po modprobe mam FATAL ERROR Inserting............. invalid modules format.
Odpowiednia architektura paczki do architektury całego systemu? (x86 vs x86_64) ?
Pozdr0
dienet
[img]http://i164.photobucket.com/albums/u19/slawek15/kotekeo0lq3.jpg[/img]

kicker
Użytkownik
Posty: 4
Rejestracja: 2015-04-08, 10:55

Re: Instalacja karty WIFI WN 851ND

Post autor: kicker » 2015-04-22, 08:40

Zmieniłem na sieciówkę Edimax EW-7722In, ta niby powinna sama z siebie działać a nie działa.
Pokaże co podaje mi modprobe i modinfo.
Nie pamiętam dobrze po jakim poleceniu ale pojawiło mi się coś takiego że sterownik jest 3.0.0 a powinien być 3.2.13.
Załączniki
modprobe.jpg
lspci-v.jpg
2.jpg
1.jpg

kicker
Użytkownik
Posty: 4
Rejestracja: 2015-04-08, 10:55

Re: Instalacja karty WIFI WN 851ND

Post autor: kicker » 2015-04-28, 15:33

Chyba problem polega na tym że mam dwa jądra, prawdopodobnie instaluje sterownik na stare jądro 3.0.0. a powinienem 3.2, jak wskazać podczas kompilacji to nowsze jądro ?

ODPOWIEDZ