Instalacja sterowników ATI

Gdy jakieś urządzenie nie chce w Slackware działać...

Moderatorzy: Moderatorzy, Administratorzy

iGLO
Użytkownik
Posty: 6
Rejestracja: 2006-04-05, 01:37
Kontakt:

Re: Instalacja sterowników ATI

Post autor: iGLO »

pawian pisze:shm masz?
mam,

Kod: Zaznacz cały

$ mount |grep shm
tmpfs on /dev/shm type tmpfs (rw)
zaraz sprobuje ati-driver-installer-8.14.13.run + patche

edit.

miesozer podaj dokladna wersje sterownikow dla xorga 6.8.2 i skad sciagales patche.

Pozdrawiam,
Ostatnio zmieniony 2006-04-05, 21:28 przez iGLO, łącznie zmieniany 1 raz.

miesozer
Użytkownik
Posty: 141
Rejestracja: 2005-04-13, 11:18
Lokalizacja: z wietnamu, hej!
Kontakt:

Re: Instalacja sterowników ATI

Post autor: miesozer »

z tego tematu, ale to było dawno temu. http://forum.slackware.pl/viewtopic.php?t=3903
X.org 6.8.2 był w slacku 10.1? nie jestem pewien - w każdym bądź razie na 10.1 mi to wszystko śmigało.

iGLO
Użytkownik
Posty: 6
Rejestracja: 2006-04-05, 01:37
Kontakt:

Re: Instalacja sterowników ATI

Post autor: iGLO »

Slackware 10.1 - X.org 6.8.1
Slackware 10.2 - X.org 6.8.2

To zmieniam X.org na 6.8.1 kernel na 2.6.11.5, stery 8.10.19. Zobaczymy co z tego wyjdzie.

miesozer
Użytkownik
Posty: 141
Rejestracja: 2005-04-13, 11:18
Lokalizacja: z wietnamu, hej!
Kontakt:

Re: Instalacja sterowników ATI

Post autor: miesozer »

KIlka postów wyżej dałem linki do tematów związanych z naszym problemem na innych forach i gdzieś tam było napisane że jeszcze fglrx'y w wersji 8.16 działały normalnie więc najlepiej spróbuj ostatnich działających. A do tego wydaje mi się niczego w nich nie trzeba będzie patchować. Powodzenia i daj znać czy się udało.

iGLO
Użytkownik
Posty: 6
Rejestracja: 2006-04-05, 01:37
Kontakt:

Re: Instalacja sterowników ATI

Post autor: iGLO »

Dziala !!!

Slackware 10.2
Kernel 2.6.12
X.org 6.8.2
Sterowniki: ati-driver-installer-8.14.13.run + 3 patche ( http://forum.slackware.pl/viewtopic.php?t=5312 )

fgl_glxgears
1330 frames in 5.0 seconds = 266.000 FPS
1553 frames in 5.0 seconds = 310.600 FPS
1543 frames in 5.0 seconds = 308.600 FPS
1549 frames in 5.0 seconds = 309.800 FPS
1539 frames in 5.0 seconds = 307.800 FPS
1544 frames in 5.0 seconds = 308.800 FPS

glxgears
10353 frames in 5.0 seconds = 2070.600 FPS
10526 frames in 5.0 seconds = 2105.200 FPS
10528 frames in 5.0 seconds = 2105.600 FPS
10532 frames in 5.0 seconds = 2106.400 FPS
10526 frames in 5.0 seconds = 2105.200 FPS
10526 frames in 5.0 seconds = 2105.200 FPS
10523 frames in 5.0 seconds = 2104.600 FPS

W Q3 1.32
/timedemo 1
/demo four
800x600 HQ 155 fps
1024x768 HQ 121 fps

nie jest zle, juz nic wiecej nie zmieniam ;)

Pozdrawiam i dzieki za porady.

przemek999
Pomocnik
Posty: 1157
Rejestracja: 2005-03-04, 18:27

Re: Instalacja sterowników ATI

Post autor: przemek999 »

Ja mam kernel 2.6.15 (naglowki z 2.6.x), X.org 6.9 i na najnowszych sterach ATI pieknie smiga :)
Pozdrawiam Przemek.

miesozer
Użytkownik
Posty: 141
Rejestracja: 2005-04-13, 11:18
Lokalizacja: z wietnamu, hej!
Kontakt:

Re: Instalacja sterowników ATI

Post autor: miesozer »

Na nowych z tego co się orientuję to nie ma bola żeby poszło - jedynym ratunkiem pozostają stare...tylko że z nimi jest problem pod x.orgiem 6.9 i kółko się zamyka :/
iGLO czyli mówisz że fgl_gears działa normalnie, no bo same fpsy i tak wyświetlał, co?

iGLO
Użytkownik
Posty: 6
Rejestracja: 2006-04-05, 01:37
Kontakt:

Re: Instalacja sterowników ATI

Post autor: iGLO »

Tak. Zawsze wyswietlalo mi fpsy tylko wtedy nie bylo tekstur, teraz juz sa. Zamiast szesciana z zebatkami byl niebieski albo czarny szescian i gry sie wieszaly na samym poczatku. Fpsy podalem orientacyjnie dla wydajnosci. W Q3 jest dosc duzo fpsow ale w Enemy Territory jest chyba troche mniej niz mialem na m$.

miesozer
Użytkownik
Posty: 141
Rejestracja: 2005-04-13, 11:18
Lokalizacja: z wietnamu, hej!
Kontakt:

Re: Instalacja sterowników ATI

Post autor: miesozer »

Ja pękłem i zrobiłem downgrade z x.orgów 6.9 do 6.8.2 i zainstalowałem stery w wersji 8.16.20. I wszystko śmiga ale okazało się że ta karta (R9200) nie daje rady tenebrae ( http://liflg.org/?what=dl&catid=6&gamei ... lish-2.run ) a to przecie tylko podkręcony quake pierwszy...wielkie rozczarowanie.

Awatar użytkownika
crash_zero
Użytkownik
Posty: 28
Rejestracja: 2005-11-19, 23:30

Re: Instalacja sterowników ATI

Post autor: crash_zero »

miesozer pisze:

Kod: Zaznacz cały

X -version

A ja sobie myśle dlaczego znów wiesza mi się komputer jak nagrywam płyty...to teraz już wiem:

Kod: Zaznacz cały

bash-3.1# X -version

X Window System Version 6.9.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 6.9
Build Operating System: Linux 2.4.32 i686 [ELF] 
Current Operating System: Linux localhost 2.4.31 #21 Sun Jun 5 19:19:51 PDT 2005 i686
Build Date: 21 March 2006
        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Module Loader present
bash-3.1# 
Coś mi się zdaje, że przy upgrade swaret'em niechcący dałem do instalacji najnowszego xorg'a i sterowniki ati przestały działać. Macie jakiś pomysł?

przemek999
Pomocnik
Posty: 1157
Rejestracja: 2005-03-04, 18:27

Re: Instalacja sterowników ATI

Post autor: przemek999 »

Moze podam tutaj swoja konfiguracje - sterowniki byly instalowane z graficznego kreatora, wszystko pieknie dziala:
Karta: Radeon X550
Sterowniki: ATI 8.24.8
X.org: 6.9.0
Kernel: 2.6.15.4-bootsplash
Slackware: current

Moj config X.org (sekcja device, reszta standardowa):

Kod: Zaznacz cały

#
# Ati fglrx driver
#
Identifier  "Fglrx"
Driver      "fglrx"
VendorName  "ATI Technologies Inc"
BoardName   "Unknown Board"
Option      "no_accel" "no"
Option      "no_dri" "no"
Option      "mtrr" "off"
#Option      "backingstore" "true" 
Wynik fglrxinfo:

Kod: Zaznacz cały

display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X550 Generic
OpenGL version string: 2.0.5755 (8.24.8)
Wynik fgl_xglgears (standardowy rozmiar okna):

Kod: Zaznacz cały

Using GLX_SGIX_pbuffer
2932 frames in 5.0 seconds = 586.400 FPS
4895 frames in 5.0 seconds = 979.000 FPS
4875 frames in 5.0 seconds = 975.000 FPS
Grałem w ppracer i smigal bardzo ladnie, moze te sterowniki nie daja pelnego kopa, ale mamy przynajmniej akceleracje sprzetowa i bardzo wygodna prace.
Ostatnio zmieniony 2006-04-23, 12:29 przez przemek999, łącznie zmieniany 1 raz.
Pozdrawiam Przemek.

ogro
Użytkownik
Posty: 103
Rejestracja: 2004-08-21, 12:37

Re: Instalacja sterowników ATI

Post autor: ogro »

Ja kombinowalem na Slacku 10 i tak namodzilem ze niestety postanowilem na nowo zainstalowac Slackware 10.2. I tak na swieza instalacje Slackware zainstalowalem bez najmniejszych problemow stery ATI w wersji (pod konsola):

Kod: Zaznacz cały

display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY RADEON 9600 Generic
OpenGL version string: 2.0.5755 (8.24.8)
glxgears: 2943
fgl_glxgears: 388

UPDATE 28.04.2006

Wielkie dzieki dla przemek999 , teraz stery ATI pieknie mi sie zainstalowaly na kernelu 2.6.x :) Prawdopodobnie problemem byly naglowki kernela. Jak zainstalowalem te od 2.6.x i przekompilowalem jajko stery zainstalowaly sie bez problemu, i bez zadnych patchy wszystko smiga.
Ostatnio zmieniony 2006-04-27, 23:13 przez ogro, łącznie zmieniany 1 raz.
c2d e8400, gigabyte 965p-dq6, patriot LLK 4gb ddr2 800MHz, radeon hd4850, Samsung SpinPoint F3 1TB (HD103SJ), slackware 14.0

Awatar użytkownika
pralat
Użytkownik
Posty: 51
Rejestracja: 2005-12-02, 09:32
Lokalizacja: Opole

Re: Instalacja sterowników ATI

Post autor: pralat »

Tez mam problem ze sterownikiem... Oto szczegoly:

Slackware 10.1
kernel 2.6.15.7 (na 2.6.16 w ogole modul nie dzialal ze wzgledu na brak inter_module...)
X.org 6.8.2 (probowalem tez 6.8.1)
xorg.conf:
standardowy, Driver "fglrx", bez zadnych opcji
ati 8.24
karta radeon 9600

Modul fglrx kompiluje sie i mozna go zaladowac bez problemow, natomiast przy uruchamianiu X-ow sa problemy:
Symbol xf86PrintEDID from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol firegl_InitIrq from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol firegl_InitIrq from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!

Mialem tez bledy odnosnie funkcji "fbGetWinPrivateIndex", ale zalatwilem to poprzez Load "fb" w xorg.conf.
Nie mam pojecia, jak rozwiazac problemy, ktore pozostaly. Dziwi mnie w ogole blad odnosnie "firegl_InitIrq", bo funkcje firegl_xxxx pochodza chyba z samego sterownika ati, wiec fglrx ma problem ze znaleziemiem swoich wlasnych funkcji?

ivo_207
Użytkownik
Posty: 26
Rejestracja: 2005-02-17, 15:37
Lokalizacja: Ełk

Re: Instalacja sterowników ATI

Post autor: ivo_207 »

Kiedys tez meczylem sie nad sterownikami Ati do Radeona 9200SE 64MB i powiem jedno: 9200 to szajs jakich malo! Niby wszystko sie instalowalo, bylo spoko, ale jak odpalalem cos co wymagalo wiekszej pracy karty graficznej to nagle ekran sie zawieszal, tylko myszka chodzila. Mowie wam, 9200 to szajs pod Linuksa, sprzedalem go dla ziomka, ktory ma jakas grafe zintegrowana i uzywa windy. Zadowolony chlopak jest, a ja za mniej niz 250 zeta kupilen nowego radeona 9550 256MB 128bit. I teraz na linuksie ta sama metoda instalcji idzie bez zarzutu.

Awatar użytkownika
pralat
Użytkownik
Posty: 51
Rejestracja: 2005-12-02, 09:32
Lokalizacja: Opole

Re: Instalacja sterowników ATI

Post autor: pralat »

Udalo mi sie uruchomic X-y przy uzyciu nowych sterow 8.25 i kernela 2.6.16.18, niestety pojawil sie kolejny problem :(

Kod: Zaznacz cały

(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
(EE) fglrx(0): cannot init AGP
(II) fglrx(0): [drm] removed 1 reserved context for kernel
Teraz tak:
- xorg.conf wygenerowalem za pomoca fglrxconfig
- UseInternalAGPGART = no
- mam zaladowane moduly agpgart (2 uzycia), via_agp (0 uzyc) , fglrx (0 uzyc)
- probowalem sugerowanych opcji w xorg.conf:
- Section "DRI" -> Mode 0666
- "KernelModuleParm" "agplock=0"
- UseFastTLS = 2
- mam "tmpfs on /dev/shm type tmpfs (rw)"
- DRM w kernelu mam wylaczone
- X.org 6.8.2

Nie mam juz pomyslow, co moze byc przyczyna...
Ostatnio zmieniony 2006-05-25, 08:06 przez pralat, łącznie zmieniany 2 razy.

ODPOWIEDZ