Instalacja sterowników ATI

Gdy jakieś urządzenie nie chce w Slackware działać...

Moderatorzy: Moderatorzy, Administratorzy

wujek_czesio
Użytkownik
Posty: 17
Rejestracja: 2005-03-20, 15:01

Re: Instalacja sterowników ATI

Post autor: wujek_czesio »

Jasne, że q3 działa, i gears wyświetlna wszystko elegancko, trudno tu skriny zgrac bo szybko sie obraca i animacja jest :P ale masz 2 zrobilem... Działa płynniutko...

Obrazek
Obrazek

I log z konsoli:
Using GLX_SGIX_pbuffer
6204 frames in 5.0 seconds = 1240.800 FPS
6487 frames in 5.0 seconds = 1297.400 FPS
6645 frames in 5.0 seconds = 1329.000 FPS
6474 frames in 5.0 seconds = 1294.800 FPS
3499 frames in 5.0 seconds = 699.800 FPS
6474 frames in 5.0 seconds = 1294.800 FPS
5932 frames in 6.0 seconds = 988.667 FPS
5219 frames in 5.0 seconds = 1043.800 FPS
Broken pipe
Nic się nie wiesza, chodzi wszystko znakomicie :> Jak znasz program pod linux'a którym mogę zgrać film z animacji opengl to Ci mogę nagrać, jak jeszcze nie wierzysz :P

Fglrx, najnowszy z www.ati.com , czyli ten co wyszedł z cat'ami 6.3 pod windę.. btw. Masz to na skrinie w poprzednim moim poście!! zobacz go, jest i nr. sterów i nr. jajka..

pozdro.
Ostatnio zmieniony 2006-03-16, 14:28 przez wujek_czesio, łącznie zmieniany 2 razy.

miesozer
Użytkownik
Posty: 141
Rejestracja: 2005-04-13, 11:18
Lokalizacja: z wietnamu, hej!
Kontakt:

Re: Instalacja sterowników ATI

Post autor: miesozer »

Nie żebym nie wierzył tylko ciekawi mnie Twoja konfiguracja: najnowszy fglrx to 8.23.7 i moduł kompilowałes z wersji pod x.orga? czy może kombinowałeś coś ze sterami od xfree. I podaj proszę wersje jajka!!!
EDIT: i napisz jeszcze czy robiłeś coś specjalnego, mam na myśli jakieś patche czy inne takie specjalne zabiegi :]
Ostatnio zmieniony 2006-03-16, 14:32 przez miesozer, łącznie zmieniany 1 raz.

wujek_czesio
Użytkownik
Posty: 17
Rejestracja: 2005-03-20, 15:01

Re: Instalacja sterowników ATI

Post autor: wujek_czesio »

No napisałem Ci że masz na skrinie w poprzednim poście!!! nr. sterów 8.23.7, jajko 2.6.15 !! Kurde czytaj moje posty, na skrinie wszystko widać!!. Moduł kompilowałem ze skryptu ATI, nie ściągałem do danej wersji xorg'a, tylko skrypt ATI, wykrywa przy kompilacji xorg 6.9.0 i ładnie się kompiluje :). Życzę powodzenia. Pózniej napiszę dokładne info.

Żadnych specjali nie dawałem, patchy itd. i w tym tkwi poezja, że mi to ślicznie działa :))))
W jajko wkompiluj standardowo
Character devieces [M]->/dev/agpgart
Character devieces [M]->Tutaj dla swojego chipsetu, ja mam NF3 i AMD64(Sempron) więc dałem - AMD Opteron/Athlon64 on-CPU gart support

Graphics support [M]->Vesa Vga
Graphics support [M]->Ati Radeon display support ( ten pod old ).
xorg.conf wygenerowałem przez xorgconfig, jako grafikę moduł grafiki wybrarłem "radeon" czyli nr. 6.

Po wygenerowaniu, zmieniłem "radeon" na "fglrx", odhaszowałem "load dri" ( czyli usunąłem hash :P ) jest on pod "load glx". No i zahashowałem odświeżania poziome i pionowe, żeby mi automatycznie fglrx, wykrył dobrze.

A tutaj mój xorg.conf
# **********************************************************************
# Module section -- this section is used to specify
# which dynamically loadable modules to load.
# **********************************************************************
#
Section "Module"

# This loads the DBE extension module.

Load "dbe" # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection

# This loads the font modules
Load "type1"
# Load "speedo"
Load "freetype"
# Load "xtt"

# This loads the GLX module
Load "glx"
# This loads the DRI module
Load "dri"

EndSection

# **********************************************************************
# Files section. This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"

# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

RgbPath "/usr/X11R6/lib/X11/rgb"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)
#
#

FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/local/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic/"

# The module search path. The default path is shown here.

# ModulePath "/usr/X11R6/lib/modules"

EndSection

# **********************************************************************
# Server flags section.
# **********************************************************************

Section "ServerFlags"

# Uncomment this to cause a core dump at the spot where a signal is
# received. This may leave the console in an unusable state, but may
# provide a better stack trace in the core dump to aid in debugging

# Option "NoTrapSignals"

# Uncomment this to disable the <Ctrl><Alt><Fn> VT switch sequence
# (where n is 1 through 12). This allows clients to receive these key
# events.

# Option "DontVTSwitch"

# Uncomment this to disable the <Ctrl><Alt><BS> server abort sequence
# This allows clients to receive this key event.

# Option "DontZap"

# Uncomment this to disable the <Ctrl><Alt><KP_+>/<KP_-> mode switching
# sequences. This allows clients to receive these key events.

# Option "Dont Zoom"

# Uncomment this to disable tuning with the xvidtune client. With
# it the client can still run and fetch card and monitor attributes,
# but it will not be allowed to change them. If it tries it will
# receive a protocol error.

# Option "DisableVidModeExtension"

# Uncomment this to enable the use of a non-local xvidtune client.

# Option "AllowNonLocalXvidtune"

# Uncomment this to disable dynamically modifying the input device
# (mouse and keyboard) settings.

# Option "DisableModInDev"

# Uncomment this to enable the use of a non-local client to
# change the keyboard or mouse settings (currently only xset).

# Option "AllowNonLocalModInDev"

EndSection

# **********************************************************************
# Input devices
# **********************************************************************

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"

Identifier "Keyboard1"
Driver "kbd"

# For most OSs the protocol can be omitted (it defaults to "Standard").
# When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
# uncomment the following line.

# Option "Protocol" "Xqueue"

Option "AutoRepeat" "500 30"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# Option "LeftAlt" "Meta"
# Option "RightAlt" "ModeShift"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc105"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"

# These are the default XKB settings for Xorg
# Option "XkbRules" "xorg"
# Option "XkbModel" "pc105"
# Option "XkbLayout" "us"
# Option "XkbVariant" ""
# Option "XkbOptions" ""

# Option "XkbDisable"

Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "pl"

EndSection


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2" # IntelliMouse PS/2
Option "Device" "/dev/mouse"

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.

# Option "Protocol" "Xqueue"

# Mouse-speed setting for PS/2 mouse.

# Option "Resolution" "256"

# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.

# Option "BaudRate" "9600"
# Option "SampleRate" "150"

# Mouse wheel mapping. Default is to map vertical wheel to buttons 4 & 5,
# horizontal wheel to buttons 6 & 7. Change if your mouse has more than
# 3 buttons and you need to map the wheel to different button ids to avoid
# conflicts.

Option "ZAxisMapping" "4 5 6 7"

# Emulate3Buttons is an option for 2-button mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)

# Option "Emulate3Buttons"
# Option "Emulate3Timeout" "50"

# ChordMiddle is an option for some 3-button Logitech mice

# Option "ChordMiddle"

EndSection


# **********************************************************************
# Other input device sections
# this is optional and is required only if you
# are using extended input devices. This is for example only. Refer
# to the xorg.conf man page for a description of the options.
# **********************************************************************
#
# Section "InputDevice"
# Identifier "Mouse2"
# Driver "mouse"
# Option "Protocol" "MouseMan"
# Option "Device" "/dev/mouse2"
# EndSection
#
# Section "InputDevice"
# Identifier "spaceball"
# Driver "magellan"
# Option "Device" "/dev/cua0"
# EndSection
#
# Section "InputDevice"
# Identifier "spaceball2"
# Driver "spaceorb"
# Option "Device" "/dev/cua0"
# EndSection
#
# Section "InputDevice"
# Identifier "touchscreen0"
# Driver "microtouch"
# Option "Device" "/dev/ttyS0"
# Option "MinX" "1412"
# Option "MaxX" "15184"
# Option "MinY" "15372"
# Option "MaxY" "1230"
# Option "ScreenNumber" "0"
# Option "ReportingMode" "Scaled"
# Option "ButtonNumber" "1"
# Option "SendCoreEvents"
# EndSection
#
# Section "InputDevice"
# Identifier "touchscreen1"
# Driver "elo2300"
# Option "Device" "/dev/ttyS0"
# Option "MinX" "231"
# Option "MaxX" "3868"
# Option "MinY" "3858"
# Option "MaxY" "272"
# Option "ScreenNumber" "0"
# Option "ReportingMode" "Scaled"
# Option "ButtonThreshold" "17"
# Option "ButtonNumber" "1"
# Option "SendCoreEvents"
# EndSection

# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"

Identifier "720T"

# HorizSync is in kHz unless units are specified.
# HorizSync may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY. REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.

# HorizSync 31.5

# HorizSync 30-64 # multisync
# HorizSync 31.5, 35.2 # multiple fixed sync frequencies
# HorizSync 15-25, 30-50 # multiple ranges of sync frequencies

# VertRefresh is in Hz unless units are specified.
# VertRefresh may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY. REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.

# VertRefresh 50-70

EndSection


# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

# Standard VGA Device:

Section "Device"
Identifier "Standard VGA"
VendorName "Unknown"
BoardName "Unknown"

# The chipset line is optional in most cases. It can be used to override
# the driver's chipset detection, and should not normally be specified.

# Chipset "generic"

# The Driver line must be present. When using run-time loadable driver
# modules, this line instructs the server to load the specified driver
# module. Even when not using loadable driver modules, this line
# indicates which driver should interpret the information in this section.

Driver "vga"
# The BusID line is used to specify which of possibly multiple devices
# this section is intended for. When this line isn't present, a device
# section can only match up with the primary video device. For PCI
# devices a line like the following could be used. This line should not
# normally be included unless there is more than one video device
# intalled.

# BusID "PCI:0:10:0"

# VideoRam 256

# Clocks 25.2 28.3

EndSection

# Device configured by xorgconfig:

Section "Device"
Identifier "X800GTO"
Driver "fglrx"
#VideoRam 262144
# Insert Clocks lines here if appropriate
EndSection


# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present. Each describes
# the configuration of a single screen. A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
Identifier "Screen 1"
Device "X800GTO"
Monitor "720T"
DefaultDepth 24

Subsection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection

# **********************************************************************
# ServerLayout sections.
# **********************************************************************

# Any number of ServerLayout sections may be present. Each describes
# the way multiple screens are organised. A specific ServerLayout
# section may be specified from the X server command line with the
# "-layout" option. In the absence of this, the first section is used.
# When now ServerLayout section is present, the first Screen section
# is used alone.

Section "ServerLayout"

# The Identifier line must be present
Identifier "Simple Layout"

# Each Screen line specifies a Screen section name, and optionally
# the relative position of other screens. The four names after
# primary screen name are the screens to the top, bottom, left and right
# of the primary screen. In this example, screen 2 is located to the
# right of screen 1.

Screen "Screen 1"

# Each InputDevice line specifies an InputDevice section name and
# optionally some options to specify the way the device is to be
# used. Those options include "CorePointer", "CoreKeyboard" and
# "SendCoreEvents".

InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"

EndSection

# Section "DRI"
# Mode 0666
# EndSection
Zdaj relacje czy zadziałało u Ciebie!! :) to może do FAQ pójdzie :P

pozdro.
Ostatnio zmieniony 2006-03-16, 15:08 przez wujek_czesio, łącznie zmieniany 2 razy.

miesozer
Użytkownik
Posty: 141
Rejestracja: 2005-04-13, 11:18
Lokalizacja: z wietnamu, hej!
Kontakt:

Re: Instalacja sterowników ATI

Post autor: miesozer »

Widać nie w sterowniku leży problem, bo na każdym jajku i na każdych sterach mam taki sam efekt - sterownik się kompiluje i ładuje, ale nie działa jak należy. Napisz mi jeszcze Czesiu po co Ci to:

Kod: Zaznacz cały

Graphics support [M]->Vesa Vga
Graphics support [M]->Ati Radeon display support ( ten pod old ).
może daj wynik lsmod by sprawdzić czy Ty tego w ogóle używasz.
Z Twoich postów cieszę się dlatego że przynajmniej dowiedziałem się że to powinno działać bo do tej pory nikt nie dał mi jednoznacznej odpowiedzi czy da się odpalić fglrx na x.orgu 6.9.

Awatar użytkownika
pawian
Użytkownik
Posty: 51
Rejestracja: 2005-05-13, 20:54

Re: Instalacja sterowników ATI

Post autor: pawian »

miesozer pisze:Widać nie w sterowniku leży problem, bo na każdym jajku i na każdych sterach mam taki sam efekt - sterownik się kompiluje i ładuje, ale nie działa jak należy. Napisz mi jeszcze Czesiu po co Ci to:

Kod: Zaznacz cały

Graphics support [M]->Vesa Vga
Graphics support [M]->Ati Radeon display support ( ten pod old ).
może daj wynik lsmod by sprawdzić czy Ty tego w ogóle używasz.
Z Twoich postów cieszę się dlatego że przynajmniej dowiedziałem się że to powinno działać bo do tej pory nikt nie dał mi jednoznacznej odpowiedzi czy da się odpalić fglrx na x.orgu 6.9.
da sie

wujek_czesio
Użytkownik
Posty: 17
Rejestracja: 2005-03-20, 15:01

Re: Instalacja sterowników ATI

Post autor: wujek_czesio »

miesozer pisze:Widać nie w sterowniku leży problem, bo na każdym jajku i na każdych sterach mam taki sam efekt - sterownik się kompiluje i ładuje, ale nie działa jak należy. Napisz mi jeszcze Czesiu po co Ci to:

Kod: Zaznacz cały

Graphics support [M]->Vesa Vga
Graphics support [M]->Ati Radeon display support ( ten pod old ).
może daj wynik lsmod by sprawdzić czy Ty tego w ogóle używasz.
Z Twoich postów cieszę się dlatego że przynajmniej dowiedziałem się że to powinno działać bo do tej pory nikt nie dał mi jednoznacznej odpowiedzi czy da się odpalić fglrx na x.orgu 6.9.
Ati nie potrzebny, dziala bez, mam dla zasady :P Nie wiem czy wydajnosc zwiększa :/
Jakiś framebuffer musisz mieć, więc mam Vese wkompilowaną w jajko a nie moduł... Inaczej jak włączysz FB w Consoli to zobaczy piękny czarny ekran przy włączeniu systemu ponownie, zamiast bootsplasha czy loga ze skryptów startowych...

Spróbuj dokładnie tak jak ja mam... xorg.conf itd.

pozdro.

miesozer
Użytkownik
Posty: 141
Rejestracja: 2005-04-13, 11:18
Lokalizacja: z wietnamu, hej!
Kontakt:

Re: Instalacja sterowników ATI

Post autor: miesozer »

Ręce mi, wurwa jechana nać, opadają!!! :mur: :mur: :mur: :mur: :mur:
Próbowałem rożne kombinacje jajek i fglrxów, powywalałem wszystkie konfigi, skompilowałem sobie swojego własnego x.orga...i mase innych , coraz mniej racjonalnych posunięć i WIELKA DUPA! Wszystko idzie niby gładko, ani instalator, ani uruchamiane programy nie wywalają błędów i nie mam jak szukać pomocy - zawsze pomagało wklejenie błędu w google a teraz nie da rady. Może ktoś mi powie czym sie różnią, z "technicznego punktu widzenia" armagetron i foobilard (które działąją normalnie) od quake'a i fgl_gears (które nie działają!). Może to byłby jakiś trop.
Pozdrawiam

wujek_czesio
Użytkownik
Posty: 17
Rejestracja: 2005-03-20, 15:01

Re: Instalacja sterowników ATI

Post autor: wujek_czesio »

A ja odpaliłem jeszcze fuhquake, czyli q1 podrasowane ;). Smiga jak ta lala :P wypas... Walcz dalej :) ja walczyłem długooooooo :P

miesozer
Użytkownik
Posty: 141
Rejestracja: 2005-04-13, 11:18
Lokalizacja: z wietnamu, hej!
Kontakt:

Re: Instalacja sterowników ATI

Post autor: miesozer »

wujek_czesio pisze:A ja odpaliłem jeszcze fuhquake, czyli q1 podrasowane ;). Smiga jak ta lala :P wypas... Walcz dalej :) ja walczyłem długooooooo :P
To ja też się pochwalę że fuhquake śmiga rewelacyjnie, ale taki tenebrae (inny podrasowany quake pierwszy) już nie - gra się odpala ale gubi teskuty a do tego "śmiga" z zawrotną prędkością 15 fpsów. Znalazłem mój problem na kilku forach* i okazuję się że na tą dolegliuwość cierpią tanie karty typu R9200, R9250 i że problem zaczął się od wersji sterów coś koło 8.18-8.20. I cały problem polega na tym że starsze nie chcą się kompilować po x.orga 6.9 bądź nie działają prawidłowo - jednakże inaczej niż w moim przypadku. Z tego co znalazłem wynika że problem leży w samych sterach i bez uprzejmości panów (a może i pań) z ati nie ma co liczyć na poprawne działanie. Na potwierdzenie tego że problem dotyka kart takich jak 9200 dam przykład kolesia który przy niezmienionej konfiguracji systemu podminił karte z 9200 na 9600 i poszło z miejsca bez problemów.

Pozdrawiam.

* http://ati.cchtml.com/show_bug.cgi?id=232
http://www.rage3d.com/board/showthread. ... 5&posted=1
http://www.rage3d.com/board/showthread.php?p=1334088801

mpier
Użytkownik
Posty: 1002
Rejestracja: 2005-10-01, 13:24
Lokalizacja: Blachownia||Cz-wa
Kontakt:

Re: Instalacja sterowników ATI

Post autor: mpier »

miesozer pisze:Znalazłem mój problem na kilku forach* i okazuję się że na tą dolegliuwość cierpią tanie karty typu R9200, R9250 i że problem zaczął się od wersji sterów coś koło 8.18-8.20
Ty też masz taką kartę? Na moim radeonie 9200SE ze sterownikiem z xorg 6.9 gram (bardzo rzadko) w q3, ale demo q4 nie poszło. Nie mam tam kilkuset kaltek (wiem, lepiej mieć mieć 310 jak 300), ale te niskie kilkadziesiąt w zupełności mi wystarcza, a w atiową kostkę nie gram od dawana ;).

miesozer
Użytkownik
Posty: 141
Rejestracja: 2005-04-13, 11:18
Lokalizacja: z wietnamu, hej!
Kontakt:

Re: Instalacja sterowników ATI

Post autor: miesozer »

mpier pisze:Ty też masz taką kartę? Na moim radeonie 9200SE ze sterownikiem z xorg 6.9 gram (bardzo rzadko) w q3, ale demo q4 nie poszło. Nie mam tam kilkuset kaltek (wiem, lepiej mieć mieć 310 jak 300), ale te niskie kilkadziesiąt w zupełności mi wystarcza, a w atiową kostkę nie gram od dawana ;).
No - mam radeona 9200 na kości RV280.
Nie wiem czemu ale kiedyś próbowałem tych strerów z jądra i przeraziła mnie ich słaba wydajność. Teraz odpaliłem i chodzi to całkiem przyzwoicie: fuhquake i quake3 zupełnie płynnie, armagetrony i inne foobilardy też. Ale to cholerne tenebrae idzie jak krew z nosa, przy 1024 ok 10-15 fpsów. Ale ten quake jest "trochę" bardziej podrasowany niż fuhquake. Czyli póki co zostaję przy sterach z jaja. Dzięki mpier za sugestie.

iGLO
Użytkownik
Posty: 6
Rejestracja: 2006-04-05, 01:37
Kontakt:

Re: Instalacja sterowników ATI

Post autor: iGLO »

Mmam r9000 64MB 128bit sapphire tv-out na rv250. Probowalem kilku kerneli, standardowy-2.4.31, 2.6.15, 2.6.15.7, 2.6.16.1. Probowalem roznych sterownikow 8.18, 8.20.8, 8.23.7. X.org 6.8.2
Na wszystkich jest identycznie. Oprocz tego ostatniego kernela na innych wszystko sie ladnie kompiluje, rendering chodzi, zadnych problemow oprocz fgl_glxgears. Ten szescian jest albo czarny albo niebieski, a powinny byc zebatki :( tuxreacer chodzi, enemy territory za intrem sie wiesza, z Q3 pewnie jest podobnie chociaz nie sprawdzalem.
Zastanawiam sie jeszcze nad starsza wersja X.org'a i starszymi patchowanymi sterownikami ati a jak nie to nvidia.

miesozer
Użytkownik
Posty: 141
Rejestracja: 2005-04-13, 11:18
Lokalizacja: z wietnamu, hej!
Kontakt:

Re: Instalacja sterowników ATI

Post autor: miesozer »

W przypadku x.orga 6.8 da się zrobić tak żeby działało - wszysarczy zainstalować starszego fglrx'a. Mi na 8.12 (paczowanym) chodziło póki nie zrobiłem upgradu systemu do xorga 6.9.

Awatar użytkownika
pawian
Użytkownik
Posty: 51
Rejestracja: 2005-05-13, 20:54

Re: Instalacja sterowników ATI

Post autor: pawian »

iGLO pisze:Mmam r9000 64MB 128bit sapphire tv-out na rv250. Probowalem kilku kerneli, standardowy-2.4.31, 2.6.15, 2.6.15.7, 2.6.16.1. Probowalem roznych sterownikow 8.18, 8.20.8, 8.23.7. X.org 6.8.2
Na wszystkich jest identycznie. Oprocz tego ostatniego kernela na innych wszystko sie ladnie kompiluje, rendering chodzi, zadnych problemow oprocz fgl_glxgears. Ten szescian jest albo czarny albo niebieski, a powinny byc zebatki :( tuxreacer chodzi, enemy territory za intrem sie wiesza, z Q3 pewnie jest podobnie chociaz nie sprawdzalem.
Zastanawiam sie jeszcze nad starsza wersja X.org'a i starszymi patchowanymi sterownikami ati a jak nie to nvidia.
shm masz?

miesozer
Użytkownik
Posty: 141
Rejestracja: 2005-04-13, 11:18
Lokalizacja: z wietnamu, hej!
Kontakt:

Re: Instalacja sterowników ATI

Post autor: miesozer »

Pawian przeczytaj cały temat a będziesz się wtryniał z shm'em. Bez zamontowanego tmpfs glx zachwuje się zupełnie inaczej - system wywala błędy przy próbie odpalenia czegokolwiek 3d. A tu jest tak że niby wszytko działa a nie działa. :\

ODPOWIEDZ