nie dziala otoczenie sieciowe -- nic z forum nie pomoglo

Serwery i sieci oparte na Slackware, wszelkiego rodzaju usługi, troubleshooting.

Moderatorzy: Moderatorzy, Administratorzy

Awatar użytkownika
Karpiu
Użytkownik
Posty: 7
Rejestracja: 2006-10-26, 14:56
Kontakt:

nie dziala otoczenie sieciowe -- nic z forum nie pomoglo

Post autor: Karpiu » 2006-10-29, 20:20

Witam, mam nastepujacy problem: nie dziala mi OTOCZENIE SIECIOWE w Windowsach odkad wszystko puscilem przez dhcp,sambe i iptables na slacku. Przejzalem forum i znalazlem pare tematow niestety nic nie pomoglo (znalazlem np te tematy:ten i i ten) . Dodatkowo w większosci tamatow podaje sie za konieczne zmiany ( np. tutaj ) w ustawieniach windowsa a ja niestety nie moge sobie na to pozwolic. O to moje konfigi:

Kod: Zaznacz cały

# dhcpd.conf 
# 
# Configuration file for ISC dhcpd (see 'man dhcpd.conf') 
# 
     # domena sieci 
     option domain-name "karpinski.waw.pl"; 
     # dynamiczne uaktualnianie DNS 
     ddns-update-style none;
     option domain-name-servers 10.0.0.1; 
     # domyslny czas dzierżawy adresu (sekundy) 
     default-lease-time 86400; 
     # maksymalny czas dzierżawy adresu (sekundy) 
     max-lease-time 86400; 

# adres podsieci ktora obsluguje DHCP 
subnet 10.0.0.0 
# maska podsieci 
netmask 255.255.255.0 
{ 
     # zakres ADRESOW DYNAMICZNYCH przydzielanych przez DHCP 
     range 10.0.0.10 10.0.0.15; 
     # adres rozgloszeniowy sieci 
     option broadcast-address 10.0.0.255; 
     # adres routera/bramy w sieci 
     option routers 10.0.0.1; 
     # adres serwera WINS w sieci 
     option netbios-name-servers 10.0.0.1; 
} 

# deklaracja poszczegolnych stacji roboczych wraz z ich parametrami - dotyczy ADRESOW STATYCZNYCH 

host STACJA_1
{ 
     # adres przetowy (MAC) danego hosta 
     hardware ethernet <mac karty> 
     # adres IP danego hosta 
     fixed-address 10.0.0.2; 
     # adres rozgloszeniowy 
     option broadcast-address 10.0.0.255; 
     # adres ip routera/bramy 
     option routers 10.0.0.1; 
     # adres ip serwera WINS 
     option netbios-name-servers 10.0.0.1; 
}

host STACJA_2
{ 
     # adres przetowy (MAC) danego hosta 
     hardware ethernet <mac karty>
     # adres IP danego hosta 
     fixed-address 10.0.0.3; 
     # adres rozgloszeniowy 
     option broadcast-address 10.0.0.255; 
     # adres ip routera/bramy 
     option routers 10.0.0.1; 
     # adres ip serwera WINS 
     option netbios-name-servers 10.0.0.1; 
} 

Kod: Zaznacz cały

[global]
restrict anonymous = no
preferred master = no
workgroup = Marcin1
server string = Serwer
max protocol = NT
ldap ssl = No
server signing = Auto
map to guest = Bad User
guest ok = yes
local master        = yes
preferred master    = yes
domain master       = yes  
wins support        = yes 
os level            = 65 
encrypt passwords    = yes

Kod: Zaznacz cały

# uruchomienie przekazywania pakietow IP.
echo "1" > /proc/sys/net/ipv4/ip_forward

# wyczyśćmy tablice iptables odpowiedzialne za nat i za filtrowanie pakietów:

iptables -F -t nat
iptables -X -t nat
iptables -F -t filter
iptables -X -t filter
iptables -F POSTROUTING -t nat

# Domyślnie odrzucamy i nie zezwalany na forwardowanie pakietów

iptables -t filter -P FORWARD DROP
iptables -P OUTPUT ACCEPT
iptables -P INPUT ACCEPT

# Zezwalamy na by serwer przepuszczał pakiety które pochodzą z naszej sieci
# lokalnej lub są dla niej przeznaczone.

iptables -t filter -A FORWARD -s 10.0.0.0/255.255.255.0 -d 0/0 -j ACCEPT
iptables -t filter -A FORWARD -s 0/0 -d 10.0.0.0/255.255.0.0 -j ACCEPT

iptables -A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT 
iptables -A FORWARD -p tcp -m state --state ESTABLISHED,RELATED -j ACCEPT 
iptables -A FORWARD -p udp -m state --state ESTABLISHED,RELATED -j ACCEPT 
iptables -A FORWARD -p icmp -m state --state ESTABLISHED,RELATED -j ACCEPT

# Teraz nakazujemy by wszystkie pakiety pochodzące z lanu były maskowane

iptables -t nat -A POSTROUTING -s 10.0.0.0/16 -d 0/0 -j MASQUERADE

iptables -A INPUT -s 0.0.0.0/0 -i eth0 -p tcp --dport 27017 -j ACCEPT
iptables -A FORWARD -s 0.0.0.0/0 -i eth0 -p tcp --dport 27017 -j ACCEPT
iptables -A PREROUTING -t nat -p tcp -i eth0 --dport 27017 -j DNAT --to 10.0.0.3:27017
iptables -A INPUT -s 0.0.0.0/0 -i eth0 -p udp --dport 27017 -j ACCEPT
iptables -A FORWARD -s 0.0.0.0/0 -i eth0 -p udp --dport 27017 -j ACCEPT
iptables -A PREROUTING -t nat -p tcp -i eth0 --dport 27017 -j DNAT --to 10.0.0.3:27017

iptables -A INPUT -s 0.0.0.0/0 -i eth0 -p tcp --dport 4712 -j ACCEPT
iptables -A FORWARD -s 0.0.0.0/0 -i eth0 -p tcp --dport 4712 -j ACCEPT
iptables -A PREROUTING -t nat -p tcp -i eth0 --dport 4712 -j DNAT --to 10.0.0.2:4712
iptables -A INPUT -s 0.0.0.0/0 -i eth0 -p udp --dport 4712 -j ACCEPT
iptables -A FORWARD -s 0.0.0.0/0 -i eth0 -p udp --dport 4712 -j ACCEPT
iptables -A PREROUTING -t nat -p udp -i eth0 --dport 4712 -j DNAT --to 10.0.0.2:4712

iptables -A INPUT -s 0.0.0.0/0 -i eth0 -p tcp --dport 4661 -j ACCEPT
iptables -A FORWARD -s 0.0.0.0/0 -i eth0 -p tcp --dport 4661 -j ACCEPT
iptables -A PREROUTING -t nat -p tcp -i eth0 --dport 4661 -j DNAT --to 10.0.0.2:4661
iptables -A INPUT -s 0.0.0.0/0 -i eth0 -p tcp --dport 4662 -j ACCEPT
iptables -A FORWARD -s 0.0.0.0/0 -i eth0 -p tcp --dport 4662 -j ACCEPT
iptables -A PREROUTING -t nat -p tcp -i eth0 --dport 4662 -j DNAT --to 10.0.0.2:4662

iptables -A INPUT -s 0.0.0.0/0 -i eth0 -p tcp --dport 4711 -j ACCEPT
iptables -A FORWARD -s 0.0.0.0/0 -i eth0 -p tcp --dport 4711 -j ACCEPT
iptables -A PREROUTING -t nat -p tcp -i eth0 --dport 4711 -j DNAT --to 10.0.0.2:4711
iptables -A INPUT -s 0.0.0.0/0 -i eth0 -p udp --dport 4711 -j ACCEPT
iptables -A FORWARD -s 0.0.0.0/0 -i eth0 -p udp --dport 4711 -j ACCEPT
iptables -A PREROUTING -t nat -p udp -i eth0 --dport 4711 -j DNAT --to 10.0.0.2:4711

iptables -A INPUT -s 0.0.0.0/0 -i eth0 -p udp --dport 4665 -j ACCEPT
iptables -A FORWARD -s 0.0.0.0/0 -i eth0 -p udp --dport 4665 -j ACCEPT
iptables -A PREROUTING -t nat -p udp -i eth0 --dport 4665 -j DNAT --to 10.0.0.2:4665
iptables -A INPUT -s 0.0.0.0/0 -i eth0 -p udp --dport 4672 -j ACCEPT
iptables -A FORWARD -s 0.0.0.0/0 -i eth0 -p udp --dport 4672 -j ACCEPT
iptables -A PREROUTING -t nat -p udp -i eth0 --dport 4672 -j DNAT --to 10.0.0.2:4672

iptables -A INPUT -s 0.0.0.0/0 -i eth0 -p tcp --dport 80 -j ACCEPT
iptables -A FORWARD -s 0.0.0.0/0 -i eth0 -p tcp --dport 80 -j ACCEPT
iptables -A PREROUTING -t nat -p tcp -i eth0 --dport 80 -j DNAT --to 10.0.0.2:80
iptables -A INPUT -s 0.0.0.0/0 -i eth0 -p udp --dport 80 -j ACCEPT
iptables -A FORWARD -s 0.0.0.0/0 -i eth0 -p udp --dport 80 -j ACCEPT
iptables -A PREROUTING -t nat -p udp -i eth0 --dport 80 -j DNAT --to 10.0.0.2:80

iptables -A INPUT -s 0.0.0.0/0 -i eth0 -p tcp --dport 1550 -j ACCEPT
iptables -A FORWARD -s 0.0.0.0/0 -i eth0 -p tcp --dport 1550 -j ACCEPT
iptables -A PREROUTING -t nat -p tcp -i eth0 --dport 1550 -j DNAT --to 10.0.0.2:1550
iptables -A INPUT -s 0.0.0.0/0 -i eth0 -p udp --dport 1550 -j ACCEPT
iptables -A FORWARD -s 0.0.0.0/0 -i eth0 -p udp --dport 1550 -j ACCEPT
iptables -A PREROUTING -t nat -p udp -i eth0 --dport 1550 -j DNAT --to 10.0.0.2:1550

iptables -A INPUT -p udp -m udp --dport 137 -j ACCEPT
iptables -A INPUT -p udp -m udp --dport 138 -j ACCEPT
iptables -A INPUT -m state --state NEW -m tcp -p tcp --dport 139 -j ACCEPT
iptables -A INPUT -m state --state NEW -m tcp -p tcp --dport 445 -j ACCEPT

# I doładujmy moduł do obsługi ftp i irc (moduł do irca zauważyłem dopiero
# w kernelu 2.4.14 dlatego się w końcu za niego wziąłem

/sbin/modprobe ip_nat_ftp
/sbin/modprobe ip_nat_irc

Co jest nie tak ?? Dodam ze wolabym nie tworzyc listy wszystkich kompów w sieci bo czesto wpada ktos z laptopem z zewnatrz i wolabym zeby odrazu z automatu znalazl sie w otoczeniu. Dodam jeszcez ze wywalnia po IP działają bez problemu natomiast po nazwach juz nie.

Pozdro
Ostatnio zmieniony 2006-10-29, 20:25 przez Karpiu, łącznie zmieniany 2 razy.

Awatar użytkownika
Skyscraper
Administrator
Posty: 753
Rejestracja: 2004-05-22, 10:46
Lokalizacja: Wrocław
Kontakt:

Re: nie dziala otoczenie sieciowe -- nic z forum nie pomoglo

Post autor: Skyscraper » 2006-10-30, 18:21

Zagladales do FAQ ?

Awatar użytkownika
Karpiu
Użytkownik
Posty: 7
Rejestracja: 2006-10-26, 14:56
Kontakt:

Re: nie dziala otoczenie sieciowe -- nic z forum nie pomoglo

Post autor: Karpiu » 2006-10-30, 21:18

Jasne, że tak! Posiłkuje sie artykułami podczas konfiguracji wszystkiego. Na wszelki wypadek przejzalem je jeszcze raz i nie znalazlem nic co rozwiazywalo by moj problem.

Znalazlem informacje o potrzebie przekierowania odpowiednich portow (oczywscie sprawdzilem ten trop), znalazlem info jak zrobic aby samba byla serwerem wins (to takze nie pomoglo). Oczywiscie probowalm tez sybioz kilku sposobow i mimo wszystko nie dziala. Stad pytanie. Specjalnie wkleilem configi zeby mozliwe bylo znalezienie zrodla problemu.
Jesli cokolwiek pominalem to prosze wskaz chociaz droge :) a ja juz postaram sie ja pokonac.

Awatar użytkownika
Skyscraper
Administrator
Posty: 753
Rejestracja: 2004-05-22, 10:46
Lokalizacja: Wrocław
Kontakt:

Re: nie dziala otoczenie sieciowe -- nic z forum nie pomoglo

Post autor: Skyscraper » 2006-10-30, 21:24

Jakie są objawy bo wyłączeniu firewalla?
czyli domyslnie polityka na wszystkich łancuchach = ACCEPT

Awatar użytkownika
Karpiu
Użytkownik
Posty: 7
Rejestracja: 2006-10-26, 14:56
Kontakt:

Re: nie dziala otoczenie sieciowe -- nic z forum nie pomoglo

Post autor: Karpiu » 2006-10-30, 21:33

Po dlugie walce udalo ! Problem nie lezal po stronie serwera tylko po stronie klientów. Zmylil mnie fakt ze wszystko popsulo sie po przejsciu na iptables sambe i dhcp.
Ostatnio zmieniony 2006-10-30, 23:46 przez Karpiu, łącznie zmieniany 2 razy.

ODPOWIEDZ