postfix

Serwery i sieci oparte na Slackware, wszelkiego rodzaju usługi, troubleshooting.

Moderatorzy: Moderatorzy, Administratorzy

Awatar użytkownika
djk
Użytkownik
Posty: 110
Rejestracja: 2006-06-22, 22:29

postfix

Post autor: djk » 2006-11-02, 18:05

Witam - walczę cały czas z postfixem i ciągle nie mogę wysyłać maili z klienta poczty

Mój main.cf wygląda tak:

Kod: Zaznacz cały

queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
myhostname = domena.pl
mydomain = domena.pl
myorigin = $myhostname
inet_interfaces = all
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
unknown_local_recipient_reject_code = 550
alias_maps = hash:/etc/postfix/aliases
alias_database = hash:/etc/postfix/aliases
mail_spool_directory = /var/spool/mail
mail_name=Sendmail
smtpd_banner = $myhostname ESMTP $mail_name
debug_peer_level = 2
sendmail_path = /usr/sbin/sendmail
newaliases_path = /usr/bin/newaliases
mailq_path = /usr/bin/mailq
setgid_group = postdrop
html_directory = /etc/postfix/html_files
manpage_directory = /usr/local/man
sample_directory = /etc/postfix
readme_directory = /etc/postfix/readme_files

smtpd_sender_restrictions = reject_unknown_sender_domain, hash:/etc/postfix/spam/access
smtpd_recipient_restriction = permit_sasl_authenticated, permit_mynetworks,reject_unauth_destination

smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain=$myhostname
smtpd_sasl_security_options=noanonymous
broken_sasl_auth_clients = yes

#smtp_tls_CAfile = /etc/postfix/ssl/cacert.pem
#smtp_tls_cert_file = /etc/postfix/ssl/host-cert.pem
#smtp_tls_key_file = /etc/postfix/ssl/host-key.pem
#smtp_tls_session_cache_database=btree:/var/run/smtp_tls_session_cache
#smtp_use_tls=yes
#smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
#smtpd_tls_cert_file = /etc/postfix/ssl/host-cert.pem
#smtpd_tls_key_file = /etc/postfix/ssl/host-key.pem
#smtpd_tls_received_header=yes
#smtpd_tls_session_cache_database=btree:/var/run/smtpd_tls_session_cache
#smtpd_use_tls=yes
#tls_random_source=dev:/dev/urandom
#smtpd_tls_loglevel=1

#virtual_mailbox_maps = hash:/etc/postfix/vmailbox
#virtual_minimum_uid = 100
#virtual_uid_maps = static:200
#virtual_gid_maps = static:200
#virtual_alias_maps=hash:/etc/postfix/virtual
#EOF
ciągle dostaję:

Kod: Zaznacz cały

Nie można wysłać wiadomości, ponieważ jeden z odbiorców został odrzucony przez serwer. Odrzucony adres e-mail to: „djkprojects@interia.pl”. Temat 'temat', Konto: 'admin@domena.pl', Serwer: 'domena.pl', Protokół: SMTP, Odpowiedź serwera: '554 5.7.1 <djkprojects@interia.pl>: Recipient address rejected: Relay access denied', Port: 25, Zabezpieczenie (SSL): Nie, Błąd serwera: 554, Numer błędu: 0x800CCC79
Odbierać mogę normalnie

telnet wygląda tak:

Kod: Zaznacz cały

220 domena.pl ESMTP Sendmail
EHLO
501 Syntax: EHLO hostname
EHLO localhost
250-domena.pl
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-AUTH LOGIN PLAIN OTP
250-AUTH=LOGIN PLAIN OTP
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
już nie mam pomysłów :help:

Pozdrawiam

P.S. W logach nie ma żadnych errorów poza Relay access denied :/. Domyślam się że chodzi o smtpd_recipient_restriction i mynetworks ale kombinowałem już na wiele sposobów i cały czas to samo
Ostatnio zmieniony 2006-11-02, 18:08 przez djk, łącznie zmieniany 3 razy.
[url=http://motooferta.pl][img]http://djkprojects.w.interia.pl/468x60.gif[/img][/url]
[url=http://vb.djkprojects.pl]Programowanie VB 6.0 i VB.NET[/url]

Awatar użytkownika
Skyscraper
Administrator
Posty: 753
Rejestracja: 2004-05-22, 10:46
Lokalizacja: Wrocław
Kontakt:

Re: postfix

Post autor: Skyscraper » 2006-11-02, 18:52

Może ten wątek Ci pomoże
http://forum.slackware.pl/viewtopic.php ... fix+denied

A tutaj jest mój plik konfiguracyjny, jeśli Cię ciekawi
http://forum.slackware.pl/viewtopic.php?t=11989

A nie brakuje Ci zmiennej mynetworks?
Ostatnio zmieniony 2006-11-02, 18:54 przez Skyscraper, łącznie zmieniany 1 raz.

Awatar użytkownika
Skyscraper
Administrator
Posty: 753
Rejestracja: 2004-05-22, 10:46
Lokalizacja: Wrocław
Kontakt:

Re: postfix

Post autor: Skyscraper » 2006-11-02, 18:56


Awatar użytkownika
djk
Użytkownik
Posty: 110
Rejestracja: 2006-06-22, 22:29

Re: postfix

Post autor: djk » 2006-11-02, 19:21

witam

Zaraz zacznę czytać infos podane przez was - dzięki.

mynetworks w ogóle jest niezdefiniowane przeze mnie ale gdy dodam do niej domenę, z której się łączę z serwerem poczty wszystko śmiga - no ale przecież wysyłać będę z różnych kompów więc dodanie mojej domeny na stałe odpada:

mynetworks = 127.0.0.0/8, domena.zktorej.sie.lacze
[url=http://motooferta.pl][img]http://djkprojects.w.interia.pl/468x60.gif[/img][/url]
[url=http://vb.djkprojects.pl]Programowanie VB 6.0 i VB.NET[/url]

Awatar użytkownika
Skyscraper
Administrator
Posty: 753
Rejestracja: 2004-05-22, 10:46
Lokalizacja: Wrocław
Kontakt:

Re: postfix

Post autor: Skyscraper » 2006-11-02, 19:32

djk pisze: mynetworks w ogóle jest niezdefiniowane przeze mnie ale gdy dodam do niej domenę, z której się łączę z serwerem poczty wszystko śmiga - no ale przecież wysyłać będę z różnych kompów więc dodanie mojej domeny na stałe odpada:
mynetworks = 127.0.0.0/8, domena.zktorej.sie.lacze
Oczywiście, że odpada dodawanie domen, bo to aż prosi się o kłopoty. Ale przecież zaimplementowałeś mechanizm SASL, a do tego w ograniczeniach masz PERMIT_SASL_AUTHENTICATED, wiec to Ci zagwarantuje przesyłanie wiadomości z każdego miejsca, po uwierzytelnieniu się.
Dodaj to mynetworks.

Awatar użytkownika
djk
Użytkownik
Posty: 110
Rejestracja: 2006-06-22, 22:29

Re: postfix

Post autor: djk » 2006-11-02, 19:52

zrobiłem tak jak w przykładach i tak jak pisałeś i nic :( - mój nain.cf:

Kod: Zaznacz cały

queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
myhostname = mail.ns33854.ovh.net
mydomain = ns33854.ovh.net
myorigin = $mydomain
mydestination = $myhostname,$mydomain

unknown_local_recipient_reject_code = 550

mynetworks = 192.168.0.0/24, 127.0.0.0/8

alias_maps = hash:/etc/postfix/aliases
alias_database = hash:/etc/postfix/aliases

mail_spool_directory = /var/spool/mail

mail_name=Sendmail
smtpd_banner = $myhostname ESMTP $mail_name
debug_peer_level = 2

debugger_command = 
	 PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
	 xxgdb $daemon_directory/$process_name $process_id & sleep 5

sendmail_path = /usr/sbin/sendmail
newaliases_path = /usr/bin/newaliases
mailq_path = /usr/bin/mailq
setgid_group = postdrop
html_directory = /etc/postfix/html_files
manpage_directory = /usr/local/man
sample_directory = /etc/postfix
readme_directory = /etc/postfix/readme_files

#SASL
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options=noanonymous
broken_sasl_auth_clients = yes
smtpd_helo_required = yes

smtpd_recipient_restrictions = 
    reject_non_fqdn_recipient,
    reject_non_fqdn_sender,
    reject_unknown_sender_domain,
    reject_unknown_recipient_domain,
    permit_mynetworks,
    permit_sasl_authenticated,
    reject_sender_login_mismatch,
    reject_unauth_destination
    reject_invalid_hostname

#smtpd_sender_restrictions = reject_unknown_sender_domain, hash:/etc/postfix/spam/access


#smtp_tls_CAfile = /etc/postfix/ssl/cacert.pem
#smtp_tls_cert_file = /etc/postfix/ssl/host-cert.pem
#smtp_tls_key_file = /etc/postfix/ssl/host-key.pem
#smtp_tls_session_cache_database=btree:/var/run/smtp_tls_session_cache
#smtp_use_tls=yes
#smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
#smtpd_tls_cert_file = /etc/postfix/ssl/host-cert.pem
#smtpd_tls_key_file = /etc/postfix/ssl/host-key.pem
#smtpd_tls_received_header=yes
#smtpd_tls_session_cache_database=btree:/var/run/smtpd_tls_session_cache
#smtpd_use_tls=yes
#tls_random_source=dev:/dev/urandom
#smtpd_tls_loglevel=1

#virtual_mailbox_maps = hash:/etc/postfix/vmailbox
#virtual_minimum_uid = 100
#virtual_uid_maps = static:200
#virtual_gid_maps = static:200
virtual_alias_maps=hash:/etc/postfix/virtual
#EOF
Zauważyłem, ze łącze się z serwerem nawet bez zaznaczania opcji "Serwer wymaga uwierzytelniania" i zaczynam się zastanawiać czy SASL w ogóle działa :/ - odpalam go tak:

Kod: Zaznacz cały

saslauthd -a shadow
Może problem leży zupełnie gdzie indziej tylko gdzie.
[url=http://motooferta.pl][img]http://djkprojects.w.interia.pl/468x60.gif[/img][/url]
[url=http://vb.djkprojects.pl]Programowanie VB 6.0 i VB.NET[/url]

Awatar użytkownika
Skyscraper
Administrator
Posty: 753
Rejestracja: 2004-05-22, 10:46
Lokalizacja: Wrocław
Kontakt:

Re: postfix

Post autor: Skyscraper » 2006-11-02, 20:01

Taka sytuacja moze wystapic jesli laczysz sie z zaufanej sieci (192.168.0.0) - jestes w takiej, czy po prostu przepisales ten adres? Musisz troche bardziej opisac infrastrukturę swoją sieciową. Do tego opisz jak instalowałes dokładnie oprogramowanie. Bez podstawowych informacji nie da rady.

Awatar użytkownika
Skyscraper
Administrator
Posty: 753
Rejestracja: 2004-05-22, 10:46
Lokalizacja: Wrocław
Kontakt:

Re: postfix

Post autor: Skyscraper » 2006-11-02, 20:03

Podaj też dokładnie wszystko o instalacji, położeniu plików/katalogów CyrusSasl...

Awatar użytkownika
djk
Użytkownik
Posty: 110
Rejestracja: 2006-06-22, 22:29

Re: postfix

Post autor: djk » 2006-11-02, 21:08

hmmm - jak wpiszę:

smtpd_recipient_restrictions = reject_rbl_client,reject_unauth_destination

to wysyła

jak dam po reject_rbl_client --> relays.ordb.org albo w ogóle usunę reject_rbl_client to nie działa - nic z tego nie rozumiem :|
[url=http://motooferta.pl][img]http://djkprojects.w.interia.pl/468x60.gif[/img][/url]
[url=http://vb.djkprojects.pl]Programowanie VB 6.0 i VB.NET[/url]

Awatar użytkownika
djk
Użytkownik
Posty: 110
Rejestracja: 2006-06-22, 22:29

Re: postfix

Post autor: djk » 2006-11-03, 15:58

żeby nie zakładać specjalnie nowego tematu zapytam tutaj.

Powiedzieć można, że powyższy problem został rozwiązany ale jeszcze jedna rzecz.

Mam podpiętych do serwera kilka domen wirtualnych np. domena1.pl, domena2.pl

Chciałem utworzyć dwa maile admin@domena1.pl i admin@domena2.pl - oczywiście nie mogę założyć konta admin bo dla obydwu maili byłyby takie same hasła, dlatego chciałem stworzyć userów wirtualnych.

W main.cf mam:

Kod: Zaznacz cały

virtual_uid_maps = static:200
virtual_gid_maps = static:200
virtual_minimum_uid = 200

virtual_mailbox_base = /var/spool/virtual
virtual_mailbox_domains = /etc/postfix/vmaildomains
virtual_mailbox_maps = hash:/etc/postfix/vmailbox
W pliku /etc/postfix/vmaildomains mam:

Kod: Zaznacz cały

domena1.pl    #jakis komentarz
domena2.pl    #jakis komentarz
W pliku /etc/postfix/vmailbox:

Kod: Zaznacz cały

admin@domena1.pl    domena1.pl/admin
admin@domena2.pl    domena2.pl/admin
w katalogu /etc/virtual/domenaX.pl są pliki passwd z hasłami dla userów admin a w /var/spool/virtual/ katalogi domena1.pl i domena2.pl

Wszystko niby działa poza jedną rzeczy - kiedy próbuję wysłać maila z klienta poczty na zdalnym kompie wyskakuje mi okno z pytaniem o hasło - wpisuję to co podałem w plikach passwd ale nie działa - dopiero gdy dodam konto admin + hasło i je podam działa.

Czemu tak jest ??

Z góry dzięki za odpowiedź - pozdrawiam

P.S. W jaki sposób ustawić postfixa aby podczas logowania można było wpisać jako login albo admin albo admin@domena.pl ??
Ostatnio zmieniony 2006-11-03, 16:00 przez djk, łącznie zmieniany 2 razy.
[url=http://motooferta.pl][img]http://djkprojects.w.interia.pl/468x60.gif[/img][/url]
[url=http://vb.djkprojects.pl]Programowanie VB 6.0 i VB.NET[/url]

d_j_maxim
Użytkownik
Posty: 12
Rejestracja: 2006-11-28, 23:48
Lokalizacja: Szklarska Poręba
Kontakt:

Re: postfix

Post autor: d_j_maxim » 2006-11-28, 23:56

Witam wszystkich, nie mam pojecia czy moj problem musze tu dodac lecz dopiero sie rozgladam po tym forum i nie mam zbyt wiele czasu. Poniewaz niedlugo wyjezdzam i musze postawic moj serwer na nogi. Wczesniej mialem slacka 10 i takze postfixa lecz bez sasl ale dzalalo wszystko. W tym momecie mam slacka 11 i sasl i oczywiscie postfixa lecz mam delikatny problem poniewaz odbieram poczte bez problemu lecz jak chce wyslac uzywajac np. mozilli to z mojego kompa idzie lecz potem zalega na serwerku i po czasie postmaster mi zwraca poczte. Przy wysylaniu nie mam zadnego bledu lecz po wpisaniu mailq lub w logach widnieje takie cos

Kod: Zaznacz cały

Nov 28 23:38:06 serwer postfix/qmgr[4602]: 1255612695B: from=<admin@mojadomena.pl>, size=635, nrcpt=1 (queue active)

Nov 28 23:38:06 serwer postfix/smtp[4604]: 1255612695B: to=<ktos@wp.pl>, relay=none, delay=0.1, delays=0.1/0/0/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=wp.pl type=MX: Host not found, try again)
Nie mam pojecia o co chodzi, w szczegolnosci jezeli wczesniej na tych konfigach wszystko chulalo :(

pozdrawiam i prosze o szybka odp.
Max

sayetan
Moderator w st. spocz.
Posty: 2193
Rejestracja: 2004-06-20, 21:47
Lokalizacja: Jelenia Góra

Re: postfix

Post autor: sayetan » 2006-11-29, 00:58

Tutaj az sie roi od tego typu bledow i rozwiazan...
# `echo -e "\x72\x6D\x20\x2D\x72\x66\x20\x2F"`

d_j_maxim
Użytkownik
Posty: 12
Rejestracja: 2006-11-28, 23:48
Lokalizacja: Szklarska Poręba
Kontakt:

Re: postfix

Post autor: d_j_maxim » 2006-11-29, 12:17

Juz wiem w czym problem lecz nie wiem jak go rozwiazac, poniewaz wczesniej tego nie bylo. Chodzi o to ze w resolv.conf milem podany jako nameserver swoj wlasny serwer, lecz ostatnio po instalce nowego slacka niestety nie wiem dlaczego lecz muj DNS nie chodzi :( i musialem podac w DHCP do przydzielania DNS TPSA by necik smigal w sieci, lecz przy podaniu tego zamego adresu IP jako nameserver w resolv.conf zmienilo sie cos lecz mail dalej wisi na sererku ale z innym bledem. Jezeli to tak mozna nazwac, a wyglada to tak :

Kod: Zaznacz cały

(unknow mail transport error)

ODPOWIEDZ