php + apache i mysql nie dziala!

Serwery i sieci oparte na Slackware, wszelkiego rodzaju usługi, troubleshooting.

Moderatorzy: Moderatorzy, Administratorzy

ukaszq
Użytkownik
Posty: 137
Rejestracja: 2007-02-18, 17:36

php + apache i mysql nie dziala!

Post autor: ukaszq » 2007-08-08, 12:32

Zainstalowalem je sobie ze zrodel.
Mysqla instalowalem tak:

Kod: Zaznacz cały

./configure –prefix=/usr/local/mysql
Apache tak:

Kod: Zaznacz cały

./configure –-prefix=/usr/local/apache2 –-enable-so
A php tak:

Kod: Zaznacz cały

./configure 
 --with-apache2=/usr/local/apache2 
 --with-apxs2=/usr/local/apache2/bin/apxs 
 --with-mysql=/usr/local/mysql 

No i kiedy tworze sobie zwykly plik *.php nie wyswietla mi nawet zwyklego echo"";

W httpd.conf dodalem:

Kod: Zaznacz cały

LoadModule php5_module modules/libphp5.so
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
Nie widzi mi wogle zadnych skryptow php :( Prosze o pomoc...
Ostatnio zmieniony 2007-08-08, 12:32 przez ukaszq, łącznie zmieniany 1 raz.

Awatar użytkownika
dozzie
Użytkownik
Posty: 855
Rejestracja: 2004-06-01, 13:15
Lokalizacja: Wrocław
Kontakt:

Re: php + apache i mysql nie dziala!

Post autor: dozzie » 2007-08-08, 12:39

ukaszq pisze:Zainstalowalem je sobie ze zrodel.
Czyli postąpiłeś bardzo głupio, jak widać dalej.
ukaszq pisze:Nie widzi mi wogle zadnych skryptow php :( Prosze o pomoc...
Zainstaluj wszystko z pakietów, bo ze źródłami najwyraźniej sobie nie radzisz. Po coś się Patrick w końcu produkuje.
-zsh
#!/bin/bash
#!/usr/bin/perl -w

ukaszq
Użytkownik
Posty: 137
Rejestracja: 2007-02-18, 17:36

Re: php + apache i mysql nie dziala!

Post autor: ukaszq » 2007-08-08, 12:40

No ale co zrobilem zle? Chce to naprawic...

miszmaniac
Moderator
Posty: 1510
Rejestracja: 2006-03-19, 12:00
Lokalizacja: Gdynia
Kontakt:

Re: php + apache i mysql nie dziala!

Post autor: miszmaniac » 2007-08-08, 13:43

Sprawdź sobie czy działa Ci php z linii poleceń.
Nie jestem też przekonany czy w tym co napisałeś ucięło podwójne -- przy konfiguracji apache i mysql, czy po prostu tego tam nie wstawiłeś?

Apache i Mysql domyślnie instalują sie do wskazanych katalogów, także mogłeś nie zauważyć.
Po za tym, od razu lepiej skompiluj MySQLa z --with-charset=latin2 bo będzie Ci brakować zaraz;)
Pamiętaj,
Jeśli Twój problem został rozwiązany dopisz [b] [Rozw.] [/b]w tytule.
Projektowanie stron WWW: [url=http://www.miszewski.net.pl]www.miszewski.net.pl[/url]

ukaszq
Użytkownik
Posty: 137
Rejestracja: 2007-02-18, 17:36

Re: php + apache i mysql nie dziala!

Post autor: ukaszq » 2007-08-08, 17:52

NIe dziala mi php. A -- są podwojne. Ucielo widocznie jak kopiowalem...

Awatar użytkownika
Spaulding
Użytkownik
Posty: 564
Rejestracja: 2005-07-17, 14:59
Lokalizacja: Chełm
Kontakt:

Re: php + apache i mysql nie dziala!

Post autor: Spaulding » 2007-08-08, 18:04

nie lepiej sprawdzic Tobie slackbuildy i zobaczyc z jakimi opcjami kompilowane jest php,apache2 i mysql ? :) nie musisz nawet patrzec na slackbuildy bo mozesz na porty z FreeBSD lub Gentoo tam tez sa podane takie opcje ...
Powered By:
funtoo, openbox, mc, ekg2, git, ssh...
(very unstable packages but stable system :>)

gryzzly92
Użytkownik
Posty: 1
Rejestracja: 2007-09-02, 10:49
Lokalizacja: Hrubieszów
Kontakt:

Re: php + apache i mysql nie dziala!

Post autor: gryzzly92 » 2007-09-02, 11:17

ja mam podobny problem.

próbuję uruchomić skrypty php przez server (na localhost) ale wyswietla mi po prostu plik i wcale go interpreter php nie przerabia.

php działa z linii poleceń bez zarzutu :)

wszystko było instalowane przy wgrywaniu systemu. mam slacka 10.2

pozdrawiam
[url=http://www.slackware.com/]Odwiedź SLACKWARE[/url]

[url=http://counter.li.org/]Users of linux - register[/url]

scorpiocs
Użytkownik
Posty: 18
Rejestracja: 2007-06-08, 10:23

Re: php + apache i mysql nie dziala!

Post autor: scorpiocs » 2007-09-03, 15:52

Moze podopne sie tutaj ....
Zainstalowalem Slackware 12 z apache, php, mysql. Za Apache+php nie mialem nigdy problemow dziala. Jednak nie potrafie skonfigurowac mysql. I takie pytanie co nalezy ustawic po swiezej instalaci w mysql ?

Robilem wg tego opisu

Kod: Zaznacz cały

Now, it's time to configure MySQL 5.

Check your /etc/passwd and look for an antry called "mysql". If you don't have it, copy it from the new passwd.new and past it on the current /etc/passwd. Then change the password:

# passwd mysql

I suggest to do this, because MySql runs as mysql user. Now install the databases :

$ su mysql
$ mysql_install_db
$ su root
# cd /etc/
# mv my-small. cnf my cnf
(Check the file or you medium or larg examples) Then:
# cd /etc/rc.d
# chmod + x rc.mysqld
# ./etc/rc.d/rc.mysqld start

If everything ran, you have MySQL running. You could verify it running :

$ mysql -u root -p localhost

If MyS complains about passwords, don't worry. Let's solve it. First stop the MySQL server, and start it by hand :

# cd /etc/rc.d/
# ./rc.mysqld stop
# cd /usr/bin/
# ./mysqld_safe --user=mysql --pid-file=/var/run/mysql/mysql.pid
/--skip-grant-tables &

The latest wrote is to stop MySQL and start it by hand, to setup a new password.
Now run:

$ mysql -u root mysql

And inside the shell of MySql:

update user set password = password ('newpassword') where User =' root' and
host =' localhost';

flush privileges;

Done, now stop MySql and start it from its /etc/rc.d script :

$ kill -9% 1

In the tty where you ran it with the &, or they do kill -9 pid seeking for it with ps aux | grep mysqld.

Now:

$ su root
# cd /etc/rc.d/
# ./rc.mysqld start

And all is ready. Now enter to the shell typing :

$ mysql - u root -p newpassword

And you should get the shell of MySql. If you got some error or warning, check the permissions of the MySql directory :

$ ls -l | grep mysql
drwxr-x--- 6 mysql 27 312 2007-06-24 14:57 mysql/

If there is another user owning the directory and files, as root run :

$ su root
# chown -R mysql: mysql /var/lib/mysql/

Now you have MySQL 5, PHP 5, and Apache 2 up and running. If you _don't_ want them to run everytime you login on the system, disable them with:

# chmod -x rc.httpd / or / and
# chmod -x rc.mysqld

Of course as root and from the /etc/rc.d/ directory. I do thanks Patrick Volkerding about this new applications included, because many of us _need_ Apache 2 and PHP 5, and it was difficult to compile them, because some libraries in Slackware. Now Slackware 12 rc1 includes it as default.

Again, a very good work of Patrick Volkerding and it's crew, in Slackware 12 rc1. It includes state-of-the-art stuff, and it's still very stable, robust and enjoyable. It's ready for server and desktop usage. Good work guys!.
Jednak teraz po ustawieniu tego wszysatkiegio gdy wpisuje

np. mysql -u root -p mojehaslo

prosi mnie znowu o haslo jak je wpisuje to wyskakuje

unknown database: moje haslo

Nie wiem juz mnie slabi to ;/ pomoze ktos ?

topdolar
Użytkownik
Posty: 389
Rejestracja: 2006-10-05, 18:35

Re: php + apache i mysql nie dziala!

Post autor: topdolar » 2007-09-03, 16:24

jak chcesz sie polaczyc z baza pisz

Kod: Zaznacz cały

mysql -u root -p {enter}
$Password: klepiesz haslo {enter}
powinno grac :)
Ostatnio zmieniony 2007-09-03, 16:30 przez topdolar, łącznie zmieniany 1 raz.

scorpiocs
Użytkownik
Posty: 18
Rejestracja: 2007-06-08, 10:23

Re: php + apache i mysql nie dziala!

Post autor: scorpiocs » 2007-09-03, 16:57

no tak gra :mrgreen: a nie wie ktos czasem czy w ten sposob bedzie tez dzialal phpmyadmin ? bo jak tak to ekstra i nic mi wiecej do szczescia nie potrzeba ;]

miszmaniac
Moderator
Posty: 1510
Rejestracja: 2006-03-19, 12:00
Lokalizacja: Gdynia
Kontakt:

Re: php + apache i mysql nie dziala!

Post autor: miszmaniac » 2007-09-03, 21:09

Co masz na myśli, czy w ten sposób będzie działał? Phpmyadmin nie korzysta z klienta mysql, tylko z wbudowanych funkcji php. W sumie dużo on nie wymaga, więc spokojnie powinien działać.
Pamiętaj,
Jeśli Twój problem został rozwiązany dopisz [b] [Rozw.] [/b]w tytule.
Projektowanie stron WWW: [url=http://www.miszewski.net.pl]www.miszewski.net.pl[/url]

scorpiocs
Użytkownik
Posty: 18
Rejestracja: 2007-06-08, 10:23

Re: php + apache i mysql nie dziala!

Post autor: scorpiocs » 2007-09-04, 10:29

napsialem tak poniewaz jak maile mproblem z mysql tzn z zalogowaniem sie do niego to phpmyadmin zwracal ten sam blad. Ale teraz juz odpalilem sieciowke, zainstalowalem phpmyadmina i wszystko ladnie dziala.


Wielkie dzieki za wszleka pomoc

Awatar użytkownika
viper99
Użytkownik
Posty: 5
Rejestracja: 2007-09-19, 20:46

Re: php + apache i mysql nie dziala!

Post autor: viper99 » 2007-09-20, 19:11

ukaszq pisze:Zainstalowalem je sobie ze zrodel.
Mysqla instalowalem tak:

Kod: Zaznacz cały

./configure –prefix=/usr/local/mysql
Apache tak:

Kod: Zaznacz cały

./configure –-prefix=/usr/local/apache2 –-enable-so
A php tak:

Kod: Zaznacz cały

./configure 
 --with-apache2=/usr/local/apache2 
 --with-apxs2=/usr/local/apache2/bin/apxs 
 --with-mysql=/usr/local/mysql 

No i kiedy tworze sobie zwykly plik *.php nie wyswietla mi nawet zwyklego echo"";

W httpd.conf dodalem:

Kod: Zaznacz cały

LoadModule php5_module modules/libphp5.so
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
Nie widzi mi wogle zadnych skryptow php :( Prosze o pomoc...

Sprawdz czy masz wpisy w httpd.conf

AddModule mod_php5.c

oraz

<IfModule mod_dir.c>
DirectoryIndex index.html index.php
</IfModule>

jesli nie to zapisz i daj:
killall -HUP httpd
przeladujesz w ten sposob plik konfiguracyjny.
Teraz sprawdz czy dziala;)
windows is great... if u like blue...

miszmaniac
Moderator
Posty: 1510
Rejestracja: 2006-03-19, 12:00
Lokalizacja: Gdynia
Kontakt:

Re: php + apache i mysql nie dziala!

Post autor: miszmaniac » 2007-09-20, 20:18

viper99 pisze:AddModule mod_php5.c

oraz

<IfModule mod_dir.c>
DirectoryIndex index.html index.php
</IfModule>
To już zdecydowanie nieaktualne. W pliku httpd.conf apache 2.x nie używa się wpisów AddModule tylko LoadModule.
Dalej się nie będę rozpisywał bo ten temat został rozwiązany.
Pamiętaj,
Jeśli Twój problem został rozwiązany dopisz [b] [Rozw.] [/b]w tytule.
Projektowanie stron WWW: [url=http://www.miszewski.net.pl]www.miszewski.net.pl[/url]

ukaszq
Użytkownik
Posty: 137
Rejestracja: 2007-02-18, 17:36

Re: php + apache i mysql nie dziala!

Post autor: ukaszq » 2007-09-24, 07:07

Dzieki... juz sie udalo :)

ODPOWIEDZ