Virtual Hosts

Serwery i sieci oparte na Slackware, wszelkiego rodzaju usługi, troubleshooting.

Moderatorzy: Moderatorzy, Administratorzy

Prezes87
Użytkownik
Posty: 7
Rejestracja: 2009-06-06, 14:46

Virtual Hosts

Post autor: Prezes87 »

Witam!
Na początku powiem, że moja przygoda ze Slackware dopiero się rozpoczęła i nie jestem expertem :P

A teraz do rzeczy:
Chciałem postawić serwer http który obsługiwałby 2 strony www. Poczytałem troche na necie i tutaj na forum i zrobiłem jak w wiekszości przypadków nakazano. Zainstalowałem Apache (v. 2.1.1 bodajże) i skonfigurowałem plik http.conf w nastepujacy sposób:

Listen Nr_ip:80

a później dodałem:

Kod: Zaznacz cały

<VirtualHost Nr_ip:80>
ServerAdmin email
DocumentRoot /home/koles1/
ServerName www.koles1.hopto.org
DirectoryIndex index.html
</VirtualHost>

<VirtualHost Nr_ip:80>
ServerAdmin email
DocumentRoot /home/koles2/
ServerName www.koles2.hopto.org
DirectoryIndex index.html
</VirtualHost>
Jednak nie działa mi żadna storna ;/ Na stronie no-ip.com skonfigurowałem obie strony aby po wpisaniu ich adresu łączyły się z moim IP

Czy ktoś mógłby coś pomóc ;)??

largo3: Nie [quote] a

Kod: Zaznacz cały

. ;)[/color]
Ostatnio zmieniony 2009-06-06, 17:37 przez Prezes87, łącznie zmieniany 1 raz.
Awatar użytkownika
marco70
Moderator
Posty: 1110
Rejestracja: 2006-10-26, 19:03
Lokalizacja: K...l
Kontakt:

Re: Virtual Hosts

Post autor: marco70 »

Sprawdź co w trawie piszczy /var/log/httpd/error_log :-)
slackware64-current
i5-9600K CPU @ 3.70GHz
Prezes87
Użytkownik
Posty: 7
Rejestracja: 2009-06-06, 14:46

Re: Virtual Hosts

Post autor: Prezes87 »

Kod: Zaznacz cały

[Sat Jun 06 15:02:39 2009] [notice] Digest: generating secret for digest authentication ...
[Sat Jun 06 15:02:39 2009] [notice] Digest: done
[Sat Jun 06 15:02:40 2009] [notice] Apache/2.2.10 (Unix) DAV/2 configured -- resuming normal operations
[Sat Jun 06 15:25:36 2009] [notice] caught SIGTERM, shutting down
[Sat Jun 06 15:25:39 2009] [notice] Digest: generating secret for digest authentication ...
[Sat Jun 06 15:25:39 2009] [notice] Digest: done
[Sat Jun 06 15:25:40 2009] [notice] Apache/2.2.10 (Unix) DAV/2 configured -- resuming normal operations
[Sat Jun 06 15:27:20 2009] [notice] caught SIGTERM, shutting down
[Sat Jun 06 15:27:22 2009] [notice] Digest: generating secret for digest authentication ...
[Sat Jun 06 15:27:22 2009] [notice] Digest: done
[Sat Jun 06 15:27:23 2009] [notice] Apache/2.2.10 (Unix) DAV/2 configured -- resuming normal operations
[Sat Jun 06 15:29:47 2009] [notice] caught SIGTERM, shutting down
[Sat Jun 06 15:29:50 2009] [notice] Digest: generating secret for digest authentication ...
[Sat Jun 06 15:29:50 2009] [notice] Digest: done
[Sat Jun 06 15:29:51 2009] [notice] Apache/2.2.10 (Unix) DAV/2 configured -- resuming normal operations
[Sat Jun 06 15:40:27 2009] [notice] caught SIGTERM, shutting down
[Sat Jun 06 15:40:30 2009] [notice] Digest: generating secret for digest authentication ...
[Sat Jun 06 15:40:30 2009] [notice] Digest: done
[Sat Jun 06 15:40:31 2009] [notice] Apache/2.2.10 (Unix) DAV/2 configured -- resuming normal operations
[Sat Jun 06 15:45:25 2009] [notice] caught SIGTERM, shutting down
[Sat Jun 06 15:48:26 2009] [notice] Digest: generating secret for digest authentication ...
[Sat Jun 06 15:48:26 2009] [notice] Digest: done
[Sat Jun 06 15:48:27 2009] [notice] Apache/2.2.10 (Unix) DAV/2 configured -- resuming normal operations
largo3: Code!
Ostatnio zmieniony 2009-06-06, 17:37 przez Prezes87, łącznie zmieniany 1 raz.
Awatar użytkownika
freak117
Użytkownik
Posty: 250
Rejestracja: 2006-12-13, 21:26
Lokalizacja: z sieci

Re: Virtual Hosts

Post autor: freak117 »

A wpis "NameVirtualHost *:80" jest :?:
Tak poza tym to w Apache2 configi są już rozbite i lepiej odhaszuj w httpd.conf linijke:

Kod: Zaznacz cały

Include /etc/httpd/extra/httpd-vhosts.conf
(oczywiście z odpowiednią ścieżką) i tam sobie ustawiaj vhosty.
W3 rulez ;D
Prezes87
Użytkownik
Posty: 7
Rejestracja: 2009-06-06, 14:46

Re: Virtual Hosts

Post autor: Prezes87 »

"NameVirtualHost *:80" wpisałem to zamiast "NameVirtualHost MojeIP:80"

I wyskoczył warning:
[warn] NameVirtualHost *:80 has no VirtualHosts httpd

Przy stop daje jeszcze:
(no pid file) not running

No i wklepałem hosty również do tego pliku

I miałem zapytać czy to działa:
1.wpisuje adres w wyszukiwarke
2.przekierowanie na adres IP
3.analiza jakie polecenie(adres www) zostało wywołane
4.wyswietlenie strony glownej(tylko skąd Apache ma wiedzieć która jest główna?)
Ostatnio zmieniony 2009-06-06, 18:38 przez Prezes87, łącznie zmieniany 2 razy.
Awatar użytkownika
mina86
Moderator
Posty: 3338
Rejestracja: 2004-06-14, 21:58
Lokalizacja: Linux 5.x x86_64
Kontakt:

Re: Virtual Hosts

Post autor: mina86 »

Prezes87 pisze:nie jestem expertem
Z pewnością, zważywszy, że takie słowo nie istnieje w języku polskim.
Prezes87 pisze:Jednak nie działa mi żadna storna
Że tak powiem, be more specific[/b].

Co się stanie jak przy uruchomionym Apache'u wejdziesz na http://localhost/?
Co się stanie jeśli po wpisaniu 127.0.0.1 www.koles1.hopto.org do /etc/hosts wejdziesz na http://www.koles1.hopto.org/?

PS. http://no-www.org/
Zastrzegam sobie prawo nieanalizowania postów pisanych niepoprawną polszczyzną.
Post generated automatically by A.I. system code name ‘mina86’ in response to the previous one.
Prezes87
Użytkownik
Posty: 7
Rejestracja: 2009-06-06, 14:46

Re: Virtual Hosts

Post autor: Prezes87 »

mina86 pisze: Co się stanie jak przy uruchomionym Apache'u wejdziesz na http://localhost/?
Nie wiem czy to coś zmienia ale działam obecnie na putty.

Po wpisaniu tego adresu wykskauje mi 403 Forbidden

You don't have permission to access / on this server.
mina86 pisze: Co się stanie jeśli po wpisaniu 127.0.0.1 www.koles1.hopto.org do /etc/hosts wejdziesz na http://www.koles1.hopto.org/?
To co powyżej w przypadku localhost
Awatar użytkownika
mina86
Moderator
Posty: 3338
Rejestracja: 2004-06-14, 21:58
Lokalizacja: Linux 5.x x86_64
Kontakt:

Re: Virtual Hosts

Post autor: mina86 »

Wygląda na to, że masz źle ustawione uprawnienia. Spróbuj

Kod: Zaznacz cały

<Directory /home/koles1/>
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>
i to samo dla drugiego katalogu. I oczywiście upewnij się, że Apache (apache:apache) może odczytać te katalogi. Log błędów powinien tutaj pomóc.
Ostatnio zmieniony 2009-06-07, 00:59 przez mina86, łącznie zmieniany 1 raz.
Zastrzegam sobie prawo nieanalizowania postów pisanych niepoprawną polszczyzną.
Post generated automatically by A.I. system code name ‘mina86’ in response to the previous one.
Prezes87
Użytkownik
Posty: 7
Rejestracja: 2009-06-06, 14:46

Re: Virtual Hosts

Post autor: Prezes87 »

Błędów nie było, ale dalej nie działa. ;/ Oto pliki w których grzebałem może jest tu coś co przeoczyłem, a jest istotne:

httpd.conf

Kod: Zaznacz cały

Listen 80

LoadModule authn_file_module lib/httpd/modules/mod_authn_file.so
LoadModule authn_dbm_module lib/httpd/modules/mod_authn_dbm.so
LoadModule authn_anon_module lib/httpd/modules/mod_authn_anon.so
LoadModule authn_dbd_module lib/httpd/modules/mod_authn_dbd.so
LoadModule authn_default_module lib/httpd/modules/mod_authn_default.so
LoadModule authn_alias_module lib/httpd/modules/mod_authn_alias.so
LoadModule authz_host_module lib/httpd/modules/mod_authz_host.so
LoadModule authz_groupfile_module lib/httpd/modules/mod_authz_groupfile.so
LoadModule authz_user_module lib/httpd/modules/mod_authz_user.so
LoadModule authz_dbm_module lib/httpd/modules/mod_authz_dbm.so
LoadModule authz_owner_module lib/httpd/modules/mod_authz_owner.so
LoadModule authnz_ldap_module lib/httpd/modules/mod_authnz_ldap.so
LoadModule authz_default_module lib/httpd/modules/mod_authz_default.so
LoadModule auth_basic_module lib/httpd/modules/mod_auth_basic.so
LoadModule auth_digest_module lib/httpd/modules/mod_auth_digest.so
LoadModule file_cache_module lib/httpd/modules/mod_file_cache.so
LoadModule cache_module lib/httpd/modules/mod_cache.so
LoadModule disk_cache_module lib/httpd/modules/mod_disk_cache.so
LoadModule mem_cache_module lib/httpd/modules/mod_mem_cache.so
LoadModule dbd_module lib/httpd/modules/mod_dbd.so
LoadModule dumpio_module lib/httpd/modules/mod_dumpio.so
LoadModule ext_filter_module lib/httpd/modules/mod_ext_filter.so
LoadModule include_module lib/httpd/modules/mod_include.so
LoadModule filter_module lib/httpd/modules/mod_filter.so
LoadModule substitute_module lib/httpd/modules/mod_substitute.so
LoadModule deflate_module lib/httpd/modules/mod_deflate.so
LoadModule ldap_module lib/httpd/modules/mod_ldap.so
LoadModule log_config_module lib/httpd/modules/mod_log_config.so
LoadModule log_forensic_module lib/httpd/modules/mod_log_forensic.so
LoadModule logio_module lib/httpd/modules/mod_logio.so
LoadModule env_module lib/httpd/modules/mod_env.so
LoadModule mime_magic_module lib/httpd/modules/mod_mime_magic.so
LoadModule cern_meta_module lib/httpd/modules/mod_cern_meta.so
LoadModule expires_module lib/httpd/modules/mod_expires.so
LoadModule headers_module lib/httpd/modules/mod_headers.so
LoadModule ident_module lib/httpd/modules/mod_ident.so
LoadModule usertrack_module lib/httpd/modules/mod_usertrack.so
LoadModule unique_id_module lib/httpd/modules/mod_unique_id.so
LoadModule setenvif_module lib/httpd/modules/mod_setenvif.so
LoadModule version_module lib/httpd/modules/mod_version.so
LoadModule proxy_module lib/httpd/modules/mod_proxy.so
LoadModule proxy_connect_module lib/httpd/modules/mod_proxy_connect.so
LoadModule proxy_ftp_module lib/httpd/modules/mod_proxy_ftp.so
LoadModule proxy_http_module lib/httpd/modules/mod_proxy_http.so
LoadModule proxy_ajp_module lib/httpd/modules/mod_proxy_ajp.so
LoadModule proxy_balancer_module lib/httpd/modules/mod_proxy_balancer.so
LoadModule mime_module lib/httpd/modules/mod_mime.so
LoadModule dav_module lib/httpd/modules/mod_dav.so
LoadModule status_module lib/httpd/modules/mod_status.so
LoadModule autoindex_module lib/httpd/modules/mod_autoindex.so
LoadModule asis_module lib/httpd/modules/mod_asis.so
LoadModule info_module lib/httpd/modules/mod_info.so
LoadModule cgi_module lib/httpd/modules/mod_cgi.so
LoadModule dav_fs_module lib/httpd/modules/mod_dav_fs.so
LoadModule vhost_alias_module lib/httpd/modules/mod_vhost_alias.so
LoadModule negotiation_module lib/httpd/modules/mod_negotiation.so
LoadModule dir_module lib/httpd/modules/mod_dir.so
LoadModule imagemap_module lib/httpd/modules/mod_imagemap.so
LoadModule actions_module lib/httpd/modules/mod_actions.so
LoadModule userdir_module lib/httpd/modules/mod_userdir.so
LoadModule alias_module lib/httpd/modules/mod_alias.so
LoadModule rewrite_module lib/httpd/modules/mod_rewrite.so

<IfModule !mpm_netware_module>
<IfModule !mpm_winnt_module>
User apache
Group apache

</IfModule>
</IfModule>

ServerAdmin prezes1987@gmail.com

ServerName koles1.hopto.org

NameVirtualHost *:80

<VirtualHost *:80>
    ServerAdmin prezes1987@gmail.com
    DocumentRoot /home/koles1/
    ServerName www.koles1.hopto.org
    DirectoryIndex      index.html
</VirtualHost>

<VirtualHost *:80>
    ServerAdmin prezes1987@gmail.com
    DocumentRoot /home/koles2/
    ServerName www.koles2.hopto.org
    DirectoryIndex      index.html
</VirtualHost>

<Directory /home/koles1/>
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

<Directory /home/koles2/>
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>
DocumentRoot "/usr/koles1"
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
</Directory>

<Directory "/srv/httpd/htdocs">
    Options Indexes FollowSymLinks

    AllowOverride None

    Order allow,deny
    Allow from all

</Directory>

<IfModule dir_module>
    DirectoryIndex index.html
</IfModule>

<FilesMatch "^\.ht">
    Order allow,deny
    Deny from all
    Satisfy All
</FilesMatch>

ErrorLog "/var/log/httpd/error_log"

LogLevel warn

<IfModule log_config_module>
    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%h %l %u %t \"%r\" %>s %b" common

    <IfModule logio_module>
      LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio
    </IfModule>

    CustomLog "/var/log/httpd/access_log" common

</IfModule>

<IfModule alias_module>

    ScriptAlias /cgi-bin/ "/srv/httpd/cgi-bin/"

</IfModule>

<IfModule cgid_module>
</IfModule>

<Directory "/srv/httpd/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
</Directory>

DefaultType text/plain

<IfModule mime_module>
    TypesConfig /etc/httpd/mime.types

    AddType application/x-compress .Z
    AddType application/x-gzip .gz .tgz

</IfModule>

Include /etc/httpd/extra/httpd-vhosts.conf

<IfModule ssl_module>
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
</IfModule>
httpd-vhosts.conf

Kod: Zaznacz cały

ServerName koles1.hopto.org

NameVirtualHost *:80

<VirtualHost *:80>
    ServerAdmin prezes1987@gmail.com
    ServerName www.koles1.hopto.org:80
    ServerAlias www.koles1.hopto.org
    DirectoryIndex      index.html
    DocumentRoot /home/koles1
</VirtualHost>

<VirtualHost *:80>
    ServerAdmin prezes1987@gmail.com
    ServerName  www.koles2.hopto.org:80
    DocumentRoot /home/koles2
    DirectoryIndex      index.html
    ServerAlias www.koles2.hopto.org
</VirtualHost>
I polecenie wpisałem
#grep -v "#" httpd.conf | cat -s
Ostatnio zmieniony 2009-06-07, 12:03 przez Prezes87, łącznie zmieniany 1 raz.
Awatar użytkownika
mina86
Moderator
Posty: 3338
Rejestracja: 2004-06-14, 21:58
Lokalizacja: Linux 5.x x86_64
Kontakt:

Re: Virtual Hosts

Post autor: mina86 »

I wejście na te hosty daje 403 bez wpisu w logu błędów? Jak dla mnie jest to dość dziwne... Możesz jeszcze próbować przenieść sekcję <Directory /> nad wszystkie inne, ale nie jestem pewny, czy to pomorze. Dodatkowo, jak już pisałem, sprawdź uprawnienia do katalogów -- czy użytkownik apache:apache może je odczytywać. Swoją drogą, czy na pewno chodzi o ścieżki /home/koles#, a nie przypadkiem /home/koles#/public_html czy coś podobnego?

[ Komentarz dodany przez: largo3: 2009-06-07, 19:37 ]
Jak nie Pomorze to może Mazowsze... :P
Zastrzegam sobie prawo nieanalizowania postów pisanych niepoprawną polszczyzną.
Post generated automatically by A.I. system code name ‘mina86’ in response to the previous one.
Prezes87
Użytkownik
Posty: 7
Rejestracja: 2009-06-06, 14:46

Re: Virtual Hosts

Post autor: Prezes87 »

Jak sprawdzić uprawnienia użytkowników? I gdzie jest ich lista?

zmienił się też błąd teraz nie mam dostępu do /index.html a nie do serwera

ok działa...

ale tylko na kompie z którego to odpalam ;p z innego nie działa ;P

może chodzi o numer portu?
albo w listen powinno być
156.17.230.211:80 ?

I do jakiej grupy należą osoby które podłączają sie za pomocą przeglądarki z zewnatrz ;>?

Może to chodzi o to co mam w pliku rc.firewall

Kod: Zaznacz cały

#Local Interface Information
LOCAL_IFACE="eth1"
LOCAL_IP="192.168.1.1"
LOCAL_NET="192.168.1.0/24"
LOCAL_BCAST="192.168.1.255"

# Localhost Interface

LO_IFACE="lo"
LO_IP="127.0.0.1"
Ostatnio zmieniony 2009-06-07, 16:25 przez Prezes87, łącznie zmieniany 6 razy.
Awatar użytkownika
mina86
Moderator
Posty: 3338
Rejestracja: 2004-06-14, 21:58
Lokalizacja: Linux 5.x x86_64
Kontakt:

Re: Virtual Hosts

Post autor: mina86 »

Prezes87 pisze:Jak sprawdzić uprawnienia użytkowników? I gdzie jest ich lista?
Nie do końca rozumiem pytanie.
Prezes87 pisze:z innego nie działa ;P
Zdefiniuj "nie działa"? Czy z zewnątrz ping dochodzi? Czy w logach Apache'a pojawia się informacja o próbie połączenia? Czy łączy się, ale jest błąd dostępu?
Prezes87 pisze:może chodzi o numer portu?
albo w listen powinno być
156.17.230.211:80 ?
Z Listen jest wszystko dobrze.
Prezes87 pisze:I do jakiej grupy należą osoby które podłączają sie za pomocą przeglądarki z zewnatrz ;>?
Nie ma znaczenia skąd -- pliki WWW odczytywane są przez użytkownika, z jaim działa Apache. Jak można wyczytać z pliku konfiguracyjnego jest to apache:apache. Jeżeli skonfigurowałeś suExec to od tego istnieją wyjątki, ale nie wygląda na to, abyś miał to skonfigurowane.
Może to chodzi o to co mam w pliku rc.firewall
Jeżeli tak wygląda Twój plik rc.firewall to równie dobrze możesz go skasować.
Zastrzegam sobie prawo nieanalizowania postów pisanych niepoprawną polszczyzną.
Post generated automatically by A.I. system code name ‘mina86’ in response to the previous one.
Prezes87
Użytkownik
Posty: 7
Rejestracja: 2009-06-06, 14:46

Re: Virtual Hosts

Post autor: Prezes87 »

mina86 pisze:
Prezes87 pisze:Jak sprawdzić uprawnienia użytkowników? I gdzie jest ich lista?
Nie do końca rozumiem pytanie.
Znaczy się. Czy istnieje plik w którym są wypisani wszyscy użytkownicy?
mina86 pisze:
Prezes87 pisze:z innego nie działa ;P
Zdefiniuj "nie działa"? Czy z zewnątrz ping dochodzi? Czy w logach Apache'a pojawia się informacja o próbie połączenia? Czy łączy się, ale jest błąd dostępu?
Nie ma w logach prób połączeń. Ping mówi że nie może odnaleźć hosta. Może problem tkwi w ustawieniach hostów na no-ip.com?

W przeglądarce wyskakuje Serwer koles1.hopto.org zbyt długo nie odpowiada.

a może ustawienia pliku hosts są źle?


jak to coś zmieni to jeszcze przy starice i stop apacha wyuskakuje warning
NameVirtualHost *:80 has no VirtualHosts
Ostatnio zmieniony 2009-06-07, 18:52 przez Prezes87, łącznie zmieniany 2 razy.
miszmaniac
Moderator
Posty: 1510
Rejestracja: 2006-03-19, 12:00
Lokalizacja: Gdynia
Kontakt:

Re: Virtual Hosts

Post autor: miszmaniac »

NameVirtualHost *:80 has no VirtualHosts
To wyskakuje, bo pewnie tutaj masz napisane *:80, a w definicji virtualek <VirtualHost IP:80>

A jak zrobisz ping: koles1.hopto.org
PING koles1.hopto.org (156.17.230.211) 56(84) bytes of data...

To to jest twój adres IP?
Pamiętaj,
Jeśli Twój problem został rozwiązany dopisz [b] [Rozw.] [/b]w tytule.
Projektowanie stron WWW: [url=http://www.miszewski.net.pl]www.miszewski.net.pl[/url]
infern
Użytkownik
Posty: 268
Rejestracja: 2006-10-26, 14:38
Lokalizacja: Wrocław

Re: Virtual Hosts

Post autor: infern »

A może po prostu:

Kod: Zaznacz cały

<VirtualHost Nr_ip:80>
ServerAdmin email
DocumentRoot /home/koles1/
ServerName koles1.hopto.org
DirectoryIndex index.html
</VirtualHost>

<VirtualHost Nr_ip:80>
ServerAdmin email
DocumentRoot /home/koles2/
ServerName koles2.hopto.org
DirectoryIndex index.html
</VirtualHost> 
Dla ping koles1.hopto.org oraz koles2.hopto.org jest rozwiązywana nazwa na adres IP, natomiast jeśli dodasz "www", to wtedy FQDN nie jest rozpoznawany...

PS. A może masz SElinux'a ;-) Bo ostatnio się z tym ścierałem na RHCE...
Ostatnio zmieniony 2009-06-09, 10:09 przez infern, łącznie zmieniany 1 raz.
Pozdrawiam Tomek
ODPOWIEDZ