Subversion

Serwery i sieci oparte na Slackware, wszelkiego rodzaju usługi, troubleshooting.

Moderatorzy: Moderatorzy, Administratorzy

Awatar użytkownika
darvark
Użytkownik
Posty: 164
Rejestracja: 2005-12-17, 11:45
Lokalizacja: Kielce
Kontakt:

Subversion

Post autor: darvark »

Hej
Od pewnego czasu walczę z svn pod slackware. Próbowałem kilku poradników jak go skonfigurować, żeby działał z apachem i można było używać go z zewnątrz. Niestety ciągle nie chce współpracować. Mam dodanego użytkownika, w teorii svn jest poprawnie skonfigurowany, apache działa. Nie mogę połączyć się z repozytorium ani poprzez konsole ani przez www. Macie może jakieś sprawdzone konfiguracje?

maho
Użytkownik
Posty: 455
Rejestracja: 2006-03-25, 12:28
Lokalizacja: Kielcowo

Re: Subversion

Post autor: maho »

Jakieś logi odnośnie svn-a?

U mnie po prostu wygląda to tak (dla repo prywatnych):
Całość dla zwykłego vhosta +

Kod: Zaznacz cały

    <Location /private>
	Order allow,deny
	Allow from all
	DAV svn
	SVNParentPath /home/subversion/private
	AuthzSVNAccessFile /etc/apache2/auth-files/public-svn-authzfile
	Require valid-user
	AuthType Basic
	AuthName "Repozytorium SVN..."
	AuthUserFile /home/subversion/.dav_svn.passwd
    </Location>

Awatar użytkownika
darvark
Użytkownik
Posty: 164
Rejestracja: 2005-12-17, 11:45
Lokalizacja: Kielce
Kontakt:

Re: Subversion

Post autor: darvark »

Logi nic mi nie mówią, a wpis mam taki sam. Nie wiem jak sprawdzić czy mam poprawnie działający WebDav. Może to on jest powodem problemów.

Awatar użytkownika
mina86
Moderator
Posty: 3314
Rejestracja: 2004-06-14, 21:58
Lokalizacja: Linux 4.x x86_64
Kontakt:

Re: Subversion

Post autor: mina86 »

<semi-troll>Jeżeli nie potrzebujesz anonimowego dostępu do repozytorium, to zwyczajnie zacznij używać gita i SSH.</semi-troll>
Zastrzegam sobie prawo nieanalizowania postów pisanych niepoprawną polszczyzną. :: Post generated automatically by A.I. system called “mina86” in response to the previous one. :: Tiny Applications

ODPOWIEDZ