wicd problem z siecią WPA2-Enterprise

Serwery i sieci oparte na Slackware, wszelkiego rodzaju usługi, troubleshooting.

Moderatorzy: Moderatorzy, Administratorzy

Miko
Użytkownik
Posty: 13
Rejestracja: 2012-04-03, 09:05

wicd problem z siecią WPA2-Enterprise

Post autor: Miko » 2013-10-05, 21:08

Witam

Mam dostępną sieć wi-fi o danych parametrach:

Nazwa sieci : moja.siec.pl
Typ zabezpieczeń : WPA2-Enterprise
Typ szyfrowania : AES
Metoda uwierzytelniania: EAP-MSCHAP V2
Uwierzytelniania przez użytkownika
Sieć wymaga następujących certyfikatów:
- http://www.terena.org/activities/tcs/re ... A_Root.pem
- http://www.terena.org/activities/tcs/re ... rdware.pem
- http://www.terena.org/activities/tcs/re ... SSL_CA.pem

Proszę o pomoc przy konfiguracji wicd na moim laptopie :)

Awatar użytkownika
dienet
Moderator
Posty: 2106
Rejestracja: 2007-07-24, 18:58
Lokalizacja: Racibórz/Rybnik
Kontakt:

Re: wicd problem z siecią WPA2-Enterprise

Post autor: dienet » 2013-10-06, 09:50

A co już próbowałeś zrobić?
Pozdr0
dienet
[img]http://i164.photobucket.com/albums/u19/slawek15/kotekeo0lq3.jpg[/img]

Awatar użytkownika
webster
Użytkownik
Posty: 1266
Rejestracja: 2009-10-06, 11:58
Lokalizacja: Gdańsk
Kontakt:

Re: wicd problem z siecią WPA2-Enterprise

Post autor: webster » 2013-10-06, 11:00

w WPA-Ent Masz CA, Cert USER, i Klucz PRV.

Który u Ciebie to klucz nie mam pojęcia.

Do podłączenia w WPA_ENT konieczne jest podanie również Tożsamości aczkolwiek ta może być dowolna. EOT - Jeśli Masz jeszcze jakieś pytania to pisz, jednak nikt za Ciebie nie uzupełni pozycji w wizardzie...
††† Chaos Of The Mirror - Valheru †††
††† I ♥ SlackWare RuLeZ †††

Slackware Poland FaceBook

Miko
Użytkownik
Posty: 13
Rejestracja: 2012-04-03, 09:05

Re: wicd problem z siecią WPA2-Enterprise

Post autor: Miko » 2013-10-07, 10:22

Otóż nie wiem dlaczego nie działa mi interfejs graficzny w wicd ale dla mnie to nie problem więc używam wicd-curses.

Znajduje mi sieć ale nie znalazłem w ustawieniach połączenia takiego rodzaju połączenia jak ja potrzebuje:

Dlatego w katalogu /etc/wicd/encryption/templates stworzyłem nowy plik w którym dałem następującą konfigurację:

name = EAP with MSCHAPv2
author = Miko
version = 1.0
require identity *Identity password *Password
-----
ctrl_interface=/var/run/wpa_supplicant
network={
ssid="$_ESSID"
scan_ssid=$_SCAN
key_mgmt=WPA-EAP
eap=EAP
phase2="auth=MSCHAPV2"
identity="$_IDENTITY"
password="$_PASSWORD"
}
A następnie dodałem nazwe do tego pliku aby wyświetlała mi się w wicd-curses
/etc/wicd/encryption/templates/active

I niestety nie mogę się połączyć... Moim zdaniem czegoś brakuje albo coś źle wpisałem...

Awatar użytkownika
webster
Użytkownik
Posty: 1266
Rejestracja: 2009-10-06, 11:58
Lokalizacja: Gdańsk
Kontakt:

Re: wicd problem z siecią WPA2-Enterprise

Post autor: webster » 2013-10-07, 19:04

ja korzystam z p12 i u mnie wygląda sekcja tak:

Kod: Zaznacz cały

ctrl_interface=/var/run/wpa_supplicant
eapol_version=1   
fast_reauth=1  
ap_scan=1
network={
        ssid="SSID"    
        key_mgmt=WPA-EAP
        proto=WPA
        pairwise=TKIP
        group=TKIP
        eap=TLS
        ca_cert="/etc/ssl/certs/ca.crt"
        identity="Imie_Nazwisko"
        private_key="/etc/ssl/certs/Moj_Cert.p12"
        private_key_passwd="Haslo_Do_P12"
}
Na dziś dzień korzystam w NetworkManager'a w KDE i nawet nie bąknie, jednak gdy łączyłem się poprzez supplicanta to właśnie tak jak wyżej.
††† Chaos Of The Mirror - Valheru †††
††† I ♥ SlackWare RuLeZ †††

Slackware Poland FaceBook

ODPOWIEDZ