Aktualizacja current powoduje problemy.

Instalacja Slackware Linux, problemy i wstępna konfiguracja, aktualizacje do nowszych wersji.

Moderatorzy: Moderatorzy, Administratorzy

Servant
Użytkownik
Posty: 11
Rejestracja: 2006-12-02, 01:33
Kontakt:

Aktualizacja current powoduje problemy.

Post autor: Servant »

Ostatnia aktualizacja wersji current spowodowała u mnie trzy problemy. Jednego nie rozwiązałem.
Po pierwsze to nie chcą normalnie wystartować X-y. Mimo wielu prób, nie dałem rady. X server próbuje wystartować i bez żadnego komunikatu kończy procedurę. Mogę się tylko zalogować. Po zalogowaniu wpisuję startx <Enter> i... X-y startują normalnie.
żeby uprościć procedurę ustawiłem automatyczne logowanie w /etc/inittab, ale to nie jest rozwiązanie.
Jakieś sugestie mile widziane.

Druga sprawa, to wykładanie się Okulara przy otwieraniu plików PDF. Co ciekawe inne pliki otwierają się bez problemu. Po długich poszukiwaniach dotarłem do informacji, że za otwieranie pdf odpowiada poppler (uruchomiony Okular z konsoli wskazywał na błąd drkonqi, ale przywrócenie poprzedniej wersji problemu nie rozwiązywało).
Faktycznie, wersja "poppler-20.11.0-x86_64-1.txz" jest chyba skopana. Przywrócenie "poppler-0.68.0-x86_64-1.txz" rozwiązało sprawę i Okular już otwiera pdf-y i się nie wywala. Nawiasem mówiąc jakiś dziwny przeskok jest w numeracji wersji popplera. Starsza wersja jest z 20.08.2018, a nowa z 3.11.2020. Tym bardziej jest to niezrozumiałe, że przedostatni upgrade currenta robiłem latem tego roku.
KDE4 nie mam. Zaistalowałem KDE Plasma 5 ze strony http://slackware.uk/people/alien-kde/current/5/x86_64
Multilib pobiera się stąd: http://slackware.uk/people/alien/multilib/current
Sprawa trzecia: Przestały mi działać niektóre programy pod wine. Szczególnie boleśnie odczułem niemożność uruchomienia e-pity.
Okazało się, że program uruchomiony z konsoli ma taki problem: failed to load .so lib "/usr/lib/wine/winepulse.drv.so"
Plik oczywiście tam był, ale z jakichś powodów biblioteka nie ładowała się. I to niezależnie od wersji wine. Zatem któraś z nowych paczek currenta nie chciała współpracować z wine instalowanej z paczki (ze strony https://wiki.winehq.org/Download).
Sprawdzanie wszystkich paczek programów, z którymi współpracuje wine okazało się ponad moje siły. :)

Postanowiłem, że skompiluję sobie wine ze źródeł i zobaczymy co będzie. To był strzał w 10. Wine zaczęło działać poprawnie.

Dla tych co mają ten sam problem, a nie kompilowali wine, poniżej instrukcja krok po kroku.

Budowanie paczki wine:
Przejść do katalogu /usr/src i założyć tam katalog np wine-5.xx (xx to numer wersji). W moim przypadku to była wersja wine-5.21 dlatego poniżej będę używał tego numeru wersji.
mkdir wine-5.21
cd /usr/src/wine-5.21
mkdir wine32-build
mkdir wine64-build
Można już teraz utworzyć katalog wine w /tmp (przyda się później)
mkdir /tmp/wine
Rozpakować źródła (zawartość podkatalogu wine-5.21) najpierw do
/usr/src/wine-5.21/wine32-build
a potem to samo do
/usr/src/wine-5.21/wine64-build

Mała uwaga: do rozpakowania najlepiej użyć mc, bo najpierw należy wejść do archiwum
wine-5.21.tar.xz, a następnie do katalogu wine-5.21 i dopiero zawartość tego katalogu przekopiować do katalogów
/usr/src/wine-5.21/winexx-build
Następnie:
cd /usr/src/wine-5.21/wine64-build
./configure --prefix=/usr --enable-win64
make
make install DESTDIR=/tmp/wine
cd /usr/src/wine-5.21/wine32-build
PKG_CONFIG_PATH=/usr/lib ../wine64-build/configure --prefix=/usr --with-wine64=../wine64-build
make
make install DESTDIR=/tmp/wine
cd /tmp/wine
makepkg ../wine-5.21-x86_64-1[tu_twoj_nick].txz
Paczka utworzy się w /tmp

PS. Może by tę instrukcję przenieść w inne miejsce i nadać odpowiedni tytuł tematowi?
leplo
Użytkownik
Posty: 4
Rejestracja: 2007-06-23, 20:02
Lokalizacja: Wrocław
Kontakt:

Re: Aktualizacja current powoduje problemy.

Post autor: leplo »

Cześć Servant,
A może zamiast przenosić w inne miejsce zrobić z tego tematu worek na naprawianie różnych błędów aktualizacji currenta?
Bo mam kilka z którymi sobie nie radzę, a może ktoś z forumowiczów już sprawę rozwalił, tylko się nie chwali.

Spodziewam się, że od roku to już naprawiłeś swój problem z X-ami, czy nie?
ODPOWIEDZ