Zamordowałem slacka :/

Instalacja Slackware Linux, problemy i wstępna konfiguracja, aktualizacje do nowszych wersji.

Moderatorzy: Moderatorzy, Administratorzy

Mietas
Użytkownik
Posty: 10
Rejestracja: 2006-10-22, 20:14
Lokalizacja: Opalenica
Kontakt:

Zamordowałem slacka :/

Post autor: Mietas » 2006-10-23, 19:54

Witam ponownie. Teraz wydaje się, że całkowicie zabiłem slacka. Podczas kompilacji kernela 2.6 coś się skopało i nic nie działa :/ Na dodatek, kernel 2.4 działa jakby chciał a nie mógł, czyli w ogóle nie działa USB, Xy wariują. Niestety nie mam płytek instalacyjnych a niechciałbym reinstalacji systemu :/

Pomóżcie! Niestety zachciało mi się kernela 2.6.... I zepsułem wszystko. W gentoo nie było takich problemów. :help: :mrgreen: :mrgreen: :rotfl: :rotfl:

Dzięki wszystkim za pomoc, jakoś się odwdzięczę. Niestety jestem skazany na windę :/
Ostatnio zmieniony 2006-10-23, 19:55 przez Mietas, łącznie zmieniany 1 raz.
Powered by Gentoo Linux 2007.0
Kernel 2.6.23-rc6-mm1
Filesytem on /: ext4dev
KDE 3.5.7

Awatar użytkownika
difrost
Moderator
Posty: 2802
Rejestracja: 2006-03-11, 12:31
Lokalizacja: Wrocław
Kontakt:

Re: Zamordowałem slacka :/

Post autor: difrost » 2006-10-23, 19:59

Mietas pisze:Podczas kompilacji kernela 2.6 coś się skopało i nic nie działa :/ Na dodatek, kernel 2.4 działa jakby chciał a nie mógł, czyli w ogóle nie działa USB, Xy wariują. Niestety nie mam płytek instalacyjnych a niechciałbym reinstalacji systemu :/
Co sie dokladnie skopalo? Skompilowales 2.6 do konca? Moze Ci sie procesor usmazyl :>
[url=http://bdtk.sourceforge.net][img]http://pin.if.uz.zgora.pl/~beton/bdt-ready.png[/img][/url] #337142
--------------------------------------------
"I had a letter in the post today. It said 'Gas Bill'. It sounds a tempting offer." -- Alan Cox
"Users have been trained that when a computer bluescreens and losing all of their data, it's either (a) just the way things are, or (b) it's microsoft's fault." -- Theodore Tso

Mietas
Użytkownik
Posty: 10
Rejestracja: 2006-10-22, 20:14
Lokalizacja: Opalenica
Kontakt:

Re: Zamordowałem slacka :/

Post autor: Mietas » 2006-10-23, 20:05

Tzn. włączyłem kompilację kernela i wyszedłem na chwilkę. Gdy wróciłem, był już skompilowany lecz zauważyłem że skompilowały się tylko moduły fs.... Tak więc sprawdziłem wszystko w menuconfig i od nowa rozpoczęłem kompilację. Tym razem skompilował się cały. Jednak włączam na kernelu 2.6 i pokazuje się kernel panic. Uruchamiam Gentoo LiveCD, chrootuję się i dodaję do lilo.conf wpis od kernela 2.4 I miła ( a może niemiła :D ) niespodzianka, kernel 2.4 też nie działa (tak w miarę). Dzieje się to co opisałem.

Niestety kernel 2.6 wyrzuca kernel panic i chodzi o VFS. W configu już sprawdzałem, wszystko ok. Nie wiem co się dzieje :(


Czy konieczna będzie reinstalacja systemu?
Ostatnio zmieniony 2006-10-23, 20:16 przez Mietas, łącznie zmieniany 1 raz.
Powered by Gentoo Linux 2007.0
Kernel 2.6.23-rc6-mm1
Filesytem on /: ext4dev
KDE 3.5.7

Awatar użytkownika
difrost
Moderator
Posty: 2802
Rejestracja: 2006-03-11, 12:31
Lokalizacja: Wrocław
Kontakt:

Re: Zamordowałem slacka :/

Post autor: difrost » 2006-10-23, 20:23

Wiec tak: to, ze kompilowales ,,obok'' 2.6 i dostajesz Kernel Panic przy jego starcie NIE POWINNO wplynac na zainstalowane wczesniej 2.4. Wydaje mi sie, ze trzeba po prostu zrobic dzialajace 2.6 i tyle.

Wkompilowales obsluge swojego fs'a, kontorlera IDE/SATA?
[url=http://bdtk.sourceforge.net][img]http://pin.if.uz.zgora.pl/~beton/bdt-ready.png[/img][/url] #337142
--------------------------------------------
"I had a letter in the post today. It said 'Gas Bill'. It sounds a tempting offer." -- Alan Cox
"Users have been trained that when a computer bluescreens and losing all of their data, it's either (a) just the way things are, or (b) it's microsoft's fault." -- Theodore Tso

Awatar użytkownika
m4jkel
Użytkownik
Posty: 690
Rejestracja: 2005-10-15, 18:56
Lokalizacja: Katowice

Re: Zamordowałem slacka :/

Post autor: m4jkel » 2006-10-23, 21:19

Mietas pisze:czyli w ogóle nie działa USB, Xy wariują.
Jakbyś sprecyzował, byłoby łatwiej :)

Moduł do USB się nie ładuje, urządzeń nie wykrywa?

Xy nie starują, rozdzielczość nie taka, obraz się kręci wokół własnej osi?

Pozwól sobie pomóć ;)
[url=http://userbars.org][img]http://img89.imageshack.us/img89/9140/brainpng1ug.png[/img][/url]
To nie był kwadrat. To było koło o charakterze prostokąta.

Awatar użytkownika
difrost
Moderator
Posty: 2802
Rejestracja: 2006-03-11, 12:31
Lokalizacja: Wrocław
Kontakt:

Re: Zamordowałem slacka :/

Post autor: difrost » 2006-10-23, 21:34

Prawdopodobnie moduly gdzies wcielo. Jesli uzywales jadra dystrybucyjnego, to przeinstaluj kernel-modules.
[url=http://bdtk.sourceforge.net][img]http://pin.if.uz.zgora.pl/~beton/bdt-ready.png[/img][/url] #337142
--------------------------------------------
"I had a letter in the post today. It said 'Gas Bill'. It sounds a tempting offer." -- Alan Cox
"Users have been trained that when a computer bluescreens and losing all of their data, it's either (a) just the way things are, or (b) it's microsoft's fault." -- Theodore Tso

Awatar użytkownika
guitarrizer
Użytkownik
Posty: 349
Rejestracja: 2004-06-12, 14:23
Lokalizacja: Gdańsk
Kontakt:

Re: Zamordowałem slacka :/

Post autor: guitarrizer » 2006-10-23, 22:04

Dobrych kilka kerneli temu mialem kernel panic z dosc blachego powodu. W domyslnej konfiguracji wlaczony byl suspend na /dev/hda2, podczas gdy ja takiej partycji nie mialem. W nowych kernelach zrezygnowano z tego i wprowadzono mozliwosc samodzielnego wybrania partycji.

Brak obslugi USB to jeszcze nie tragedia, podobnie jak awaria iksow. Ja bym sie chrootowal z jakiegos live CD (jesli nie masz instalek Slacka - ja nie rozstaje sie z System Rescue CD - nawet jesli nie jest potrzebne, zawsze czuje sie spokojniejszy, efekt placebo ;) ).

PS
Jesli instalowales nowego kernela przez "make install", w katalogu /boot najprawdopodobniej masz starego kernela o nazwie vmlinuz.old - sproboj zabootowac sie nim do systemu.
Ostatnio zmieniony 2006-10-23, 22:09 przez guitarrizer, łącznie zmieniany 1 raz.
Linux Registered User #350196

Obrazek

Mietas
Użytkownik
Posty: 10
Rejestracja: 2006-10-22, 20:14
Lokalizacja: Opalenica
Kontakt:

Re: Zamordowałem slacka :/

Post autor: Mietas » 2006-10-24, 15:07

Dzieki difrost, odratowalem slacka :D Faktycznie, moduly poszly na spacer.... :D Jednak nadal nie wiem o co chodzi z tym kernelem 2.6... Moglby mi ktos przeslac configa?? Calkowicie sobie nie radze..... W gentoo nie mialem problemow... Czyzby cofam sie w rozwoju?? :P

Bardzo prosze o configa. Nie koniecznie tu. Mozna na maila. Mietas2005@wp.pl
Powered by Gentoo Linux 2007.0
Kernel 2.6.23-rc6-mm1
Filesytem on /: ext4dev
KDE 3.5.7

Awatar użytkownika
difrost
Moderator
Posty: 2802
Rejestracja: 2006-03-11, 12:31
Lokalizacja: Wrocław
Kontakt:

Re: Zamordowałem slacka :/

Post autor: difrost » 2006-10-24, 15:13

W rzuc tutaj lspci.
[url=http://bdtk.sourceforge.net][img]http://pin.if.uz.zgora.pl/~beton/bdt-ready.png[/img][/url] #337142
--------------------------------------------
"I had a letter in the post today. It said 'Gas Bill'. It sounds a tempting offer." -- Alan Cox
"Users have been trained that when a computer bluescreens and losing all of their data, it's either (a) just the way things are, or (b) it's microsoft's fault." -- Theodore Tso

Awatar użytkownika
dawidmo
Użytkownik
Posty: 307
Rejestracja: 2006-08-24, 16:16
Lokalizacja: Pszczyna
Kontakt:

Re: Zamordowałem slacka :/

Post autor: dawidmo » 2006-10-24, 15:18

Mietas pisze:Moglby mi ktos przeslac configa?? Calkowicie sobie nie radze..... W gentoo nie mialem problemow... Czyzby cofam sie w rozwoju?? :P
W Gentoo jest genkernel :mrgreen:
Aby chciało mi się tak bardzo, jak mi się nie chce ;]

Mietas
Użytkownik
Posty: 10
Rejestracja: 2006-10-22, 20:14
Lokalizacja: Opalenica
Kontakt:

Re: Zamordowałem slacka :/

Post autor: Mietas » 2006-10-24, 15:36

Niestety nie zgadles... Recznie kompilowalem :D

A tak poza tym... Naprawilem blad w 2.6 instalujac kernel-generic-2.6.17.13 itd... :D

Teraz dzwiek padl... Ale z tym sobie poradze :D[/list]
Powered by Gentoo Linux 2007.0
Kernel 2.6.23-rc6-mm1
Filesytem on /: ext4dev
KDE 3.5.7

ODPOWIEDZ