Problem z apache

Instalacja Slackware Linux, problemy i wstępna konfiguracja, aktualizacje do nowszych wersji.

Moderatorzy: Moderatorzy, Administratorzy

todziu
Użytkownik
Posty: 116
Rejestracja: 2006-04-26, 19:20
Kontakt:

Problem z apache

Post autor: todziu »

Mam slackware 9.1 oraz apache-1.3.28, postanowiłem zaktualizować apache - odinstalowałem 1.3.28 i zainstalowałem z paczek apache2-2.0.59-i486 - poczło OK ale przy uruchomieniu apache wywalił błąd z glibc-2.3.2 wiec to też zaktualizowałem do ver glibc-2.5-i486-4 no i problem przy aktualizacji wywaliło mi błąd:

Kod: Zaznacz cały

FATAL: kernel too old
/sbin/installpkg: line 456: 19100 Naruszenie ochrony pamięci  /sbin/ldconfig
Executing install script for glibc-2.5-i486-4...
teraz próbuje przeinstalować z paczek apache na apache-1.3.28 i wywala mi ten sam błąd:
FATAL: kernel too old....
Przy poleceniu ldconfig wywala:

Kod: Zaznacz cały

FATAL: kernel too old
Naruszenie ochrony pamięci
czy można ten problem rozwiązać bez rekompilacji jajka ? - dzieki
Ostatnio zmieniony 2007-06-30, 09:55 przez todziu, łącznie zmieniany 1 raz.

Awatar użytkownika
dozzie
Użytkownik
Posty: 855
Rejestracja: 2004-06-01, 13:15
Lokalizacja: Wrocław
Kontakt:

Re: Problem z apache

Post autor: dozzie »

Nie ruszaj gałęzi current jeśli sam wiesz że masz za małą wiedzę o działaniu systemu. Proste jak drut.
-zsh
#!/bin/bash
#!/usr/bin/perl -w

todziu
Użytkownik
Posty: 116
Rejestracja: 2006-04-26, 19:20
Kontakt:

Re: Problem z apache

Post autor: todziu »

ok ale jak to można poprawić ?


todziu
Użytkownik
Posty: 116
Rejestracja: 2006-04-26, 19:20
Kontakt:

Re: Problem z apache

Post autor: todziu »

probowałem zainstalowac ten stary pakiet glibc-2.3.2-i486-1.tgz
efekt:

Kod: Zaznacz cały

FATAL: kernel too old
FATAL: kernel too old
Package glibc-2.5-i486-4 upgraded with new package ./glibc-2.3.2-i486-1.tgz.

teraz obojętnie jakie polecenie wpisze wywala mi :

Kod: Zaznacz cały

FATAL: kernel too old
:help:

Awatar użytkownika
Lizard
Moderator
Posty: 2607
Rejestracja: 2005-05-21, 15:48
Lokalizacja: miasto w mieście

Re: Problem z apache

Post autor: Lizard »

No to ratuje Cie tylko płyta instalacyjne 9.1 i "installpkg -root".

BTW. Bardzo ciekawe, u mnie próba instalacji glibc z currenta na kernelu 2.4 zakończyła się zanim się rozpoczęła komunikatem o konieczności zmiany kernela na 2.6.
Ostatnio zmieniony 2007-06-30, 11:48 przez Lizard, łącznie zmieniany 1 raz.
Error 404 - footer not found

todziu
Użytkownik
Posty: 116
Rejestracja: 2006-04-26, 19:20
Kontakt:

Re: Problem z apache

Post autor: todziu »

no tak - ale teraz juz server sie nie chce uruchomic - zrobiłem restart i wywala
FATAL: kernel too old

miszmaniac
Moderator
Posty: 1510
Rejestracja: 2006-03-19, 12:00
Lokalizacja: Gdynia
Kontakt:

Re: Problem z apache

Post autor: miszmaniac »

To teraz, uruchom z płytki potem chroot i zainstaluj paczkę.
Pamiętaj,
Jeśli Twój problem został rozwiązany dopisz [b] [Rozw.] [/b]w tytule.
Projektowanie stron WWW: [url=http://www.miszewski.net.pl]www.miszewski.net.pl[/url]

Awatar użytkownika
aleks
Użytkownik
Posty: 80
Rejestracja: 2006-04-17, 12:33

Re: Problem z apache

Post autor: aleks »

Pozwole sobie podczepic sie pod temat.

Mam podobny problem na starej maszynce zainstalowalem sobie slacka 10.2 bo inne plytki mi tam nie startowaly zreszta instalacje przeprowadzilem z hdd
No i przyszedl czas na aktualizacje do currenta najpierw zainstalowalem jądro 2.6.13

a potem postepowałem wg tych wytycznych: ftp://ftp.belnet.be/packages/slackware/ ... PGRADE.TXT

Pojawil sie ten sam problem.
Pytanie czy wystarczy ze jest kernel 2.6.13 czy musi byc tak jak w UPGRADE.TXT conajmniej 2.6.18 ??

miszmaniac
Moderator
Posty: 1510
Rejestracja: 2006-03-19, 12:00
Lokalizacja: Gdynia
Kontakt:

Re: Problem z apache

Post autor: miszmaniac »

Jądro powinno być skompilowane tą samą wersją glibca, którą masz w systemie, więc jeśli używasz dystrybucyjnych jąder to jednak powinieneś moim zdaniem używać nowszego.
Pamiętaj,
Jeśli Twój problem został rozwiązany dopisz [b] [Rozw.] [/b]w tytule.
Projektowanie stron WWW: [url=http://www.miszewski.net.pl]www.miszewski.net.pl[/url]

Awatar użytkownika
intosh
Użytkownik
Posty: 243
Rejestracja: 2006-07-04, 13:34
Lokalizacja: Łódź
Kontakt:

Re: Problem z apache

Post autor: intosh »

miszmaniac pisze:Jądro powinno być skompilowane tą samą wersją glibca, którą masz w systemie, więc jeśli używasz dystrybucyjnych jąder to jednak powinieneś moim zdaniem używać nowszego.
- co ty za herezje wypisujesz :-).
Jądro może być skompilowane gcc albo innym kompilatorem a jako, że jest niezależne od reszty tworu zwanego dystrybucją, to w sumie, może być skompilowane czymkolwiek i w jakiejkolwiek wersji, o ile skompilowany kod będzie działał :-).
:: everyone in the world is doing something without me ::

Awatar użytkownika
Lizard
Moderator
Posty: 2607
Rejestracja: 2005-05-21, 15:48
Lokalizacja: miasto w mieście

Re: Problem z apache

Post autor: Lizard »

intosh, a to ci herezja! :D

gcc = gnu compiler collection && glibc = GNU C Library ==> Compiler != Library ;)
Error 404 - footer not found

ODPOWIEDZ