Problem z załadowaniem systemu :-( ??? z karty CF

Instalacja Slackware Linux, problemy i wstępna konfiguracja, aktualizacje do nowszych wersji.

Moderatorzy: Moderatorzy, Administratorzy

porter_1983
Użytkownik
Posty: 95
Rejestracja: 2006-10-03, 16:52

Problem z załadowaniem systemu :-( ??? z karty CF

Post autor: porter_1983 »

Witam mam problem z załadowaniem systemu z karty CF mianowicie wywala mi coś takiego w logu :-/

Kod: Zaznacz cały

Jul 27 22:47:55 serwer kernel: hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
Jul 27 22:47:55 serwer kernel: hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
Jul 27 22:47:55 serwer kernel: ide: failed opcode was: unknown
Jul 27 22:47:55 serwer kernel: hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
Jul 27 22:47:55 serwer kernel: hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
Jul 27 22:47:55 serwer kernel: ide: failed opcode was: unknown
Jul 27 22:47:55 serwer kernel: hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
Jul 27 22:47:55 serwer kernel: hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
Jul 27 22:47:55 serwer kernel: ide: failed opcode was: unknown
Jul 27 22:47:55 serwer kernel: hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
Jul 27 22:47:55 serwer kernel: hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
Jul 27 22:47:55 serwer kernel: ide: failed opcode was: unknown
Jul 27 22:47:55 serwer kernel: ide0: reset: success
Jul 27 22:47:55 serwer kernel: hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
Jul 27 22:47:55 serwer kernel: hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
Jul 27 22:47:55 serwer kernel: ide: failed opcode was: unknown
Jul 27 22:47:55 serwer kernel: hda: dma_timer_expiry: dma status == 0x21
Jul 27 22:47:55 serwer kernel: hda: DMA timeout error
Jul 27 22:47:55 serwer kernel: hda: dma timeout error: status=0x51 { DriveReady SeekComplete Error }
Jul 27 22:47:55 serwer kernel: hda: dma timeout error: error=0x84 { DriveStatusError BadCRC }
Jul 27 22:47:55 serwer kernel: ide: failed opcode was: unknown
Jul 27 22:47:55 serwer kernel: hda: dma_timer_expiry: dma status == 0x21
Jul 27 22:47:55 serwer kernel: hda: DMA timeout error
Jul 27 22:47:55 serwer kernel: hda: dma timeout error: status=0x51 { DriveReady SeekComplete Error }
Jul 27 22:47:55 serwer kernel: hda: dma timeout error: error=0x84 { DriveStatusError BadCRC }
Jul 27 22:47:55 serwer kernel: ide: failed opcode was: unknown
Jul 27 22:47:55 serwer kernel: hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
Jul 27 22:47:55 serwer kernel: hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
Jul 27 22:47:55 serwer kernel: ide: failed opcode was: unknown
Jul 27 22:47:55 serwer kernel: hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
Jul 27 22:47:55 serwer kernel: hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
Jul 27 22:47:55 serwer kernel: ide: failed opcode was: unknown
Jul 27 22:47:55 serwer kernel: hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
Jul 27 22:47:55 serwer kernel: hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
Jul 27 22:47:55 serwer kernel: ide: failed opcode was: unknown
Jul 27 22:47:55 serwer kernel: hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
Jul 27 22:47:55 serwer kernel: hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
Jul 27 22:47:55 serwer kernel: ide: failed opcode was: unknown
Jul 27 22:47:55 serwer kernel: ide0: reset: success
Jul 27 22:47:55 serwer kernel: VFS: Mounted root (ext3 filesystem) readonly.
Jul 27 22:47:55 serwer kernel: hda: dma_timer_expiry: dma status == 0x21
Jul 27 22:47:55 serwer kernel: hda: DMA timeout error
Jul 27 22:47:55 serwer kernel: hda: dma timeout error: status=0x51 { DriveReady SeekComplete Error }
Jul 27 22:47:55 serwer kernel: hda: dma timeout error: error=0x84 { DriveStatusError BadCRC }
Jul 27 22:47:55 serwer kernel: ide: failed opcode was: unknown
Jul 27 22:47:55 serwer kernel: hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
Jul 27 22:47:55 serwer kernel: hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
Jul 27 22:47:55 serwer kernel: ide: failed opcode was: unknown
Jul 27 22:47:55 serwer kernel: hda: dma_timer_expiry: dma status == 0x21
Jul 27 22:47:55 serwer kernel: hda: DMA timeout error
Jul 27 22:47:55 serwer kernel: hda: dma timeout error: status=0x51 { DriveReady SeekComplete Error }
Jul 27 22:47:55 serwer kernel: hda: dma timeout error: error=0x84 { DriveStatusError BadCRC }
Jul 27 22:47:55 serwer kernel: ide: failed opcode was: unknown

Awatar użytkownika
dienet
Moderator
Posty: 2106
Rejestracja: 2007-07-24, 18:58
Lokalizacja: Racibórz/Rybnik
Kontakt:

Re: Problem z załadowaniem systemu :-( ??? z karty CF

Post autor: dienet »

Karta pewnie sie uszkodzila. Mozna tez bez dma sprobowac odpalic, tylko jaka to byla opcja....dma=no?
Pozdr0
dienet
[img]http://i164.photobucket.com/albums/u19/slawek15/kotekeo0lq3.jpg[/img]

porter_1983
Użytkownik
Posty: 95
Rejestracja: 2006-10-03, 16:52

Re: Problem z załadowaniem systemu :-( ??? z karty CF

Post autor: porter_1983 »

Karta nówka sztuka a gdzie ta opcje bez dma wpisac ?

Awatar użytkownika
dienet
Moderator
Posty: 2106
Rejestracja: 2007-07-24, 18:58
Lokalizacja: Racibórz/Rybnik
Kontakt:

Re: Problem z załadowaniem systemu :-( ??? z karty CF

Post autor: dienet »

porter_1983, nowki tez sie uszkadzaja. Sprawdz na innym czytniku. dma=no wpisujesz do boot linii - czyli przy wyborze jadra z lilo/gruba.
Pozdr0
dienet
[img]http://i164.photobucket.com/albums/u19/slawek15/kotekeo0lq3.jpg[/img]

porter_1983
Użytkownik
Posty: 95
Rejestracja: 2006-10-03, 16:52

Re: Problem z załadowaniem systemu :-( ??? z karty CF

Post autor: porter_1983 »

;-) sprawdziłem na 512 no i rzeczywiście na niej nie wywala żadnych błędów ta ma 8G no i najwidoczniej jest z tą kartą coś nie tak napisałem do sprzedawcy żeby mi ją wymienił ;-) Zobaczymy co odpisze ;-) powód zgłaszanie błędów w trybie DMA

[ Dodano: 2009-07-29, 11:15 ]
hmm najdziwniejsze jest to że jak wepne karte CF a adapter i ustawie na MASTER to wywala te bledy :-/ a jak karta jest na SLAVE to dziala dma :-/// może to jednak nie karta tylko ten adapter :-/ zwalony

Pajaczek
Użytkownik
Posty: 1439
Rejestracja: 2006-08-03, 13:16
Lokalizacja: Winny Gród

Re: Problem z załadowaniem systemu :-( ??? z karty CF

Post autor: Pajaczek »

porter_1983, A czy to czasem nie jest Microdrive (te 8G), a nie klasyczna karta CF?? Microdrive mają większe zapotrzebowanie na powerek, i pod adapterami np. USB czasem sypią błędami (w końcu obciążając 5V z USB kilkuset mA i do tego po drodze (jak jest) stabilizator w czytniku... to nie może dać na wyjściu znów 5V których wymaga Microdrive ;) ).

porter_1983
Użytkownik
Posty: 95
Rejestracja: 2006-10-03, 16:52

Re: Problem z załadowaniem systemu :-( ??? z karty CF

Post autor: porter_1983 »

karta jest z tej aukcji : oznaczenie na karcie CF/8GB -S2 3,3V/5V

http://www.allegro.pl/item676409153_sal ... _wawa.html

a adapter to cos takiego :

http://www.allegro.pl/item697477912_ada ... ak120.html
Ostatnio zmieniony 2009-07-29, 11:18 przez porter_1983, łącznie zmieniany 1 raz.

sp7foy
Użytkownik
Posty: 167
Rejestracja: 2008-02-26, 15:07
Lokalizacja: Skierniewice

Re: Problem z załadowaniem systemu :-( ??? z karty CF

Post autor: sp7foy »

porter_1983 pisze:karta jest z tej aukcji : oznaczenie na karcie CF/8GB -S2 3,3V/5V
http://www.allegro.pl/item676409153_sal ... _wawa.html
a adapter to cos takiego :
http://www.allegro.pl/item697477912_ada ... ak120.html
A jak w ten sposób to masz, to stawiam na kabel łączący płytę z adapterem.

Awatar użytkownika
argon
Użytkownik
Posty: 240
Rejestracja: 2004-09-29, 00:49
Lokalizacja: Węgorzewo
Kontakt:

Re: Problem z załadowaniem systemu :-( ??? z karty CF

Post autor: argon »

W firmie swego czasu używaliśmy kilkudziesięciu maszyn z systemem na CF, i z obserwacji wiem że najszybciej leciały Kingstony a najdłużej działały karty PQI. Teraz w antycznym laptopie-terminalu mam kartę Toshiba 1GB, która też ma "badsector" (bardzo podobne komunikaty na starcie). Inna sprawa, nie wszystkie przejściówki miały podłączone dwie ścieżki odpowiadające właśnie za DMA i przy startowaniu systemu trzeba było wyłączać, ale dotyczyło to sprzętu z czasów gdy CF nie wspierały DMA (w trybie IDE oczywiście).
No RISC, no fun!

porter_1983
Użytkownik
Posty: 95
Rejestracja: 2006-10-03, 16:52

Re: Problem z załadowaniem systemu :-( ??? z karty CF

Post autor: porter_1983 »

sprawdzałem na innej taśmie i to samo ;-/ stawiam na adapter zamówiłem nowy więc zobaczymy jak będzie ;-) bo trochę dziwne żeby karta w trybie slave pokazywała w hdparm włączony tryb dma a na master się sypie. Czekam na nowy adapter ;-)

Awatar użytkownika
argon
Użytkownik
Posty: 240
Rejestracja: 2004-09-29, 00:49
Lokalizacja: Węgorzewo
Kontakt:

Re: Problem z załadowaniem systemu :-( ??? z karty CF

Post autor: argon »

Cóż, kolejnym podejrzanym będzie płyta ;-)
Przejedź kartę programem badblocks i zobacz czy czegoś nie znajdzie...
No RISC, no fun!

warlock
Użytkownik
Posty: 22
Rejestracja: 2006-03-21, 00:39
Lokalizacja: Nowogródek Pom.
Kontakt:

Re: Problem z załadowaniem systemu :-( ??? z karty CF

Post autor: warlock »

Kontroler musi byc engines. Jakjest jakis syfny to ci nie pojdzie slack na cf.

Awatar użytkownika
coolart
Użytkownik
Posty: 250
Rejestracja: 2004-06-20, 03:08
Kontakt:

Re: Problem z załadowaniem systemu :-( ??? z karty CF

Post autor: coolart »

ja operowalem na kartach CF sandisk 2GB i 4GB i zadna jeszcze nie ma badblockow, fakt ze to krotko ale czesto robilem reinstalki update'ty na nich i nie mialem problemow.
Ostatnio zmieniony 2009-08-07, 15:20 przez coolart, łącznie zmieniany 1 raz.

porter_1983
Użytkownik
Posty: 95
Rejestracja: 2006-10-03, 16:52

Re: Problem z załadowaniem systemu :-( ??? z karty CF

Post autor: porter_1983 »

hmm przyszedł mi nowy adapter :-/ i teraz juz nie wiem co mam myśleć zainstalowalem jeszcze raz wszystko odnowa ;-) system sie załadował lecz dalej z błędami w logu:

Jul 27 22:47:55 serwer kernel: hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
Jul 27 22:47:55 serwer kernel: hda: dma_intr: error=0x84 { DriveStatusError BadCRC }

hd parm natomias pokazuje ze udma jest włączone a np jak che odpalic : mc to wywala mi segmentatnion fault :-//

kolejna sprawa jak załaduje linuxa z cd to w logach jest wszystko wpożądku że system wykrył rozpoznał itd karte :-/
wepne karte jeszcze pod innego kompa i zobaczę jaka dostane informacje ale normalnie idzie zgłupieć :-/

Awatar użytkownika
coolart
Użytkownik
Posty: 250
Rejestracja: 2004-06-20, 03:08
Kontakt:

Re: Problem z załadowaniem systemu :-( ??? z karty CF

Post autor: coolart »

u mnie byly tylko bledy przy ladowaniu sie slacka podobne do twojego ale nie przeszkadzalo mi to bo czesciej chodzil nonstop.
porter_1983 pisze:Jul 27 22:47:55 serwer kernel: hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
Jul 27 22:47:55 serwer kernel: hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
gorzej bylo z segmentatnion fault ten blad pojawil mi sie po jakims czasie i tylko na starej plycie go mialem i tylko przy edycji przez mc jakis plikow, co dziwne przywiozlem go do polski tam mialem inny zasilacz starszy podlaczylem odpalilem edytowalem paredziesiat plikow i zadnego bledu ta sama plyta ta sama pamiec ino inny zasilacz no tylko podnioslem troche napiecie.

ODPOWIEDZ