Slackware 11 nie widzi dysku SATA

Instalacja Slackware Linux, problemy i wstępna konfiguracja, aktualizacje do nowszych wersji.

Moderatorzy: Moderatorzy, Administratorzy

dr
Użytkownik
Posty: 108
Rejestracja: 2007-01-02, 09:59
Lokalizacja: Iława

Slackware 11 nie widzi dysku SATA

Post autor: dr » 2009-10-05, 20:33

Witam ponownie.
Problemu, który opisywałem w dziale servery/sieci jakby ciąg dalszy.
http://forum.slackware.pl/viewtopic.php?t=21912
Mam tą maszynę. Ostatecznie udało się wyszperać dane z maja tego roku.
Jednak napotykam kolejny problem, z którym nie bardzo daje sobie radę.
Mam ten fizyczny "server" to komputer Dell VOSTRO 220.
I kicha nie jestem w stanie zainstalować na nim slackware 1. System nie widzi dysku. Już wyłączałem w biosie AHCI i przełączałem a ATA.
Przy wybierałem wszystkie dostępne kernele i sata.s i hugesmp i .... i lipa
nie mogę rozpisać partycji ponieważ nie widzi dysku.
Slackware 12.2 i slackware 13 widzi dyski i spokojnie się instaluje.
Niestety 12.2 i 13 ma za wysokie jądro. Do odpalenia progresa najwyższy kernel na jakim udało sie to zrobić to 2.6.18 (test26.s z slackware 11) po lekkim "oszukaństwie export LD_ASSUME_KERNEL=2.4.1 - wtedy startuje instalka) W lackware 12.2 lub 13 jak dam export LD_ASSUME_KERNEL=2.4.1 to juz nie mogę wykonać żadnego polecenia w systemie (error while loading shared libraries: libc.so.6: connot open shared object file: No such file or directory)
Teraz zaczynam rozumieć, dlaczego ktoś postawił virtual slackware 11 w slackware 12.2
Czy widzicie szanse na zainstalowanie slackware 11?
Z góry dzięki za pomoc.
Ostatnio zmieniony 2009-10-06, 06:43 przez dr, łącznie zmieniany 1 raz.

Awatar użytkownika
bzyk
Moderator w st. spocz.
Posty: 991
Rejestracja: 2004-06-05, 06:32
Lokalizacja: Pszczyna
Kontakt:

Re: Slackware 11 nie widzi dysku SATA

Post autor: bzyk » 2009-10-06, 11:10

Nie wiem jaki konkretnie masz kontroler na tym dellu, ale da sie zainstalowac slacka11 na maszynie z sata;

Kod: Zaznacz cały

root@w1b:/home/bzyk# cat /etc/slackware-version
Slackware 11.0.0
root@w1b:/home/bzyk# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda2              19G  1.9G   16G  11% /
/dev/sda3              54G   50G  627M  99% /home
/dev/hdb1             459G  367G   69G  85% /home/admin/===MUZYKA===
/dev/sdc1              28G   24G  2.9G  90% /home/admin/==REZERWA==
/dev/sdc2             431G  373G   37G  92% /home/admin/===FILMY===
/dev/sdb1             459G  406G   30G  94% /home/admin/===PLIKI===
/dev/hda1             367G  318G   31G  92% /home/admin/===FILMY===/===BASNIE-NOWE===
/dev/sdd1             459G  356G   80G  82% /home/admin/===FILMY===/===FILMY2-MEGAKOLEKCJA===
root@w1b:/home/bzyk# uname -a
Linux w1b 2.6.18 #4 Wed Sep 27 23:05:46 CDT 2006 i686 athlon-4 i386 GNU/Linux
root@w1b:/home/bzyk# lspci | grep SATA
00:0f.0 RAID bus controller: VIA Technologies, Inc. VT8251 AHCI/SATA 4-Port Controller
In /dev/null no one can hear you scream.

dr
Użytkownik
Posty: 108
Rejestracja: 2007-01-02, 09:59
Lokalizacja: Iława

Re: Slackware 11 nie widzi dysku SATA

Post autor: dr » 2009-10-06, 12:52

Wiem, że się da ponieważ kilka instalek robiłem na sata i nigdy nie było problemu. Dopiero w tym dell'u pioruńskim takie siupy. Sam już nie wiem - wygląda jakby jądro nie obsługiwało tego sprzętu. :/
Po zainstalowaniu na slackware 12.2

Kod: Zaznacz cały

lspci | grep SATA
00:1f.2 SATA controler: Intel Corporation 82801JI (ICH10 Family) SATA AHCI Controller


[ Dodano: 2009-10-06, 17:02 ]
ech chyba przyjdzie zwirtualizować jedenastkę
Ostatnio zmieniony 2009-10-06, 18:39 przez dr, łącznie zmieniany 3 razy.

Awatar użytkownika
kroqus
Użytkownik
Posty: 141
Rejestracja: 2009-04-22, 15:14

Re: Slackware 11 nie widzi dysku SATA

Post autor: kroqus » 2009-10-23, 18:36

Może to okaże się dla Ciebie pomocne; KLIK , KLIK

carpathia666
Użytkownik
Posty: 29
Rejestracja: 2008-10-19, 11:46

Re: Slackware 11 nie widzi dysku SATA

Post autor: carpathia666 » 2009-10-23, 18:52

moze to nie o to chodzi, ale zawsze przy instalacji slack'a wpisuje:

Kod: Zaznacz cały

cfdisk /dev/sda
, zapisuje tablice i setup'uje.

zawsze dziala ;>

dr
Użytkownik
Posty: 108
Rejestracja: 2007-01-02, 09:59
Lokalizacja: Iława

Re: Slackware 11 nie widzi dysku SATA

Post autor: dr » 2009-10-25, 06:36

kroqus niestety nie dane mi będzie sprawdzić rozwiązania bo już zwirtualizowałem i oddałem maszynę.

carpathia666 u mnie też zawsze działało ;) ten jednak nie widział urządzenia sda

ODPOWIEDZ