Strona 1 z 1

Problemy przy upgrade 12.2->13.37

: 2012-03-12, 14:25
autor: SaraniS
Witam
Ostatnio w końcu zdobyłem się na odwagę, żeby zaktualizować system do ostatniej stabilnej wersji. Wcześniej jeszcze zainstalowałem sobie najnowsze, jakie wtedy było, jądro 3.2.7.
Sama aktualizacja systemu, dzięki poradom PV (plik UPGRADE.TXT) przebiegła bez problemów, system wstał i nawet X zadziałały od razu, gdy usunąłem stary xorg.conf... No i właśnie...
Kartę mam Intel GM965 (tzw. X3100), na starych X działało na module i915 (w xorg.conf wpis: Driver "intel") i ładnie te ~800fps w glxgears miałem. Zaraz po instalacji, gdy chciałem uruchomić okna (z obecnym jeszcze starym configiem), Xserwer się wywalił z błędem "nie umiem znaleźć modułu i915". Bez configa, wg loga, X ładuje zarówno intela jak vesę.
Więc takie moje pytania:
1) Słyszałem, że zmieniły się ścieżki modułów pomiędzy wersją X ze Slacka 12.2 a tą w dzisiejszym 13.37? Może jakaś dobra dusza podpowiedzieć, dokąd podsymlinkować stare moduły?
2) Tak się zastanawiam - ten moduł i915 jest modułem X, ale czy przypadkiem nie ma na niego zawartosć jądra wpływu? Może bym musiał jajko przekompilować w obecnym systemie?

Tak, obsługę swojej karty mam w jądrze wkompilowaną. I jakoś mi się kojarzy, że po kompilacji jądra, jeszcze na starym systemie i Iksach, też chyba już akceleracji nie miałem...
Pomocy! ;)

Przy okazji - ma ktoś yakuake 2.8.1 skompilowane pod KDE3/QT3, ale z libpng-1.4.5 (czyli pod Slacka 13.37)? ;)

Re: 12.2->13.37, i915 brak akceleracji

: 2012-03-17, 15:54
autor: dienet
Sprawdź, z tego co pamiętam, to wkompilowanie obsługi karty w jądrze może skutkować brakiem akceleracji. W jądrze to jest dodane pod framebuffer...mam nvidię i nie wybieram tego w jądrze nigdy więc nie wybieraj i Ty ;)
Co do i915, to on pochodzi jeśli dobrze się orientuje z paczki więc nie ma czegoś takiego że linkujesz coś gdzieś. Instalujesz paczkę, wpis w xorg.conf i powinno działać.

Re: 12.2->13.37, i915 brak akceleracji

: 2012-03-18, 18:02
autor: SaraniS
Dzięki za odpowiedź.
Problem w tym, że nie chce mi się teraz (po aktualizacji 12.2->13.37) uruchomić "make xconfig":

Kod: Zaznacz cały

make xconfig
  HOSTCXX scripts/kconfig/qconf.o
In file included from /usr/lib/qt/include/QtCore/qobject.h:48:0,
                 from /usr/lib/qt/include/QtGui/qwidget.h:46,
                 from /usr/lib/qt/include/Qt3Support/q3mainwindow.h:45,
                 from scripts/kconfig/qconf.cc:19:
/usr/lib/qt/include/QtCore/qstring.h:60:22: fatal error: string: Nie ma takiego pliku ani katalogu
compilation terminated.
make[1]: *** [scripts/kconfig/qconf.o] Błąd 1
make: *** [xconfig] Błąd 2
najwyraźniej brakuje mu jakichś includów QT, przy czym wszystko, co Slackware daje, mam poinstalowane... Aha, i tak samo dzieje się zarówno spod użytkownika, jak przez sudo.
Spróbowałem przez gconfig, teraz się kompiluje i zaraz zobaczymy...
Co do samej paczki i915, to jak patrzyłem, nic takiego nie ma, jest tylko xf86-video-intel, xf86-video-i740 i xf86-video-i128. Nie patrzyłem jeszcze, możliwe, że w tej paczce xf86-video-intel jest moduł i915.
Jeszcze mam takie pytanko: które z paczek xf86-video-* są niezbędne? Początkowo władowałem full, ale zabrakło mi na system 10GB partycji :D Tak, że chciałbym coś odkroić z rzeczy których i tak nie używam...
W jądrze mam tylko zaznaczone AGP oraz DRM

Re: 12.2->13.37, i915 brak akceleracji

: 2012-03-18, 18:16
autor: ydoom
Czy masz zainstalowaną paczkę glibc? Ten include, który wyrzuca błąd to "#include <string>"...

Re: 12.2->13.37, i915 brak akceleracji

: 2012-03-18, 18:31
autor: dienet
WOW od kiedy xconfig używa qt ?;) Ja tam zawsze odpalam make menuconfig.
Raczej brakuje mu: gcc-g++-4.5.2-x86_64-2

Kod: Zaznacz cały

[(T61)/var/log/packages]$ grep * -e "c++/4.5.2/string" 
gcc-g++-4.5.2-x86_64-2:usr/include/c++/4.5.2/string
Z serii paczek xf86-video nie potrzebujesz żadnej (chyba że ten i915). Ja mam:

Kod: Zaznacz cały

xf86-video-nouveau-8bb82312-x86_64-1
xf86-video-nv-2.1.18-x86_64-1
xf86-video-vesa-2.3.0-x86_64-3
ale nic z tego nie używam, chyba że jakaś nagła sprawa np. ratowanie systemu wtedy vesa, nv mi się mogą przydać.

ydoom - 200 postów ;)

Re: 12.2->13.37, i915 brak akceleracji

: 2012-03-18, 19:12
autor: SaraniS
@dienet: niby to jakoś zależne jest od używanego środowiska graficznego, tak gdzieś wyczytałem - jak używasz qt/ KDE, to xconfig mapuje się na qconfig, jak Gnome to na gconfig, itd.
Paczki mam wszystkie z Slackware 13.37, aktualizowałem slackpkg upgrade oraz slackpkg install-new
Nie mam tylko paczek dla KDE4 (amarok, k3b3, kde*) oraz qca i proppler mam starsze wersje pod qt3.
Tak czy siak po rekompilacji jądra (wow, ani kernel-panica nie zaliczyłem ;) )efekt jest taki, że X już nie skarży się o brak modułu i915, natomiast po załadowaniu z xorg.conf sterownika intel wywala mi no screens found. Jak uruchamiam bez xorg.conf, to ładuje i intel i vesę, ale działa chyba na vesie, bo po akceleracji nie ma śladu. Aha, i bez xorg.conf - nie umie mi znaleźć sterownika fbdev. To w sumie jedyny błąd w Xorg.0.log.

Kod: Zaznacz cały

saranis@zuberek ~ $ grep '(EE)' /var/log/Xorg.0.log
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1415.398] (EE) Failed to load module "fbdev" (module does not exist, 0)
W sumie wykrywanie myszy, klawiatury, touchpada działa całkiem fajnie, i mogłoby zostać, ale z grafiką coś jest (ja mam?) przekombinowane...
Co do wspomnianych przez Was paczek:

Kod: Zaznacz cały

saranis@zuberek ~ $ ls /var/log/packages/gc*
/var/log/packages/gcc-4.5.2-i486-2           /var/log/packages/gcc-java-4.5.2-i486-2
/var/log/packages/gcc-g++-4.5.2-i486-2       /var/log/packages/gccmakedep-1.0.2-noarch-2
/var/log/packages/gcc-gfortran-4.5.2-i486-2  /var/log/packages/gcc-objc-4.5.2-i486-2
/var/log/packages/gcc-gnat-4.5.2-i486-2      /var/log/packages/gconf-2.24.0-i486-2as
saranis@zuberek ~ $ ls /var/log/packages/glib*
/var/log/packages/glib-1.2.10-i486-3
/var/log/packages/glib2-2.28.6-i486-1
/var/log/packages/glibc-2.13-i486-5_slack13.37
/var/log/packages/glibc-i18n-2.13-i486-5_slack13.37
/var/log/packages/glibc-profile-2.13-i486-5_slack13.37
/var/log/packages/glibc-solibs-2.13-i486-5_slack13.37
/var/log/packages/glibc-zoneinfo-2.13-noarch-5_slack13.37
/var/log/packages/glibmm-2.18.1-i686-1X
Tak teraz patrzę, to chyba te glibc* mam jakieś nie z oficjalnego wydania (na co wskazywałby suffix)? Zaraz się nimi zajmę... Jednak w tej chwili i tak mniej istotne jest dla mnie make qconfig a bardziej ta akceleracja...
Hm, jak widzę, są nawet nowsze niż w oficjalnym... Dobra, nie wiem skąd je wziąłem, można je wrócić do wersji dystrybucyjnej...

Re: 12.2->13.37, i915 brak akceleracji

: 2012-03-18, 20:13
autor: ydoom
Paczki glibc wydają się prawidłowe. A jak zrobisz:

Kod: Zaznacz cały

cat > /tmp/test.cpp << EOF                  
#include <string>
int main() { return 0; }
EOF
gcc /tmp/test.cpp
to zwraca błąd?
ydoom - 200 postów ;)
Czekamy na 1337 :D

Re: 12.2->13.37, i915 brak akceleracji

: 2012-03-18, 20:32
autor: SaraniS
Zwraca (chyba) dokładnie to samo:

Kod: Zaznacz cały

saranis@zuberek ~ $ cat > /tmp/test.cpp << EOF
> #include <string>
> int main() { return 0; }
> EOF
saranis@zuberek ~ $ gcc /tmp/test.cpp
/tmp/test.cpp:1:18: fatal error: string: Nie ma takiego pliku ani katalogu
compilation terminated.
saranis@zuberek ~ $ gcc -v
Reading specs from /usr/lib/gcc/i486-slackware-linux/4.5.2/specs
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/i486-slackware-linux/4.5.2/lto-wrapper
Target: i486-slackware-linux
Configured with: ../gcc-4.5.2/configure --prefix=/usr --libdir=/usr/lib --mandir=/usr/man --infodir=/usr/info --enable-shared --enable-bootstrap --enable-languages=ada,c,c++,fortran,java,objc,lto --enable-threads=posix --enable-checking=release --with-system-zlib --with-python-dir=/lib/python2.6/site-packages --disable-libunwind-exceptions --enable-__cxa_atexit --enable-libssp --enable-lto --with-gnu-ld --verbose --with-arch=i486 --target=i486-slackware-linux --build=i486-slackware-linux --host=i486-slackware-linux
Thread model: posix
gcc version 4.5.2 (GCC)
Nagłówków jądra mi brakuje? (Tego pod którym te biblioteki były kompilowane, nie tego, które mam obecnie) Nie brakuje, mam

Kod: Zaznacz cały

/var/log/packages/kernel-headers-2.6.37.6_smp-x86-2
Jednak bardziej teraz mi zależy na wykryciu, czemu Xserver nie widzi mojej karty... Z tego, co widzę w logach, ładuje moduł intel, po czym momentalnie ładuje alternatywną vesę - i reszta już z jej poziomu przebiega - wykrywa kartę

Kod: Zaznacz cały

[  1415.464] (II) VESA(0): VESA VBE OEM: Intel(r)Crestline Graphics Chip Accelerated VGA BIOS
[  1415.464] (II) VESA(0): VESA VBE OEM Software Rev: 1.0
[  1415.464] (II) VESA(0): VESA VBE OEM Vendor: Intel Corporation
[  1415.464] (II) VESA(0): VESA VBE OEM Product: Intel(r)Crestline Graphics Controller
[  1415.464] (II) VESA(0): VESA VBE OEM Product Rev: Hardware Version 0.0
następnie stwierdza, że ta karta sprzętowo nie obsługuje ani DRI ani DRI2, po czym ładuje swrast_dri.so podczas gdy w /usr/lib/xorg/modules/dri/ siedzą sobie i się nudzą zarówno i915_dri.so, jak i i965_dri.so...
O co tu chodzi?
Powtarzam, gdy użyję swojego xorg.conf w którym mam wpisane użycie tylko sterownika intel, Xserver wywala mi błąd, że nie znalazł ekranu...
Podobnie (też sprawdziłem) - po odinstalowaniu vesy, w trybie automatycznym też niby ładuje intela, ale twierdzi że nie ma urządzeń.
Czyżby w nowej wersji X sterownik intela nie obsługiwał już X3100 (Intel Corporation Mobile GM965/GL960)?
-----
Coś muszę jednak mieć nie tak w jądrze - szukałem po internecie i wg tam zamieszczonych Xorg.0.logów sterownik intel rozpoznaje ten chipset i pięknie ładuje DRI dla niego. Mowa o tej samej wersji Xorg/ sterownika intela. Pytanie, co się w jądrze zmieniło od wersji 2.6.30.3 do wersji 3.2.7, że na tamtej mi działało, a teraz nie chce? Konfigurację opieram cały czas na pliku .config właśnie z wersji 2.6.30.3...
A swoją drogą - skoro nie mam includów dla gcc/ nie są one widziane przez gcc, to jakim cudem mi się jądro kompiluje bez błędów?
Najprościej by było zrobić rm -rf / a następnie zainstalować slacka na czysto, ale z 2 powodów mi się to nie podoba: mam sporo third-party programów i nie chciałoby mi się ich ponownie instalować, a poza tym musiałbym się bawić z odpalaniem z USB a potem netinstall. No i - to by nie było rozwiązanie problemu a tylko próba jego pominięcia, wcale nie wiadomo zresztą czy skuteczna...
A tak żeby już w ogóle nie wiedzieć co się dzieje:

Kod: Zaznacz cały

saranis@zuberek ~ $ ls /usr/include/c++/4.5.2/string
/usr/include/c++/4.5.2/string
:rotfl:

Re: 12.2->13.37, i915 brak akceleracji

: 2012-03-18, 22:07
autor: alekow
Spróbuj wywalić xorg.conf a w katalogu /etc/X11/xorg.conf.d utworzyć minimalny plik "10-monitor.conf" o zawartości typu:

Kod: Zaznacz cały

Section "Device"
    Identifier    "Device"
    Driver        "TWOJ_DRIVER"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device        "Device"
    DefaultDepth    24
EndSection
PS:
Najprościej będzie chyba skorzystać z kernela generic ze slackware. Jeśli chcesz koniecznie 3.2.X to zaktualizuj do slackware-current, albo użyj configa do 3.2.7 z currenta.

Pozdr.

Re: 12.2->13.37, i915 brak akceleracji

: 2012-03-19, 01:26
autor: SaraniS
Właśnie takiego konkretu mi było trzeba :)
Kopałem się jak głupi w dokumentacji nowych X w poszukiwaniu, gdzie się obecnie umieszcza konfigurację grafiki; na plik monitor bym nie wpadł, raczej przypuszczałem że będzie to jakiś graphic_card albo co ;)
No kernel właśnie wolałbym najnowszy; nie wiem od jakiej wersji jest w nim (wbudowana, bez patchy) obsługa UVC; w moim 2.6.30.3 jeszcze jej chyba nie było (nie zauważyłem). Przez to UVC w sumie zaktualizowałem cały system - bo po aktualizacji jądra kamerka i owszem, zadziałała, ale Skype się nie chciał zaktualizować do 2.2 (za stare liby), więc po kolei poleciałem wszystko ;)
Dziś to już padam raczej, ale jutro podejmuję walkę ;)
Na początek i to dziś jeszcze, sprawdzę ten plik w xorg.xonf.d, i może zainstaluję fabryczne paczkowe jądro z 13.37 - w nim już chyba jest UVC (zdaje mi się, że mi się rzuciło w oczy). Jak to nic nie da, to jutro kompiluję 3.2.7 na configu z currenta... Poza tym, wymyśliłem, że jeszcze pozostaje mi downgrade jądra do tego z 13.37 (co właśnie dziś zrobię) i/ albo downgrade X do wersji z 12.2 na której mi działała akceleracja...
Swoją drogą - próbowałem przed chwilą starego jądra (tego 2.6.30.3) i na nim też X twierdzi że nie umie znaleźć modułu i915 (akurat w nim mam go wkompilowanego, w sumie z modułów mam tam tylko rtl8187, którego się nie da wkompilować nawet w najnowszym 3.2.7)... To jak wcześniejszy Xserver mógł działać i nawet mieć akcelerację?.. Dziwne...

W każdym razie strasznie duże niekompatybilności teraz są... Pamiętam, od 10.0 do 12.2 używałem current i nie było problemu, żeby sobie co tydzień nowe jądro na starym configu robić... Tylko patrzyłem jakie nowe opcje weszły i odpowiednie za/od/znaczałem a teraz jakoś to nie zadziałało...
-----
Ciekawe, na jądrze 2.6.37.6 akceleracja działa, za to zepsuła się Alsa... Wcześniej miałem wkompilowane sterowniki (HDA_INTEL) w jądro, z kompletnie wyłączonym OSS - teraz mam huge i... właśnie, huge niby też powinno mieć wkompilowane? Spojrzałem w /etc/alsa - jest jakiś plik od bluetooth tylko... gdzie się teraz konfiguruje Alsę i jak najlepiej to zrobić pod HDA_INTEL bez rekompilacji jądra?
W TDE nie używam arts, tylko play, a i tak większość programów odwołuje się do miksera bezpośrednio.

Re: 12.2->13.37, i915 brak akceleracji

: 2012-03-19, 02:31
autor: ydoom
SaraniS pisze:A tak żeby już w ogóle nie wiedzieć co się dzieje:

Kod: Zaznacz cały

saranis@zuberek ~ $ ls /usr/include/c++/4.5.2/string
/usr/include/c++/4.5.2/string
:rotfl:
:rotfl:

To jeszcze można sprawdzić ścieżki:
DLA C:

Kod: Zaznacz cały

gcc -xc -E -v -
U mnie daje:

Kod: Zaznacz cały

Reading specs from /usr/lib/gcc/i486-slackware-linux/4.5.2/specs
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/i486-slackware-linux/4.5.2/lto-wrapper
Target: i486-slackware-linux
Configured with: ../gcc-4.5.2/configure --prefix=/usr --libdir=/usr/lib --mandir=/usr/man --infodir=/usr/info --enable-shared --enable-bootstrap --enable-languages=ada,c,c++,fortran,java,objc,lto --enable-threads=posix --enable-checking=release --with-system-zlib --with-python-dir=/lib/python2.6/site-packages --disable-libunwind-exceptions --enable-__cxa_atexit --enable-libssp --enable-lto --with-gnu-ld --verbose --with-arch=i486 --target=i486-slackware-linux --build=i486-slackware-linux --host=i486-slackware-linux
Thread model: posix
gcc version 4.5.2 (GCC) 
COLLECT_GCC_OPTIONS='-E' '-v' '-mtune=i486' '-march=i486'
 /usr/libexec/gcc/i486-slackware-linux/4.5.2/cc1 -E -quiet -v - -mtune=i486 -march=i486
ignoring nonexistent directory "/usr/lib/gcc/i486-slackware-linux/4.5.2/../../../../i486-slackware-linux/include"
#include "..." search starts here:
#include <...> search starts here:
 /usr/local/include
 /usr/lib/gcc/i486-slackware-linux/4.5.2/include
 /usr/lib/gcc/i486-slackware-linux/4.5.2/include-fixed
 /usr/include
End of search list.
Dla C++:

Kod: Zaznacz cały

gcc -xc++ -E -v -
U mnie daje:

Kod: Zaznacz cały

Reading specs from /usr/lib/gcc/i486-slackware-linux/4.5.2/specs
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/i486-slackware-linux/4.5.2/lto-wrapper
Target: i486-slackware-linux
Configured with: ../gcc-4.5.2/configure --prefix=/usr --libdir=/usr/lib --mandir=/usr/man --infodir=/usr/info --enable-shared --enable-bootstrap --enable-languages=ada,c,c++,fortran,java,objc,lto --enable-threads=posix --enable-checking=release --with-system-zlib --with-python-dir=/lib/python2.6/site-packages --disable-libunwind-exceptions --enable-__cxa_atexit --enable-libssp --enable-lto --with-gnu-ld --verbose --with-arch=i486 --target=i486-slackware-linux --build=i486-slackware-linux --host=i486-slackware-linux
Thread model: posix
gcc version 4.5.2 (GCC) 
COLLECT_GCC_OPTIONS='-E' '-v' '-mtune=i486' '-march=i486'
 /usr/libexec/gcc/i486-slackware-linux/4.5.2/cc1plus -E -quiet -v -D_GNU_SOURCE - -mtune=i486 -march=i486
ignoring nonexistent directory "/usr/lib/gcc/i486-slackware-linux/4.5.2/../../../../i486-slackware-linux/include"
#include "..." search starts here:
#include <...> search starts here:
 /usr/lib/qt/include
 /usr/lib/gcc/i486-slackware-linux/4.5.2/../../../../include/c++/4.5.2
 /usr/lib/gcc/i486-slackware-linux/4.5.2/../../../../include/c++/4.5.2/i486-slackware-linux
 /usr/lib/gcc/i486-slackware-linux/4.5.2/../../../../include/c++/4.5.2/backward
 /usr/local/include
 /usr/lib/gcc/i486-slackware-linux/4.5.2/include
 /usr/lib/gcc/i486-slackware-linux/4.5.2/include-fixed
 /usr/include
End of search list.

Re: 12.2->13.37, i915 brak akceleracji

: 2012-03-19, 08:01
autor: alekow
Właśnie takiego konkretu mi było trzeba :)
Kopałem się jak głupi w dokumentacji nowych X w poszukiwaniu, gdzie się obecnie umieszcza konfigurację grafiki; na plik monitor bym nie wpadł, raczej przypuszczałem że będzie to jakiś graphic_card albo co ;)
Plik możesz nazwać inaczej, nawet "graphics_card.conf". Nie o to chodzi. Zdaje się że możesz też trzymać konfigurację nadal w pliku /etc/X11/xorg.conf. Moim zamysłem było to, żebyś utworzył minimalną konfigurację z minimalną ilością ustawień, bo większość jest wykrywana automatycznie. Tylko to co nie działa.

Re: Problemy przy upgrade 12.2->13.37

: 2012-03-19, 09:41
autor: SaraniS
No to już w sumie wiemy, że problem był najpewniej w tym nowym jądrze, czy jego niewłaściwej konfiguracji. Czy to był plik w xorg.conf.d, czy w samym xorg.conf, czy automat - X nie wykrywał karty Intela. Na jądrze fabrycznym, bez rekompilacji, działa niemalże "z palca" (choć zostawiłem ten plik w xorg.conf.d).
Teraz nie wiem co zrobić, chyba tytuł zmienię, bo jakkolwiek z grafiką sobie poradziłem ale mamy kolejne problemy :D I niech to może zostanie taki zbiorczy topic o problemach przy aktualizacji z 12.2 do 13.37 ;)

@ydoom:

Kod: Zaznacz cały

saranis@zuberek ~ $ gcc -xc -E -v -
Reading specs from /usr/lib/gcc/i486-slackware-linux/4.5.2/specs
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/i486-slackware-linux/4.5.2/lto-wrapper
Target: i486-slackware-linux
Configured with: ../gcc-4.5.2/configure --prefix=/usr --libdir=/usr/lib --mandir=/usr/man --infodir=/usr/info --enable-shared --enable-bootstrap --enable-languages=ada,c,c++,fortran,java,objc,lto --enable-threads=posix --enable-checking=release --with-system-zlib --with-python-dir=/lib/python2.6/site-packages --disable-libunwind-exceptions --enable-__cxa_atexit --enable-libssp --enable-lto --with-gnu-ld --verbose --with-arch=i486 --target=i486-slackware-linux --build=i486-slackware-linux --host=i486-slackware-linux
Thread model: posix
gcc version 4.5.2 (GCC)
COLLECT_GCC_OPTIONS='-E' '-v' '-mtune=i486' '-march=i486'
 /usr/libexec/gcc/i486-slackware-linux/4.5.2/cc1 -E -quiet -v - -mtune=i486 -march=i486
ignoring nonexistent directory "/usr/lib/gcc/i486-slackware-linux/4.5.2/../../../../i486-slackware-linux/include"
#include "..." search starts here:
#include <...> search starts here:
 /usr/local/include
 /usr/lib/gcc/i486-slackware-linux/4.5.2/include
 /usr/lib/gcc/i486-slackware-linux/4.5.2/include-fixed
 /usr/include
End of search list.
Czemu on najpierw w /usr/local/include szuka zamiast w /usr/include? Chociaż nie wiem czy ma to znaczenie bo w końcu tą ścieżkę gdzie plik string jest, też ma w swojej ścieżce...
-----
Z problemów zostało mi co powyżej, oraz...
Jak, do diaska, wyłączyć oszczędzanie energii?.. Wygaszacz w KDE (przepraszam, TDE) ogarnąłem poleceniem

Kod: Zaznacz cały

dcop kdesktop KScreensaverIface enable false
i jest OK, ale i tak włącza się setterm blank, mimo, że i w rc.M, i z palca w konsoli (tylko spod init3, tez z Menadżera Okien nie działają) wpisuję

Kod: Zaznacz cały

setterm -blank 0 -powersave off
?
Czy coś się zmieniło od czasów 2.6.30.X? Gdzie teraz ustawia się "oszczędzanie energii ekranu"?