Pakiety niezbędne do kompilacji ze źródeł

Instalacja Slackware Linux, problemy i wstępna konfiguracja, aktualizacje do nowszych wersji.

Moderatorzy: Moderatorzy, Administratorzy

sq9sho
Użytkownik
Posty: 4
Rejestracja: 2014-11-14, 11:02

Pakiety niezbędne do kompilacji ze źródeł

Post autor: sq9sho » 2014-11-25, 09:16

Hej,

Mam pytanie dotyczące instalacji pakietów z działu d oraz l, które z nich muszę dodać aby swobodnie móc kompilować programy ze źródeł? Zależy mi na minimalnej działającej ilości. Na chwilę obecną mam coś takiego:

d:
autoconf
automake
binutuils
cmake
gcc
gcc-g++
gcc-objc
gdb
kernel-headers
make
perl
pkg-config
python
slacktrack

l:
glibc
libelf
mpfr
readline
zlib

Wersja Slackware to 14.1.

Pozdrawiam
Czesław SQ9SHO

Awatar użytkownika
mina86
Moderator
Posty: 3314
Rejestracja: 2004-06-14, 21:58
Lokalizacja: Linux 4.x x86_64
Kontakt:

Re: Pakiety niezbędne do kompilacji ze źródeł

Post autor: mina86 » 2014-11-25, 14:54

Zależy które programy. Różne programy korzystają z różnych bibliotek i właśnie te muszą być zainstalowane, aby móc je kompilować. Sprawę komplikują opcjonalne zależności, gdzie to jakiś program może być skompilowany bez jakiejś biblioteki, ale wówczas nie będzie miał jakiejś funkcjonalności. W dużym uproszczeniu, jeżeli jakiś program wymaga danej biblioteki przy uruchamianiu, to będzie jej też wymagał przy kompilacji.
Zastrzegam sobie prawo nieanalizowania postów pisanych niepoprawną polszczyzną. :: Post generated automatically by A.I. system called “mina86” in response to the previous one. :: Tiny Applications

ODPOWIEDZ