Kernel 2.6.13, Athlon XP-M i cpufreq

Instalacja Slackware Linux, problemy i wstępna konfiguracja, aktualizacje do nowszych wersji.

Moderatorzy: Moderatorzy, Administratorzy

bialy
Użytkownik
Posty: 28
Rejestracja: 2004-11-08, 19:28

Kernel 2.6.13, Athlon XP-M i cpufreq

Post autor: bialy »

Witam,

Mam problem z nowym jajkiem 2.6.13. Po upgradzie z 2.6.11 zauważyłem brak wsprcia dla cpu frequency scaling mimo, że zaznaczone opcje są tak samo jak w wersji poprzedniej. Po skompilowaniu nowego kernela powernowd (odpowiedzialny za skalowanie częstotliwości) mówi, że nie ma procesora wspierającego cpufreq, brak jest wpisów w cpufreq w /sys/devices/system/cpu/cpu0 i ogólnie wszystko świadczy o braku wsparcia dla tego ficzera. :)
Czytałem dołączoną do kernela dokumentacje na ten temat i wygląda na to, że mój procesor (ATHLON MOBILE XP - oznaczany też jako XP-M) wspierany jest przez sterownik powernow7 i ten właśnie zaznaczyłem.

Czy ktoś ma podobny problem po przejściu na nowy kernel? Jeżeli tak to może wybrnął jakoś z sytuacji?
log_out
Użytkownik
Posty: 254
Rejestracja: 2004-08-19, 22:54

Re: Kernel 2.6.13, Athlon XP-M i cpufreq

Post autor: log_out »

A czy przypadkiem do tego ficzera nie jest potrzebny laptop ?? myśle że odpowiedni czipset też jest potrzebny (i bóg wie jakie bebechy jeszcze :twisted: ), ale moge się mylić ;)
sayetan
Moderator w st. spocz.
Posty: 2193
Rejestracja: 2004-06-20, 21:47
Lokalizacja: Jelenia Góra

Re: Kernel 2.6.13, Athlon XP-M i cpufreq

Post autor: sayetan »

Nie, potrzebny jest procesor i sterownik(moduł) obsługujący pod dany procesor.
U mnie na A64 działa z tym, że ja używam programu cpudyn, a nie powernowd.
Teraz nie moge tego sprawdzić, ale po komendzie # dmesg powinieneś ujrzeć linjke, która uaktywnia PowerNow, np. coś takiego:

Kod: Zaznacz cały

powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 1.00.09b)
powernow-k8:    0 : fid 0xe (2200 MHz), vid 0x2 (1500 mV)
powernow-k8:    1 : fid 0xc (2000 MHz), vid 0x6 (1400 mV)
powernow-k8:    2 : fid 0x2 (1000 MHz), vid 0x12 (1100 mV)
powernow-k8: cpu_init done, current fid 0xe, vid 0x2
bialy
Użytkownik
Posty: 28
Rejestracja: 2004-11-08, 19:28

Re: Kernel 2.6.13, Athlon XP-M i cpufreq

Post autor: bialy »

log_out pisze:A czy przypadkiem do tego ficzera nie jest potrzebny laptop ?? myśle że odpowiedni czipset też jest potrzebny (i bóg wie jakie bebechy jeszcze :twisted: ), ale moge się mylić ;)
Nie jest potrzebny laptop, co nie zmienia faktu, że go posiadam :)
sayetan pisze:eraz nie moge tego sprawdzić, ale po komendzie # dmesg powinieneś ujrzeć linjke, która uaktywnia PowerNow, np. coś takiego:
Dzięki. Ja wiem, że pojawia się takie coś, ale... może zademonstruje obrazkowo :)
Na 2.6.11 widzę, przy starcie:

Kod: Zaznacz cały

powernow: PowerNOW! Technology present. Can scale: frequency and voltage.
powernow: SGTC: 13333
powernow: Minimum speed 400 MHz. Maximum speed 2133 MHz.
Potem powernowd mówi do mnie:

Kod: Zaznacz cały

powernowd: PowerNow Daemon v0.96, (c) 2003-2005 John Clemens
powernowd: Found 1 cpu:  -- 1 thread (or core) per physical cpu
powernowd:   cpu0: 400Mhz - 2133Mhz (6 steps)
Natomiast na 2.6.13 sprawa ma się tak, dmesg:

Kod: Zaznacz cały

powernow: PowerNOW! Technology present. Can scale: frequency and voltage.
i powernowd:

Kod: Zaznacz cały

powernowd: PowerNow Daemon v0.96, (c) 2003-2005 John Clemens
powernowd: Found 1 cpu:  -- 1 thread (or core) per physical cpu
/sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_max_freq: No such file or directory

PowerNowd encountered and error and could not start.
Please make sure that:
 - You are running a v2.6.7 kernel or later
 - That you have sysfs mounted /sys
 - That you have the core cpufreq and cpufreq-userspace
   modules loaded into your kernel
 - That you have the cpufreq driver for your cpu loaded,
   and that it works. (check dmesg for errors)
If all of the above are true, and you still have problems,
please email the author: clemej@alum.rpi.edu
Ustawienia jądra 2.6.13:

Kod: Zaznacz cały

Power management options (ACPI, APM)  --->CPU Frequency scaling  --->
[*] CPU Frequency scaling
Default CPUFreq governor (userspace)  --->
<*>   'performance' governor
<*>   'powersave' governor
---   'userspace' governor for userspace frequency scaling
<*>   'ondemand' cpufreq policy governor
<*>   'conservative' cpufreq governor
---   CPUFreq processor drivers
<*>   ACPI Processor P-States driver
<*>   AMD Mobile Athlon/Duron PowerNow!
Wydaje mi się, że wszystko jest włączone poprawnie, jednak jak widać powernowd nie działa, cpufreqd także zgłasza problem. Nie czepiałbym się gdyby nie to, że wentylatory włączone są cały czas co zaczyna irytować :)
ODPOWIEDZ