INIT: No inittab file found

Instalacja Slackware Linux, problemy i wstępna konfiguracja, aktualizacje do nowszych wersji.

Moderatorzy: Moderatorzy, Administratorzy

stanislavus
Użytkownik
Posty: 8
Rejestracja: 2005-11-29, 15:17

INIT: No inittab file found

Post autor: stanislavus » 2005-11-29, 15:51

cześć,
jestem bardzo początkującym użytkownikiem linuxa, instalowałem Slacka 10.2 i chociaż instalacja przebiegła pomyślnie ( nie było żadnych komunikatów o błędach w trakcie instalowania ), to po uruchomieniu komputera pojawia sie napis:

INIT: no inittable found.
enter runlevel:

i nie zależnie co wpisuje odpowiada :
INIT: No more processes left in this runlevel

Poprzednio na tym samym komputerze instalowałem Slacka 9.1 i błąd był ten sam. Czy ktoś wie co robię źle ??

Z góry dziękuja za pomoc.

Stanislavus

mpier
Użytkownik
Posty: 1002
Rejestracja: 2005-10-01, 13:24
Lokalizacja: Blachownia||Cz-wa
Kontakt:

Re: INIT: No inittab file found

Post autor: mpier » 2005-11-29, 16:27

Nie wiem co zaistaowałeś i gdzie. Strzelam: wsadziłeś /etc na inną partycję.

BeteNoire
Użytkownik
Posty: 2666
Rejestracja: 2005-03-21, 01:39
Lokalizacja: z lasu

Re: INIT: No inittab file found

Post autor: BeteNoire » 2005-11-29, 16:32

A ja stawiam na wskazanie w lilo nie tej partycji co trzeba.
stanislavus, pokaż lilo.conf i fstab.

stanislavus
Użytkownik
Posty: 8
Rejestracja: 2005-11-29, 15:17

Re: INIT: No inittab file found

Post autor: stanislavus » 2005-11-30, 15:21

Wielkie dzięki!
Jak sprawdzilem to faktycznie /etc był na innej partycji. Teraz system ładuje się bez problemów :) . Gratuluję strzału. Jeszcze raz wielkie dzieki.

Stanislavus

qbsterr
Użytkownik
Posty: 25
Rejestracja: 2007-12-02, 13:01

Re: INIT: No inittab file found

Post autor: qbsterr » 2014-03-15, 23:03

Troche stare ale jare - jak to sie mowi.

Dzieki - strzal w dziesiatke :)

Slack 14.
[url=http://www.speedtest.net][img]http://www.speedtest.net/result/256704113.png[/img][/url]

cent4
Użytkownik
Posty: 279
Rejestracja: 2012-03-20, 11:18

Re: INIT: No inittab file found

Post autor: cent4 » 2015-10-09, 11:57

Też mam taki problem ale kompletnie nie wiem jak przywrócić etc na swoje miejsce - proszę pilnie o pomoc - cała firma stoi...

Awatar użytkownika
webster
Użytkownik
Posty: 1266
Rejestracja: 2009-10-06, 11:58
Lokalizacja: Gdańsk
Kontakt:

Re: INIT: No inittab file found

Post autor: webster » 2015-10-09, 12:22

Cent4 - co się dzieje, dokładnie, Pisz
††† Chaos Of The Mirror - Valheru †††
††† I ♥ SlackWare RuLeZ †††

Slackware Poland FaceBook

cent4
Użytkownik
Posty: 279
Rejestracja: 2012-03-20, 11:18

Re: INIT: No inittab file found

Post autor: cent4 » 2015-10-09, 12:49

Najpierw miałem:
INIT: No inittab file found
i system się zawieszał - nie można było nic wpisać
Teraz mam taką sytuację, że system startuje tylko niczego w jakby w etc nie widzi
Natomiast do etc się da wejść z linii poleceń
ale zauważyłem, że chyba mi zniknęła jedna partycja ;-(.
Jak daję df -h to mam tylko 3 a wcześniej były 4.
Ogólnie jest fatalnie.
Nie wiem dlaczego ale jak system się uruchamia to widzę, że wszystko do czego się odnosi do etc - to zwraca błąd, że nie można uruchomić pliku, bo nie istnieje

Awatar użytkownika
webster
Użytkownik
Posty: 1266
Rejestracja: 2009-10-06, 11:58
Lokalizacja: Gdańsk
Kontakt:

Re: INIT: No inittab file found

Post autor: webster » 2015-10-09, 12:55

Daj

ls /etc/

cat /etc/fstab
††† Chaos Of The Mirror - Valheru †††
††† I ♥ SlackWare RuLeZ †††

Slackware Poland FaceBook

cent4
Użytkownik
Posty: 279
Rejestracja: 2012-03-20, 11:18

Re: INIT: No inittab file found

Post autor: cent4 » 2015-10-09, 13:01

/dev/md3 swap swap defaults 0 0
/dev/md0 / ext4 defaults 1 1
/dev/md1 /home ext4 defaults,usrquota 1 2
/dev/md2 /var ext4 defaults 1 2
/dev/cdrom /mnt/cdrom auto noauto,owner,or 0 0
devpts /dev/pts dvpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0
none /proc/bus/usb usbfs defaults 0 0
/dev/sdc /mnt/backup ext4 auto,defaults 1 2

cent4
Użytkownik
Posty: 279
Rejestracja: 2012-03-20, 11:18

Re: INIT: No inittab file found

Post autor: cent4 » 2015-10-09, 13:06

jeszcze taka podpowiedź bo to widzę pod knopixem - jak jestem na swoim slackware to przy df -h nie widzę wszystkich podmontowanych md - brakuje md3

cent4
Użytkownik
Posty: 279
Rejestracja: 2012-03-20, 11:18

Re: INIT: No inittab file found

Post autor: cent4 » 2015-10-09, 13:27

Jestem w wielkiej kropce - do ktorej godziny moge liczyc na pomoc? Firma stoi i nie wiem jak bedzie

Awatar użytkownika
webster
Użytkownik
Posty: 1266
Rejestracja: 2009-10-06, 11:58
Lokalizacja: Gdańsk
Kontakt:

Re: INIT: No inittab file found

Post autor: webster » 2015-10-09, 13:47

To co mi dałeś wyżej to fstab czy mount ? bo potrzebuje fstab
††† Chaos Of The Mirror - Valheru †††
††† I ♥ SlackWare RuLeZ †††

Slackware Poland FaceBook

cent4
Użytkownik
Posty: 279
Rejestracja: 2012-03-20, 11:18

Re: INIT: No inittab file found

Post autor: cent4 » 2015-10-09, 13:53

To zawartość pliku /etc/fstab

Awatar użytkownika
webster
Użytkownik
Posty: 1266
Rejestracja: 2009-10-06, 11:58
Lokalizacja: Gdańsk
Kontakt:

Re: INIT: No inittab file found

Post autor: webster » 2015-10-09, 13:55

Czyli tak,

md3 nie realizujesz w fstab, więc Zignoruj swoje przeczucie o md3 - system nie korzysta z niego.
Mogłeś odnieść się do pliku "/etc/fstab" tak więc rozumiem, że zawartość normalnie katalogu "/etc" Masz. Pokaż

Kod: Zaznacz cały

grep "^id:" /etc/inittab
††† Chaos Of The Mirror - Valheru †††
††† I ♥ SlackWare RuLeZ †††

Slackware Poland FaceBook

ODPOWIEDZ