Problemy z kodowaniem unicode po aktualizacji

Czyli jak najefektywniej (lub efektowniej) skonfigurować Slackware'a w komputerze domowym

Moderatorzy: Moderatorzy, Administratorzy

Jakiego kodowania używam w slackware/linuksie

iso 8859-2
5
36%
iso 8859-1
0
Brak głosów
UTF-8
9
64%
innego
0
Brak głosów
 
Liczba głosów: 14

Awatar użytkownika
alekow
Użytkownik
Posty: 262
Rejestracja: 2007-11-30, 17:33
Lokalizacja: Poznań
Kontakt:

Problemy z kodowaniem unicode po aktualizacji

Post autor: alekow » 2009-03-12, 11:12

Po aktualizacji do najnowszego currenta mc pod konsolą nie wyświetla poprawnie polskich znaków. Sama konsola wyświetla poprawnie zarówno polskie jak i inne litery, podobnie mc poza x-em - tu też jest wszystko w porządku.

Przed aktualizacją używałem kde 4.2. Wyświetlanie znaków było poprawne, choć pod konsolą nie działała klawiatura numeryczna.

System jest w UNICODE:

lang.sh:

Kod: Zaznacz cały

export LC_ALL=pl_PL.UTF-8
export LESSCHARSET=latin1
export LC_COLLATE=pl_PL.UTF-8


rc.font

Kod: Zaznacz cały

setfont -v lat2-16.psfu.gz
w rc.M jest dodana linijka

Kod: Zaznacz cały

unicode_start
Czy spotkał się ktoś już z tym? Czy ma ktoś jakiś pomysł jak to poprawić?

----------------------------------------------------------------------------------------------------------------------------------
EDIT:
UUUUUUUUUPS!!!

jest i większy problem.

gdy próbuję otworzyć plik z katalogu który ma w nazwie polskie znaki pojawia się błąd, np.:

Kod: Zaznacz cały

Nie można otworzyć file:///home/alekow/KsiÄ�żki/chemia leków/burger's medicinal chemistry/4.pdf
----------------------------------------------------------------------------------------------------------------------------------
EDIT:

Sprawdziłem pod xfce - też są problemy z kodowaniem więc to nie wina kde. coś się musiało zmienić po zmianach w nowym currencie. Ale co?

EDIT2:

ZAŁĄCZAM ANKIETĘ
Ostatnio zmieniony 2009-03-23, 23:44 przez alekow, łącznie zmieniany 5 razy.

files
Użytkownik
Posty: 25
Rejestracja: 2009-03-08, 10:13
Lokalizacja: Radom
Kontakt:

Re: Problemy z kodowaniem unicode po aktualizacji

Post autor: files » 2009-03-19, 10:43

może zmień kodowanie na ISO8859-2
1. lang.sh
Na początek edytujemy /etc/profile.d/lang.sh hashując (lub kasując) zawartość i wpisując:
Kod:

Kod: Zaznacz cały

#!/bin/sh
# ustawienia językowe

export LANG=pl_PL
export LC_ALL=pl_PL
export LESSCHARSET=latin1
Po tym należy wydać jeszcze następujące polecenie:
Kod:

Kod: Zaznacz cały

# localedef -i pl_PL -f ISO-8859-2 pl_PL --quiet
2.W katalogu /etc/rc.d powinny znajdować się pliki: rc.font oraz rc.keymap. Jeśli nie ma pliku rc.font a jest rc.font-sample to należy utworzyć ten plik np. poprzez skopiowanie pliku rc.font-sample pod nazwą rc.font lub utworzyć go na nowo, pamiętając o tym aby nadać mu atrybut wykonywalności. (chmod +x rc.font).
W pierwszym z wymienionych plików (rc.font) powinien się znajdować wpis
Kod:

Kod: Zaznacz cały

setfont -v lat2a-16.psfu.gz
Jeśli takowego nie ma to należy dopisać. W drugim zaś pliku (rc.keymap) powinien wystąpić wpis
Kod:

Kod: Zaznacz cały

/usr/bin/loadkeys pl2.map
3. Terminal pod X
Jeśli korzystamy z GNOME/gdm, to od razu można wybrać polski język. W tym przypadku znanym (i do tej pory nierozwiązanym) problemem był fakt, że po uruchomieniu terminala pod X, polskie czcionki np. w mc wyświetlane są jako kwadraciki. Dzieje się tak dlatego, że dla języka polskiego domyślnie ustawiany jest standard kodowania UTF-8. Wystarczy wyedytować plik ~/.dmrc i zmienić jedną linijkę na:
Kod:

Kod: Zaznacz cały

Language=pl_PL.ISO8859-2
Od tej pory polskie znaki w aplikacjach konsolowych odpalonych pod X będą wyświetlane poprawnie :D

4. Midnight Commander
Aby spolszczyć MC (Midnight Commander'a) należy przejść do opcji (w menu - klawiszem F9) OPTIONS –> DISPLAY BITS. Tam wybieramy opcję SELECT i wybieramy pozycję ISO-8859-2. Następnie zaznaczamy spacją pole FULL 8 BITS INPUT. Potwierdzamy OK.,a następnie wywołujemy opcję OPTIONS –> SAVE SETUP, wcześniej wchodząc do menu klawiszem F9. Taką prcedurę powinien wykonać każdy użytkownik, który pragnie mieć MC z obsługą polskich znaków.

5. Zmiana układu klawiatury w KDE
Zauważyłem, że nawet po zainstalowaniu polskich paczek do KDE i we wstępnym skonfigurowaniu języka oraz regionu na "Polski" układ klawiatury jest nadal "Amerykański". Nie jest to zbyt dobre rozwiązanie, gdyż nie mamy w takim wypadku dostępu do polskich znaków diakrytycznych w programach odpalonych w KDE.
Aby zmienić taki stan rzeczy otwieramy Centrum sterowania i wybieramy Regionalne i dostępność -> Układ klawiatury.
Zaznaczmy opcję Włącz układ klawiatury a następnie z listy po lewej stronie wybieramy Polski (pl) i klikamy na Dodaj >>. Po tej czynności wybieramy z listy po prawej stronie Amerykański (us) i klikamy na << Usuń. Ostatecznie klikamy na Zastosuj i zamykamy Centrum sterowania.

Spróbuj tych punktów które Ci tu napisałem, aczkolwiek na drugi raz mógłbyś użyć opcji szukaj

Pozdrawiam Files

Awatar użytkownika
alekow
Użytkownik
Posty: 262
Rejestracja: 2007-11-30, 17:33
Lokalizacja: Poznań
Kontakt:

Re: Problemy z kodowaniem unicode po aktualizacji

Post autor: alekow » 2009-03-19, 18:18

Dobra, to teraz mi jeszcze powiedz jak mam zrobić, żeby móc wyświetlać nazwy plików pisane cyrylicą mając system w iso8859-2...

Dzięki za próbę pomocy, ale widzę że spotkałem się z niezrozumieniem. System był, jest i będzie w unicode, bo musi być. Opcja szukaj ani na forum, ani na wyszukiwarce nic mi nie pomogła, bo sprawa jest chyba świeża. Wcześniej system w utf działał mniej-więcej poprawnie.

Awatar użytkownika
marco70
Moderator
Posty: 1105
Rejestracja: 2006-10-26, 19:03
Lokalizacja: K...l

Re: Problemy z kodowaniem unicode po aktualizacji

Post autor: marco70 » 2009-03-19, 19:22

Jaka dokładnie paczka mc ?
Slackware 14.2 kde 4.14.38
i5-6500 CPU @ 3.20GHz

chimi
Użytkownik
Posty: 117
Rejestracja: 2005-05-01, 15:49

Re: Problemy z kodowaniem unicode po aktualizacji

Post autor: chimi » 2009-03-19, 19:28

MC do obsługi Unicode potrzebuje łatek (łatwo znaleźć; nie podaję adresu bo są dwa zestawy i nie wiem, który jest lepszy).
Ogólniejszy problem jest do rozwiązania w /etc/fstab, trzeba ustawić prawidłowo opcje nls, iocharset (dla systemów plików od microsoftu) lub w kernelu - "File systems" | "Native language support" | "Default NLS Option"

Awatar użytkownika
alekow
Użytkownik
Posty: 262
Rejestracja: 2007-11-30, 17:33
Lokalizacja: Poznań
Kontakt:

Re: Problemy z kodowaniem unicode po aktualizacji

Post autor: alekow » 2009-03-19, 19:58

marco70 pisze:Jaka dokładnie paczka mc ?
tutaj nie ma znaczenia paczka mc - problem z kodowaniem jest w całych iksach:

- mc poza iksami wyświetla poprawnie i działa poprawnie.
- mc pod iksami wyświetla poprawnie "ó" "ż" i "ź", pozostałe polskie znaki jako jeden znak zapytania "pozytyw" a drugi "negatyw"
- kde i xfce wyświetlają polskie znaki, ale przy próbie otworzenia pliku albo pokazuje błąd - patrz pierwszy post, albo otwiera plik lecz polskie znaki wyświetla niepoprawnie.

Zrobiłem mały eksperyment - zainstalowałem na próbnej partycji currenta, a na nim x-y z 12.2. Efekt był ciekawy - znaki w iksie wyświetlało niepoprawnie.
chimi pisze:MC do obsługi Unicode potrzebuje łatek
MC w currencie jest spatchowany.
chimi pisze:Ogólniejszy problem jest do rozwiązania w /etc/fstab, trzeba ustawić prawidłowo opcje nls, iocharset
problem nie ma nic wspólnego z partycjami windowsowymi
chimi pisze:lub w kernelu - "File systems" | "Native language support" | "Default NLS Option"
odpalałem system również z kernelem który używałem wcześniej - jest cały czas ten sam problem.
Ostatnio zmieniony 2009-03-24, 00:14 przez alekow, łącznie zmieniany 1 raz.

files
Użytkownik
Posty: 25
Rejestracja: 2009-03-08, 10:13
Lokalizacja: Radom
Kontakt:

Re: Problemy z kodowaniem unicode po aktualizacji

Post autor: files » 2009-03-20, 09:29

Z jakiego terminala korzystasz? Możesz zmienić

Kod: Zaznacz cały

setfont -v lat2-16.psfu.gz
na

Kod: Zaznacz cały

setfont -v lat2a-16.psfu.gz
Ostatnio zmieniony 2009-03-20, 09:32 przez files, łącznie zmieniany 1 raz.

Awatar użytkownika
alekow
Użytkownik
Posty: 262
Rejestracja: 2007-11-30, 17:33
Lokalizacja: Poznań
Kontakt:

Re: Problemy z kodowaniem unicode po aktualizacji

Post autor: alekow » 2009-03-20, 17:31

przy utf powinno być lat2 a nie lat2a. ustawienia localsów czcionek mam takie jak wcześniej mi działały na 12.2
Ostatnio zmieniony 2009-03-20, 17:32 przez alekow, łącznie zmieniany 1 raz.

files
Użytkownik
Posty: 25
Rejestracja: 2009-03-08, 10:13
Lokalizacja: Radom
Kontakt:

Re: Problemy z kodowaniem unicode po aktualizacji

Post autor: files » 2009-03-23, 14:51

może w mc w ustawieniach zmien na utf-8 i zaznacz 8 bitów

Awatar użytkownika
alekow
Użytkownik
Posty: 262
Rejestracja: 2007-11-30, 17:33
Lokalizacja: Poznań
Kontakt:

Re: Problemy z kodowaniem unicode po aktualizacji

Post autor: alekow » 2009-03-23, 23:38

Ech - zmieniam nagłowek bo nici z pomocy... problem tak na prawdę nie dotyczy mc jak się już wcześniej okazało...
Ostatnio zmieniony 2009-03-24, 00:16 przez alekow, łącznie zmieniany 1 raz.

files
Użytkownik
Posty: 25
Rejestracja: 2009-03-08, 10:13
Lokalizacja: Radom
Kontakt:

Re: Problemy z kodowaniem unicode po aktualizacji

Post autor: files » 2009-03-24, 13:01

Spróbuj tego slackware-121-i-kodowanie-utf-8-unicode może pomoże.

Awatar użytkownika
alekow
Użytkownik
Posty: 262
Rejestracja: 2007-11-30, 17:33
Lokalizacja: Poznań
Kontakt:

Re: Problemy z kodowaniem unicode po aktualizacji

Post autor: alekow » 2009-03-24, 22:18

files pisze:Spróbuj tego slackware-121-i-kodowanie-utf-8-unicode może pomoże.
to co działało w 12.2 nie chce działać w currencie...
Ostatnio zmieniony 2009-03-25, 09:52 przez alekow, łącznie zmieniany 1 raz.

ODPOWIEDZ