Problemy z GNU Gadu

Czyli jak najefektywniej (lub efektowniej) skonfigurować Slackware'a w komputerze domowym

Moderatorzy: Moderatorzy, Administratorzy

Awatar użytkownika
Rookie One
Użytkownik
Posty: 230
Rejestracja: 2004-11-13, 13:16
Lokalizacja: Gliwice
Kontakt:

Problemy z GNU Gadu

Post autor: Rookie One »

Hej,

Zainstalowalem sobie GNU Gadu 2.2.3. Po zainstalowaniu jakiegos programu zawsze uruchamiam go z terminala zeby zobaczyc ewentualne bledy. No i jest ich troche:

Kod: Zaznacz cały

bash-2.05b# gg2

** (process:874): WARNING **: /usr/lib/gg2/libgadu_gadu_plugin.so is not a valid plugin file, load failed! libgadu.so.3: cannot open shared object file: No such file or directory


** (process:874): WARNING **: Cannot load plugin /usr/lib/gg2/libgadu_gadu_plugin.so


** (process:874): WARNING **: /usr/lib/gg2/libtlen_plugin.so is not a valid plugin file, load failed! libtlen.so.1: cannot open shared object file: No such file or directory


** (process:874): WARNING **: Cannot load plugin /usr/lib/gg2/libtlen_plugin.so


** (<unknown>:874): WARNING **: Nie mo¿na odczytaæ pliku z konfiguracj± wtyczki docklet-dockapp

** (<unknown>:874): WARNING **: Nie mo¿na odczytaæ pliku z konfiguracj± wtyczki sms

** (<unknown>:874): WARNING **: /usr/lib/gg2/libsound_esd_plugin.so is not a valid plugin file, load failed! libesd.so.0: nie mo\xbfna otworzy\xe6 pliku obiektu dzielonego: Nie ma takiego pliku ani katalogu


** (<unknown>:874): WARNING **: Nie mo¿na za³adowaæ wtyczki /usr/lib/gg2/libsound_esd_plugin.so


** (<unknown>:874): WARNING **: Nie mo¿na odczytaæ pliku z konfiguracj± wtyczki 

** (<unknown>:874): WARNING **: Nie mo¿na odczytaæ pliku z konfiguracj± wtyczki aktualizacji

** (<unknown>:874): WARNING **: /usr/lib/gg2/libxosd_plugin.so is not a valid plugin file, load failed! libxosd.so.2: nie mo\xbfna otworzy\xe6 pliku obiektu dzielonego: Nie ma takiego pliku ani katalogu


** (<unknown>:874): WARNING **: Nie mo¿na za³adowaæ wtyczki /usr/lib/gg2/libxosd_plugin.so


** (<unknown>:874): WARNING **: Nie mo¿na odczytaæ pliku z konfiguracj± wtyczki 

** (<unknown>:874): WARNING **: /usr/lib/gg2/libjabber_plugin.so is not a valid plugin file, load failed! libloudmouth-1.so.0: nie mo\xbfna otworzy\xe6 pliku obiektu dzielonego: Nie ma takiego pliku ani katalogu


** (<unknown>:874): WARNING **: Nie mo¿na za³adowaæ wtyczki /usr/lib/gg2/libjabber_plugin.so


** (<unknown>:874): WARNING **: /usr/lib/gg2/libsound_oss_plugin.so is not a valid plugin file, load failed! libaudiofile.so.0: nie mo\xbfna otworzy\xe6 pliku obiektu dzielonego: Nie ma takiego pliku ani katalogu


** (<unknown>:874): WARNING **: Nie mo¿na za³adowaæ wtyczki /usr/lib/gg2/libsound_oss_plugin.so


** (<unknown>:874): WARNING **: /usr/lib/gg2/libsound_arts_plugin.so is not a valid plugin file, load failed! libaudiofile.so.0: nie mo\xbfna otworzy\xe6 pliku obiektu dzielonego: Nie ma takiego pliku ani katalogu


** (<unknown>:874): WARNING **: Nie mo¿na za³adowaæ wtyczki /usr/lib/gg2/libsound_arts_plugin.so


bash-2.05b# 
I co o tym myslicie? Wyglada na to, ze cos jest nie tak z wtyczkami... Pokazuje sie okienko programu, ale jest ono zupelnie puste, nie ma zadnych opcji konfiguracyjnych, gdzie moznaby nr gg wpisac itd. Wie ktos o co chodzi?

Z gory dzieki,

Rookie One

P.S. Sorry za te krzaki zamiast ogonkow, dopiero zainstalowalem aterma i jeszcze go nie skonfigurowalem. :P
[color=darkblue][b]- [ Slackware 10.2, kernel 2.4.31 ]
- [ Windows XP Home SP2 ][/b][/color]
[size=75]Pentium 4 3 GHz HT, 512 MB RAM, Intel 915G[/size]
Registered Linux User #372988
Awatar użytkownika
kruszek
Użytkownik
Posty: 381
Rejestracja: 2004-08-30, 19:11
Lokalizacja: Kraków

Re: Problemy z GNU Gadu

Post autor: kruszek »

to nie bledy, tylko ostrzezenia... a to kategoryczna roznica :)
Awatar użytkownika
Rookie One
Użytkownik
Posty: 230
Rejestracja: 2004-11-13, 13:16
Lokalizacja: Gliwice
Kontakt:

Re: Problemy z GNU Gadu

Post autor: Rookie One »

Teraz sam sie temu przyjrzalem troche lepiej... Tak, ale to ostrzezenia ktore informuja o tym, ze program nie ma funkcjonalnosci. Wnioskuje, ze mi brak libgadu. Szukalem i znalazlem na stronie EKG, ale tam sa tylko zrodelka, a kompilacja niezbyt mi sie usmiecha, czy jest gdzies paczka dla Slacka?
[color=darkblue][b]- [ Slackware 10.2, kernel 2.4.31 ]
- [ Windows XP Home SP2 ][/b][/color]
[size=75]Pentium 4 3 GHz HT, 512 MB RAM, Intel 915G[/size]
Registered Linux User #372988
DanielLinux
Użytkownik
Posty: 552
Rejestracja: 2004-06-11, 17:24
Kontakt:

Re: Problemy z GNU Gadu

Post autor: DanielLinux »

Biblioteka gg jest instalowana razem z GNU Gadu (przynajmniej tak było u mnie), więc to chyba raczej nie to. Żeby np. używać tlenu trzeba zainstalować libtlen.
Tylko że domyślnie w Slackwarze biblioteki ręcznie kompilowane (czy te razem z programami tak jak m.in. gg2) umieszczane są w /usr/local/lib/gg2 tymczasem u Ciebie chce czytać biblioteki z /usr/lib/gg2 w takim razie najlepiej podlinkuj sobie te biblioteki które są w /usr/local/lib/gg2 do /usr/lib/gg2.
Awatar użytkownika
Rookie One
Użytkownik
Posty: 230
Rejestracja: 2004-11-13, 13:16
Lokalizacja: Gliwice
Kontakt:

Re: Problemy z GNU Gadu

Post autor: Rookie One »

W /usr/local/lib nie mam katalogu gg2, ale byl tam plik libgadu.a, wiec zalinkowalem go do /usr/lib, ale jest bez zmian... :cry: Przy uruchamianiu dokladnie te same bledy... Na liscie wtyczek w ustawieniach nie ma wtyczki GG... Kurde, co jest?! Moze zainstalowac Kadu? Tylko ze on sie bez artsa nie uruchomi, a mi nie usmiecha sie instalowac tego swinstwa. ;/
[color=darkblue][b]- [ Slackware 10.2, kernel 2.4.31 ]
- [ Windows XP Home SP2 ][/b][/color]
[size=75]Pentium 4 3 GHz HT, 512 MB RAM, Intel 915G[/size]
Registered Linux User #372988
DanielLinux
Użytkownik
Posty: 552
Rejestracja: 2004-06-11, 17:24
Kontakt:

Re: Problemy z GNU Gadu

Post autor: DanielLinux »

Zawsze możesz ściągnąć paczkę GNU Gadu jest na stronie projektu i zobaczyćczy takie same efekty.
Awatar użytkownika
Rookie One
Użytkownik
Posty: 230
Rejestracja: 2004-11-13, 13:16
Lokalizacja: Gliwice
Kontakt:

Re: Problemy z GNU Gadu

Post autor: Rookie One »

No ale to JEST paczka... :(
[color=darkblue][b]- [ Slackware 10.2, kernel 2.4.31 ]
- [ Windows XP Home SP2 ][/b][/color]
[size=75]Pentium 4 3 GHz HT, 512 MB RAM, Intel 915G[/size]
Registered Linux User #372988
Awatar użytkownika
splitmode
Użytkownik
Posty: 60
Rejestracja: 2004-11-01, 21:46
Lokalizacja: Poznań
Kontakt:

Re: Problemy z GNU Gadu

Post autor: splitmode »

Skompiluj ze zrodel... tak bedzie najprosciej.
LRU: #286859
DanielLinux
Użytkownik
Posty: 552
Rejestracja: 2004-06-11, 17:24
Kontakt:

Re: Problemy z GNU Gadu

Post autor: DanielLinux »

Skompiluj ze zrodel... tak bedzie najprosciej.
hmmm no tak ale w przypadku Rookie One kiedy nie wie czemu nie działa to zawsze można zaisntalować paczkę i zobaczyć czy działa.
Zresztą w przypadku GNU Gadu nie ma za dużej róznicy czy się kompiluje samemu czy instaluje z paczki.
Awatar użytkownika
splitmode
Użytkownik
Posty: 60
Rejestracja: 2004-11-01, 21:46
Lokalizacja: Poznań
Kontakt:

Re: Problemy z GNU Gadu

Post autor: splitmode »

DanielLinux pisze:hmmm no tak ale w przypadku Rookie One kiedy nie wie czemu nie działa to zawsze można zaisntalować paczkę i zobaczyć czy działa.
Zresztą w przypadku GNU Gadu nie ma za dużej róznicy czy się kompiluje samemu czy instaluje paczki.
Tez mialem swoje przeboje z gg2 i nauczylem sie, ze lepiej wychodze na kompilacji ze zrodel niz instalacji "obcej" paczki(a probowalem kilka paczek). Mialem podobne problemy co Rookie One, jednakze bylo to dawno temu i nie potrafie dokladnie powiedziec na czym polegal problem. Aczkolwiek pamietam, ze przez kompilacje uzyskalem zadowalajacy rezulat, czyli dzialajace gg :]
LRU: #286859
Awatar użytkownika
Rookie One
Użytkownik
Posty: 230
Rejestracja: 2004-11-13, 13:16
Lokalizacja: Gliwice
Kontakt:

Re: Problemy z GNU Gadu

Post autor: Rookie One »

Aj, po tym, jak usilowalem skompilowac firefoksa, jakos sie uprzedzilem do kompilacji... ;/

No nic, sprobuje... :?
[color=darkblue][b]- [ Slackware 10.2, kernel 2.4.31 ]
- [ Windows XP Home SP2 ][/b][/color]
[size=75]Pentium 4 3 GHz HT, 512 MB RAM, Intel 915G[/size]
Registered Linux User #372988
Awatar użytkownika
kruszek
Użytkownik
Posty: 381
Rejestracja: 2004-08-30, 19:11
Lokalizacja: Kraków

Re: Problemy z GNU Gadu

Post autor: kruszek »

"umiejetnosc" kompilacji to raczej rzecz konieczna pod Linuxem, wiec nie ma sie co uprzedzac... tylko "nauczyc" czym predzej...

wiec do roboty...
"Java jest jak kobieta, na poczatku czlowiek nie jest do niej przekonany, ale potem zycie go zmusza, aby sie przekonal"
jacol
Przyjaciel Forum
Posty: 680
Rejestracja: 2004-06-12, 17:34

Re: Problemy z GNU Gadu

Post autor: jacol »

Witam.
Kompiluję gg2 od zawsze i nigdy z nim nie miałem kłopotu. Należy tylko powiedzieć sobie co chcemy. Ja w zasadzie ściągam 5 plików:
1. gtkspell-2.5.0.tar.gz
2. libtlen2-20040710.tar.gz
3. gg2-2.2.3.tar.gz
4. ekg-curent.tar.gz
i jako piąty słownik polski dla aspella.
Następnie PKG_CONFIG_PATH przekierowuję na /usr/local i rozpakowuję i kompiluję biblioteki
Rozpakowuję paczkę z gg2 modyfikuję sekcję --with-all-plugins w configure dla własnych potrzeb
i aby zaoszczędzić sobie pisania ./configure --with-all-plugins , make make install ldconfig i mogę pracować gg2. Pozdrawiam jacol
joi
Użytkownik
Posty: 151
Rejestracja: 2004-10-12, 20:32
Lokalizacja: raczej nie stąd ;)
Kontakt:

Re: Problemy z GNU Gadu

Post autor: joi »

Rookie One pisze:Moze zainstalowac Kadu? Tylko ze on sie bez artsa nie uruchomi, a mi nie usmiecha sie instalowac tego swinstwa. ;/
:shock:
Awatar użytkownika
Rookie One
Użytkownik
Posty: 230
Rejestracja: 2004-11-13, 13:16
Lokalizacja: Gliwice
Kontakt:

Re: Problemy z GNU Gadu

Post autor: Rookie One »

jacol pisze:1. gtkspell-2.5.0.tar.gz
2. libtlen2-20040710.tar.gz
3. gg2-2.2.3.tar.gz
4. ekg-curent.tar.gz
Czyli jednak jest to libgadu potrzebne! Inaczej nie widze sensu instalowania ekg...
joi pisze: :shock:
Czyzbym sie mylil? Da sie kadu bez artsa uruchomic? Mi wywala zadanie libarts i sie wylacza. Masz na mysli kompilowanie bez obslugi arts?
[color=darkblue][b]- [ Slackware 10.2, kernel 2.4.31 ]
- [ Windows XP Home SP2 ][/b][/color]
[size=75]Pentium 4 3 GHz HT, 512 MB RAM, Intel 915G[/size]
Registered Linux User #372988
Zablokowany