Piszemy po japońsku w Slackware

W tym miejscu zapraszamy Was do współpracy. Czekamy na propozycje, sugestie i rady.
Moderatorzy zatroszczą się o to, by najlepsze teksty trafiły do FAQ.

Moderatorzy: Moderatorzy, Administratorzy

Awatar użytkownika
dienet
Moderator
Posty: 2106
Rejestracja: 2007-07-24, 18:58
Lokalizacja: Racibórz/Rybnik
Kontakt:

Piszemy po japońsku w Slackware

Post autor: dienet » 2008-08-25, 12:11

I
Pierwszy krok to zainstalowanie odpowiednich paczek. Instalujemy:

Kod: Zaznacz cały

scim-1.4.7-i486-6 [inst=yes]: scim (Smart Common Input Method platform)
scim-anthy-1.2.4-i486-1 [inst=yes]: scim-anthy (a SCIM IMEngine module for anthy)
scim-bridge-0.4.14-i486-2 [inst=no]: scim-bridge (yet another gtk-immodule for SCIM)
scim-hangul-0.3.2-i486-1 [inst=yes]: scim-hangul (SCIM IMengine for Hangul)
scim-m17n-0.2.2-i486-1 [inst=yes]: scim-m17n (bridge IMengine to support m17n input methods in SCIM)
scim-pinyin-0.5.91-i486-1 [inst=yes]: scim-pinyin (smart pinyin IM engine)
scim-tables-0.5.7-i486-1 [inst=yes]: scim-tables (tables IMEngine for scim)
anthy-9100e-i486-1 in slackware/x
Pewnie dla jezyka japońskiego nie wszystkie są potrzebne, no ale co nam szkodzi.

II
Kolejny krok to uruchomienie programu scim i jego konfiguracja na jezyk japoński.
Otwieramy „SCIM Setup”, wybieramy „FrontEnd->Global Setup”. Z listy rozwijanej „Keyboard Layout” wybieramy oczywiscie „Japanese”. Proponuje także zmienić w sekcji „HotKeys” trigger na alt+space.
Następnie przechodzimy do „IMEngine->Anthy”. Tam wybieramy „Imput metod”, czyli jakim sylabariuszem będziemy pisać.

III
Trzeci krok to konfiguracja OpenOffice. Uruchamiamy edytor. Z menu wybieramy; „Narzędzia->Opcje”. Z drzewa po lewej stronie wybieramy: „Ustawienie językowe->Język”. U dołu zaznaczamy „ptaszka” przy „Języki azjatyckie” a powyżej z listy rozwijanej wybieramy język japoński. Klikamy OK. Następnie znowu wchodzimy w opcje językowe i wybieramy nową powstałą gałąź „Układ azjatycki”. Tam w sekcji „Znaki wiodące i kończące” wybieramy język japoński. Klikamy OK.
Ostatni krok w tej części to wybór czcionki dla języka. Uruchamiamy Writera, wchodzimy w jego opcje. Następnie wybieramy z drzewa „Czcionki podstawowe (azjatyckie).” Tam wybieramy jaką czcionką chcemy pisać. Ja wybrałem aquafont (do pobrania z internetu). Klikamy OK i zamykamy OpenOffice.

IV
Ostatni krok to utworzenie odpowiedniego skryptu który uruchomi nam OO z odpowiednimi parametrami środowiska. Mój skrypt wygląda tak:

Kod: Zaznacz cały

export LC_CTYPE="en_US.utf8"
export XMODIFIERS=@im=SCIM    #case matters for this variable!
export GTK_IM_MODULE=xim
export QT_IM_MODULE=xim
/opt/openoffice.org2.4/program/soffice
Od teraz jak chcesz pisać po japońsku to uruchamiasz ten skrypt. Ważne żeby przed uruchomieniem skryptu działał już program SCIM (można go odpalać w tle zob. scim –help).
Gdy już będziesz w edytorze (Writer) naciskasz alt+spacja i możesz cieszyć się japońskimi znakami ;]
Powodzenia !
Ostatnio zmieniony 2009-07-12, 15:15 przez dienet, łącznie zmieniany 2 razy.
Pozdr0
dienet
[img]http://i164.photobucket.com/albums/u19/slawek15/kotekeo0lq3.jpg[/img]

Awatar użytkownika
Spaulding
Użytkownik
Posty: 564
Rejestracja: 2005-07-17, 14:59
Lokalizacja: Chełm
Kontakt:

Re: Piszemy po japońsku w Slackware

Post autor: Spaulding » 2008-08-30, 09:23

a przypadkiem jak sie ma locale w utf-8 to ma sie japonskie i te inne znaczki? :]
Powered By:
funtoo, openbox, mc, ekg2, git, ssh...
(very unstable packages but stable system :>)

Awatar użytkownika
dienet
Moderator
Posty: 2106
Rejestracja: 2007-07-24, 18:58
Lokalizacja: Racibórz/Rybnik
Kontakt:

Re: Piszemy po japońsku w Slackware

Post autor: dienet » 2008-08-30, 09:39

p1r4te pisze:a przypadkiem jak sie ma locale w utf-8 to ma sie japonskie i te inne znaczki? :]
Moze sie i ma, ale jakos je musisz umiec wprowadzic i do tego sluzy wlasnie SCIM.
Ostatnio zmieniony 2008-08-30, 09:40 przez dienet, łącznie zmieniany 1 raz.
Pozdr0
dienet
[img]http://i164.photobucket.com/albums/u19/slawek15/kotekeo0lq3.jpg[/img]

Awatar użytkownika
darjerz
Użytkownik
Posty: 1052
Rejestracja: 2004-05-28, 18:26
Lokalizacja: Wrocław

Re: Piszemy po japońsku w Slackware

Post autor: darjerz » 2009-08-14, 07:22

A właśnie postawiłem świeżutkiego currenta na lapku i... tak na szybko ... pisząc krótko nie działa z OO 3.1.0 PL / Jakieś pomysły?
Nie ma rzeczy niemożliwych dla kogoś, kto nie musi ich zrobić sam.

Awatar użytkownika
dienet
Moderator
Posty: 2106
Rejestracja: 2007-07-24, 18:58
Lokalizacja: Racibórz/Rybnik
Kontakt:

Re: Piszemy po japońsku w Slackware

Post autor: dienet » 2009-08-14, 08:22

Ja na BW64 z OO.org 3.1.0 ENG nie mam problemow. W innych programach dziala? Moze jakies inne informacje podasz...
Pozdr0
dienet
[img]http://i164.photobucket.com/albums/u19/slawek15/kotekeo0lq3.jpg[/img]

Awatar użytkownika
darjerz
Użytkownik
Posty: 1052
Rejestracja: 2004-05-28, 18:26
Lokalizacja: Wrocław

Re: Piszemy po japońsku w Slackware

Post autor: darjerz » 2009-08-15, 19:24

Z konqerorem działa, z firefoxem też, z kwordem także.

Kod: Zaznacz cały

bash-3.1# ps ax | grep scim
 2792 ?        Ss     0:00 /usr/lib/scim-1.0/scim-launcher -d -c kconfig -e all -f socket --no-stay -d
 2796 ?        Ss     0:00 /usr/lib/scim-1.0/scim-helper-manager
 2797 ?        Ssl    0:02 /usr/lib/scim-1.0/scim-panel-gtk --display :0.0 -c socket -d --no-stay
 2799 ?        Ss     0:00 /usr/lib/scim-1.0/scim-launcher -d -c socket -e socket -f x11 --no-stay -d
 2800 ?        S      0:01 scim-bridge
Próbowałem zamiast xim ustawiać scim i scim-bridge i z OO dalej nic.
Nie ma rzeczy niemożliwych dla kogoś, kto nie musi ich zrobić sam.

Awatar użytkownika
dienet
Moderator
Posty: 2106
Rejestracja: 2007-07-24, 18:58
Lokalizacja: Racibórz/Rybnik
Kontakt:

Re: Piszemy po japońsku w Slackware

Post autor: dienet » 2009-08-15, 19:52

Wlasnie doinstalowalem spolszczenie - i dziala tak samo jak na eng.
Ja po uruchomieniu 'scim' dostaje:

Kod: Zaznacz cały

18945 pts/0    S+     0:00 scim
18947 ?        Ss     0:00 /usr/lib/scim-1.0/scim-launcher -d -c simple -e all -f socket --no-stay
18948 pts/0    S+     0:00 /usr/lib/scim-1.0/scim-launcher -c socket -e socket -f x11
18959 ?        Ss     0:00 /usr/lib/scim-1.0/scim-helper-manager
18960 ?        Ssl    0:00 /usr/lib/scim-1.0/scim-panel-gtk --display :0.0 -c socket -d --no-stay
Nie wiem co u Ciebie moze byc nie tak. Skad masz OO.org? Jak rozumiem odpalasz z tego samego usera programy co odpalil scim'a? Moze trigger jest dla OO.org zly? Oczywiscie OO.org skonfigurowales poprawnie - wykrywa Ci azjatyckie fonty?
Ostatnio zmieniony 2009-08-15, 19:53 przez dienet, łącznie zmieniany 2 razy.
Pozdr0
dienet
[img]http://i164.photobucket.com/albums/u19/slawek15/kotekeo0lq3.jpg[/img]

Awatar użytkownika
darjerz
Użytkownik
Posty: 1052
Rejestracja: 2004-05-28, 18:26
Lokalizacja: Wrocław

Re: Piszemy po japońsku w Slackware

Post autor: darjerz » 2009-08-16, 16:02

Openoffica z rpm przerabiałem skryptem jaki umieściłem gdzieś na forum. OO otwiera dokumenty z kandzi, a co do trigerra to chyba nieistotne bo przy aktywnym scimie można by go nawet przełączyć myszą, a tak nie jest. Nie wiem moiże problem leży po stronie OO ?
Nie ma rzeczy niemożliwych dla kogoś, kto nie musi ich zrobić sam.

Awatar użytkownika
dienet
Moderator
Posty: 2106
Rejestracja: 2007-07-24, 18:58
Lokalizacja: Racibórz/Rybnik
Kontakt:

Re: Piszemy po japońsku w Slackware

Post autor: dienet » 2009-08-16, 17:46

Ja OO.org tez mam z RPM'ow, ale po swojemu. Mi dziala. Trigger jest wazny bo czasem skrot uzyty dla niego juz w OO.org jest uzyty.
Problem lezy u Ciebie po stronie OO.org bo w innych programach Ci dziala.
Pozdr0
dienet
[img]http://i164.photobucket.com/albums/u19/slawek15/kotekeo0lq3.jpg[/img]

Awatar użytkownika
darjerz
Użytkownik
Posty: 1052
Rejestracja: 2004-05-28, 18:26
Lokalizacja: Wrocław

Re: Piszemy po japońsku w Slackware

Post autor: darjerz » 2009-08-17, 10:08

Kod: Zaznacz cały

Ja OO.org tez mam z RPM'ow, ale po swojemu.
zdradź te sztuczkę - może i u mnie zadziała.
Nie ma rzeczy niemożliwych dla kogoś, kto nie musi ich zrobić sam.

Awatar użytkownika
dienet
Moderator
Posty: 2106
Rejestracja: 2007-07-24, 18:58
Lokalizacja: Racibórz/Rybnik
Kontakt:

Re: Piszemy po japońsku w Slackware

Post autor: dienet » 2009-08-17, 14:56

Kod: Zaznacz cały

for name in *.RPM
do
rpm2tgz "$name"
done
a potem
mv *.tgz laza/
a w laza:

Kod: Zaznacz cały

for name in *.tgz
do
tar xvfz "$name"
done
potem mv opt/ laza2/
a potem w laza2

Kod: Zaznacz cały

makepkg OO.org.tgz
installpkg OO.org.tgz
Ja to tak robie juz od paru wersji i nie mam problemow z OO.org zadnych.
Pozdr0
dienet
[img]http://i164.photobucket.com/albums/u19/slawek15/kotekeo0lq3.jpg[/img]

ODPOWIEDZ