Prawy ALT w X'ach w Salckware 13

W tym miejscu zapraszamy Was do współpracy. Czekamy na propozycje, sugestie i rady.
Moderatorzy zatroszczą się o to, by najlepsze teksty trafiły do FAQ.

Moderatorzy: Moderatorzy, Administratorzy

gx
Użytkownik
Posty: 1
Rejestracja: 2008-05-11, 05:27

Prawy ALT w X'ach w Salckware 13

Post autor: gx » 2009-08-29, 22:51

Po instalacji Slackware 13 pojawił się problem z polskim layout'em w X'ach. Prawy ALT przestał działać, pomimo sprawdzonych ustawień w xorg.conf ze Slackware'a 12.2 (W wersji 13 systemu nie istnieje xorg.conf). Nowsza wersja Xorg domyślnie korzysta z HAL'a i część wpisów w xorg.conf zdaje się być ignorowana. Pogrzebałem trochę w plikach i w Internecie znajdując rozwiązanie. Może się komuś przyda:
1 Sposób (Wyłączenie HAL'a w X'ach)
Aby wyłączyć HAL'a należy wpisać w sekcji "ServerFlags" pliku xorg.conf:

Kod: Zaznacz cały

    Option   "AllowEmptyInput"     "false"
    Option   "AutoAddDevices"      "false"
    Option   "AutoEnableDevices"   "false"
Można teraz konfigurować klawiaturę po staremu.
2 Sposób (Edytowanie pliku HAL'a)
Kopiujemy

Kod: Zaznacz cały

cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy
, a następnie edytujemy '/etc/hal/fdi/policy/10-keymap.fdi' zmieniając w linijce 20 'us' na 'pl'

Kod: Zaznacz cały

...
      <merge key="input.xkb.rules" type="string">base</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">us</merge>
      <merge key="input.xkb.variant" type="string" />
...
Po restarcie demona HAL ('/etc/rc.d/rc.hald restart') i serwera X prawy alt powinien działać.
Ostatnio zmieniony 2009-08-29, 23:05 przez gx, łącznie zmieniany 1 raz.

ODPOWIEDZ