mount /dev/mmcblk0p1 read-write

W tym miejscu zapraszamy Was do współpracy. Czekamy na propozycje, sugestie i rady.
Moderatorzy zatroszczą się o to, by najlepsze teksty trafiły do FAQ.

Moderatorzy: Moderatorzy, Administratorzy

Awatar użytkownika
webster
Użytkownik
Posty: 1265
Rejestracja: 2009-10-06, 11:58
Lokalizacja: Gdańsk
Kontakt:

mount /dev/mmcblk0p1 read-write

Post autor: webster » 2010-09-15, 08:31

Problem z kartami SD podczas montowania. Karta montuje się na prawach read-only i nie można pracować.
Rozwiązania jako takiego nie udało mi się stworzyć a jedynie ominięcie problemu.

Będę pracować na katalogu /mnt/mmc, więc go sobie stworzę:

Kod: Zaznacz cały

mkdir /mnt/mmc
Jeśli nam "coś" automatycznie zamontowało SD po podpięciu do czytnika, to robimy umount:

Kod: Zaznacz cały

umount /dev/mmcblk0p1
Robimy ręcznie mount naszej karty po którym i tak się pojawi read-only:

Kod: Zaznacz cały

mount -t vfat -o rw /dev/mmcblk0p1 /mnt/mmc/
I teraz czarodziejski remount:

Kod: Zaznacz cały

mount -o remount,rw -t vfat /dev/mmcblk0p1 /mnt/mmc/
Powinno ładnie zamontować SD.

Pozdro
††† Chaos Of The Mirror - Valheru †††
††† I ♥ SlackWare RuLeZ †††

Slackware Poland FaceBook

Awatar użytkownika
Lizard
Moderator
Posty: 2562
Rejestracja: 2005-05-21, 15:48
Lokalizacja: miasto w mieście

Re: mount /dev/mmcblk0p1 read-write

Post autor: Lizard » 2010-09-15, 19:11

Jeśli wykonujesz remount sam punkt montowania wystarczy - urządzenie nie jest potrzebne.
Error 404 - footer not found

ODPOWIEDZ