Polonizacja

W tym miejscu zapraszamy Was do współpracy. Czekamy na propozycje, sugestie i rady.
Moderatorzy zatroszczą się o to, by najlepsze teksty trafiły do FAQ.

Moderatorzy: Moderatorzy, Administratorzy

Awatar użytkownika
knives
Użytkownik
Posty: 85
Rejestracja: 2009-09-24, 14:43

Polonizacja

Post autor: knives » 2011-12-02, 07:15

Temat w FAQ o polonizacji Slackware'a jest nieaktualny i nie działa w pełni na 13.37 (64-bit).

Skupię się na drugim poście w w/w temacie, gdyż jest on nowszy i w dodatku posiada informację:
"Sprawdzone na aktualnych Slackware Current i Slackware Current x64." - co wg mnie już jest nieprawdą.

Po pierwsze:
Kolejnym plikiem jest /etc/profile.d/lang.sh:

Kod: Zaznacz cały

    #!/bin/sh
    export LANG=pl_PL.utf8
    export LC_CTYPE="pl_PL.utf8"
    export LC_NUMERIC="pl_PL.utf8"
    export LC_TIME="pl_PL.utf8"
    export LC_COLLATE=C
    export LC_MONETARY="pl_PL.utf8"
    export LC_MESSAGES="en_US.utf8"
    export LC_PAPER="pl_PL.utf8"
    export LC_NAME="pl_PL.utf8"
    export LC_ADDRESS="pl_PL.utf8"
    export LC_TELEPHONE="pl_PL.utf8"
    export LC_MEASUREMENT="pl_PL.utf8"
    export LC_IDENTIFICATION="pl_PL.utf8"
    export LC_ALL=
Tu jest błąd, gdyż ostatnia linijka nie posiada żadnego parametru, a powinno być:

Kod: Zaznacz cały

export LC_ALL="pl_PL.utf8"
Po drugie:
może zastosować uwagę webstera i od razu zmienić wartość LC_MONETARY na "pl_PL" w powyższym kodzie.

Po trzecie:
Po zastosowaniu tych kroków, w trybie tekstowym jest wszystko OK, jednak w X-ach nie da się pisać polskich znaków diakrytycznych. Można temu zaradzić używając opcji w KDE i XFCE. Niestety w innych menedżerach okien nie ma takich narzędzi. Pamiętam, że w wersji 13.0, zmieniałem układ klawiatury przy pomocy HAL-a. W 13.37 już ten sposób nie działa. Teraz, zgodnie z tym, co Patrick napisał w CHANGES_AND_HINTS.TXT ("Input hotplugging is no longer done using hal; instead, it now uses udev for input device detection and keyboard mapping"), należy:

Kod: Zaznacz cały

cp /usr/share/X11/xorg.conf.d/90-keyboard-layout.conf /etc/X11/xorg.conf.d/
i wyedytować nowo skopiowany plik (/etc/X11/xorg.conf.d/90-keyboard-layout.conf) zamieniając

Kod: Zaznacz cały

Option "XkbLayout" "us"
na

Kod: Zaznacz cały

Option "XkbLayout" "pl"
Po tym zabiegu prawy ALT gramatyczny powinien poprawnie działać.

ODPOWIEDZ