intalacja sterowników ATI

W tym miejscu zapraszamy Was do współpracy. Czekamy na propozycje, sugestie i rady.
Moderatorzy zatroszczą się o to, by najlepsze teksty trafiły do FAQ.

Moderatorzy: Moderatorzy, Administratorzy

Awatar użytkownika
Sheytan
Użytkownik
Posty: 473
Rejestracja: 2007-03-31, 10:44
Lokalizacja: Ligota Piękna/Wro
Kontakt:

Re: intalacja sterowników ATI

Post autor: Sheytan » 2007-07-02, 21:51

Coś pogrzebałem w skrypcie /lib/modules/fglrx/build_mod/make.sh i teraz po wydaniu polecenia: sh make.sh dostaje odpowiedź

Kod: Zaznacz cały

initializing...
kernel includes at /lib/modules/2.6.18/build/include not found or incomplete
file: /lib/modules/2.6.18/build/include/usr/include/linux/version.h
root@szatan:/lib/modules/fglrx/build_mod#
Już nie mam pojęcia o co chodzi :/
[url=http://www.madsheytan.blogspot.com][img]http://img146.imageshack.us/img146/3848/forumstopka.png[/img][/url]
Slackware, because it works. Kubuntu, because it works. Windows, because it syncs my iPod...

Awatar użytkownika
Lizard
Moderator
Posty: 2582
Rejestracja: 2005-05-21, 15:48
Lokalizacja: miasto w mieście

Re: intalacja sterowników ATI

Post autor: Lizard » 2007-07-02, 21:51

A co pogrzebałeś?

miszmaniac, chyba każdy, kto nie śledzi lkml zdziwił się na początku. No, czyli każdy. ;)
Ostatnio zmieniony 2007-07-02, 21:54 przez Lizard, łącznie zmieniany 1 raz.
Error 404 - footer not found

Awatar użytkownika
Sheytan
Użytkownik
Posty: 473
Rejestracja: 2007-03-31, 10:44
Lokalizacja: Ligota Piękna/Wro
Kontakt:

Re: intalacja sterowników ATI

Post autor: Sheytan » 2007-07-03, 11:07

zamieniłem ścieżki na:

Kod: Zaznacz cały

if [ -z "${KERNEL_PATH}" ]; then
#linuxincludes=/usr/include    # no config info present!
linuxincludes=/usr/include/linux/
... ale nie pamiętam jaki był oryginał :P i chyba tą :[code]# sample: #define UTS_RELEASE "2.4.0-test7"
src_file=$linuxincludes/usr/include/linux/version.h[/code] obydwie są już po zmianach :P
Zamieniłem ścieżki w make.sh z /lib/modules/2.6.18/build/include/linux/version-*.h na /lib/modules/2.6.18/build/include/linux/version.h bo tylko taki plik u mnie istnieje, nic się nie poprawiło poza zniknięciem błędu z brakiem tego pliku.
No i efekt zmian jest taki:

Kod: Zaznacz cały

kernel includes at /lib/modules/2.6.18/build/include not found or incomplete 
[url=http://www.madsheytan.blogspot.com][img]http://img146.imageshack.us/img146/3848/forumstopka.png[/img][/url]
Slackware, because it works. Kubuntu, because it works. Windows, because it syncs my iPod...

Awatar użytkownika
Lizard
Moderator
Posty: 2582
Rejestracja: 2005-05-21, 15:48
Lokalizacja: miasto w mieście

Re: intalacja sterowników ATI

Post autor: Lizard » 2007-07-03, 12:02

Może czegoś nie doczytałem, może czegoś nie rozumiem? Instalowałem u siebie sterowniki ATI przy pomocy tekstowego instalatora i nie miałem żadnych kłopotów.

Sheytan, możesz mi wyjasnić jakim cudem znalazłeś się w katalogu /lib/modules/fglrx/build_mod i do czego potrzebne Ci skrypty stamtąd? Jeśli masz problem z zainstalowaniem sterowników poprzez wydanie zwykłego polecenia ./ati-driver-installer-X-x86.x86_64.run (X- wersja sterowników), to znaczy, że coś nie tak z systemem (np. czegoś brakuje), a nie cośs nie tak z instalatorem.
Error 404 - footer not found

Awatar użytkownika
Sheytan
Użytkownik
Posty: 473
Rejestracja: 2007-03-31, 10:44
Lokalizacja: Ligota Piękna/Wro
Kontakt:

Re: intalacja sterowników ATI

Post autor: Sheytan » 2007-07-03, 12:13

Nie mam właśnie problemów z zainstalowaniem sterowników... Wszystko idzie dobrze. Tylko gdzieś na forum czytałem, że trzeba w tym katalogu /lib/modules/fglrx/build_mod/ wydać polecenie sh make.sh no i tak chciałem zrobić, ale, że wyrzucało błędy o tym pliku version.h postanowiłem pozmieniać ścieżki w skrypcie. Po sh make.sh trzeba wrócić do katalogu wyżej i wydać sh make_install.sh .
Ostatnio zmieniony 2007-07-03, 12:14 przez Sheytan, łącznie zmieniany 1 raz.
[url=http://www.madsheytan.blogspot.com][img]http://img146.imageshack.us/img146/3848/forumstopka.png[/img][/url]
Slackware, because it works. Kubuntu, because it works. Windows, because it syncs my iPod...

Awatar użytkownika
Lizard
Moderator
Posty: 2582
Rejestracja: 2005-05-21, 15:48
Lokalizacja: miasto w mieście

Re: intalacja sterowników ATI

Post autor: Lizard » 2007-07-03, 13:12

No cóż, tak się kończą zabawy, w których się nie wie co się czyni. ;)

Jak napiszę, abyś usunąć /boot/vmlinuz i zrestartował komputer, bo to pomoże, to też tak zrobisz?
Ostatnio zmieniony 2007-07-03, 13:12 przez Lizard, łącznie zmieniany 1 raz.
Error 404 - footer not found

Awatar użytkownika
Sheytan
Użytkownik
Posty: 473
Rejestracja: 2007-03-31, 10:44
Lokalizacja: Ligota Piękna/Wro
Kontakt:

Re: intalacja sterowników ATI

Post autor: Sheytan » 2007-07-03, 17:27

Ej no... skoro jest na forum i nikt tego nie usunął/oznaczył jakoś, to uznałem to za słuszne.
[url=http://www.madsheytan.blogspot.com][img]http://img146.imageshack.us/img146/3848/forumstopka.png[/img][/url]
Slackware, because it works. Kubuntu, because it works. Windows, because it syncs my iPod...

Awatar użytkownika
Lizard
Moderator
Posty: 2582
Rejestracja: 2005-05-21, 15:48
Lokalizacja: miasto w mieście

Re: intalacja sterowników ATI

Post autor: Lizard » 2007-07-03, 17:50

tacchif pisze:Wysłany: 2005-08-05, 18:03 intalacja sterowników ATI
instalacja sterowników ATI (w wersji 8.14.13) zajęła mi około 2 dni
(...)
Mam Slackware 10.1 , kernel w wersji 2.6.12, X.org 6.8.1, radeona 9000, i plyte główna na chipsecie VIA KT400.
Artykuł napisany dwa lata temu. Stary Slackware, stery kernel, stare sterowniki. Na zdrowy rozum nie należy bezgranicznie ufać tak starym informacjom, a już na pewno nie próbować aplikowania patchy przeznaczonych dla innych wersji czegokolwiek niż posiadamy. Zresztą patchy nie ma już pod podanymi adresami i w ogóle autor tamtej strony nic nie wiem nt ATI (tzn. wyszukiwarka na jego stronie).

Poza tym autor tego artykułu nie odwiedził nas od ponad roku i nie wygląda, aby to zrobił w rozsądnym czasie, że o skończeniu tego tekstu nie wspomnę.
Error 404 - footer not found

Awatar użytkownika
Sheytan
Użytkownik
Posty: 473
Rejestracja: 2007-03-31, 10:44
Lokalizacja: Ligota Piękna/Wro
Kontakt:

Re: intalacja sterowników ATI

Post autor: Sheytan » 2007-07-03, 18:07

strone wcześniej jest jeden art. napisany 2007-01-17, 23:44 i trochę niżej też jest coś na ten temat... Tym się sugerowałem... Nie początkiem art-a faQ.

Ale mniejsza oto... zainstalowałem stery, dodalem wpis do fstab, i wydałem polecenie aticonfig... Nadal nie mam direct reading :/ Czy czegoś zapomniałem?
Ostatnio zmieniony 2007-07-03, 18:11 przez Sheytan, łącznie zmieniany 2 razy.
[url=http://www.madsheytan.blogspot.com][img]http://img146.imageshack.us/img146/3848/forumstopka.png[/img][/url]
Slackware, because it works. Kubuntu, because it works. Windows, because it syncs my iPod...

Awatar użytkownika
Lizard
Moderator
Posty: 2582
Rejestracja: 2005-05-21, 15:48
Lokalizacja: miasto w mieście

Re: intalacja sterowników ATI

Post autor: Lizard » 2007-07-03, 18:34

Zwróciłeś uwagę na to co wypisał aticonfig? Nie zdziwię się jeśli pokazał informacje, że xorg.conf jest już skonfigurowany i nie ma nic do roboty. Niestety program jest mało inteligentny i sugeruje się tylko obecnością Driver "fglrx". Jeśli znajdzie taki wpis w sekcji "Device", przerywa pracę. Przywróć stary xorg.conf (aticonfig zrobił kopię jeśli coś zmienił w konfiguracji) i ustaw sekcję "Device" na:

Kod: Zaznacz cały

Section "Device"
        Identifier      "Generic Video Card"
        Driver          "ati"
        BusID           "PCI:1:0:0"
EndSection
Ponownie wykonaj aticonfig --initial.
Error 404 - footer not found

Awatar użytkownika
Sheytan
Użytkownik
Posty: 473
Rejestracja: 2007-03-31, 10:44
Lokalizacja: Ligota Piękna/Wro
Kontakt:

Re: intalacja sterowników ATI

Post autor: Sheytan » 2007-07-03, 19:12

yyy, mój xorg.conf wygląda tak:

Kod: Zaznacz cały

Section "Device"
    Identifier	"Standard VGA"
    VendorName	"Unknown"
    BoardName	"Unknown"

# The chipset line is optional in most cases.  It can be used to override
# the driver's chipset detection, and should not normally be specified.

#    Chipset	"generic"

# The Driver line must be present.  When using run-time loadable driver
# modules, this line instructs the server to load the specified driver
# module.  Even when not using loadable driver modules, this line
# indicates which driver should interpret the information in this section.

    Driver     "vga"
# The BusID line is used to specify which of possibly multiple devices
# this section is intended for.  When this line isn't present, a device
# section can only match up with the primary video device.  For PCI
# devices a line like the following could be used.  This line should not
# normally be included unless there is more than one video device
# intalled.

#    BusID      "PCI:0:10:0"

#    VideoRam	256

#    Clocks	25.2 28.3

EndSection

# Device configured by xorgconfig:

Section "Device"
    Identifier  "** ATI Radeon (generic)               [radeon]"
    Driver      "radeon"
    #VideoRam    65536
    # Insert Clocks lines here if appropriate
EndSection
A moje pytanie brzmi: Którą sekcje zmienić?
[url=http://www.madsheytan.blogspot.com][img]http://img146.imageshack.us/img146/3848/forumstopka.png[/img][/url]
Slackware, because it works. Kubuntu, because it works. Windows, because it syncs my iPod...

Awatar użytkownika
Lizard
Moderator
Posty: 2582
Rejestracja: 2005-05-21, 15:48
Lokalizacja: miasto w mieście

Re: intalacja sterowników ATI

Post autor: Lizard » 2007-07-03, 20:47

Jak tak wygląda Twój konfig to nic nie zmieniaj, tylko wykonaj aticonfig --initial.
Error 404 - footer not found

Awatar użytkownika
Sheytan
Użytkownik
Posty: 473
Rejestracja: 2007-03-31, 10:44
Lokalizacja: Ligota Piękna/Wro
Kontakt:

Re: intalacja sterowników ATI

Post autor: Sheytan » 2007-07-03, 21:10

wykonałem aticonfig --initial i po restarcie X'y nie ruszają :/
[url=http://www.madsheytan.blogspot.com][img]http://img146.imageshack.us/img146/3848/forumstopka.png[/img][/url]
Slackware, because it works. Kubuntu, because it works. Windows, because it syncs my iPod...

Awatar użytkownika
Lizard
Moderator
Posty: 2582
Rejestracja: 2005-05-21, 15:48
Lokalizacja: miasto w mieście

Re: intalacja sterowników ATI

Post autor: Lizard » 2007-07-03, 21:29

No to zajrzyj do /var/log/Xorg.0.log i zobacz czemu marudzi.
Error 404 - footer not found

Awatar użytkownika
Sheytan
Użytkownik
Posty: 473
Rejestracja: 2007-03-31, 10:44
Lokalizacja: Ligota Piękna/Wro
Kontakt:

Re: intalacja sterowników ATI

Post autor: Sheytan » 2007-07-03, 21:49

Tu jest ten loghttp://www.sendspace.com/file/d57tzz Jak możesz to zajrzyj do niego, bo ja tak nie za bardzo się tam umiem połapać ;)
Ostatnio zmieniony 2007-07-03, 21:53 przez Sheytan, łącznie zmieniany 1 raz.
[url=http://www.madsheytan.blogspot.com][img]http://img146.imageshack.us/img146/3848/forumstopka.png[/img][/url]
Slackware, because it works. Kubuntu, because it works. Windows, because it syncs my iPod...

ODPOWIEDZ