Slackware Current eXtended Desktop

Informacje i dyskusje na najświeższe tematy z branży IT

Moderatorzy: Moderatorzy, Administratorzy

borys
Użytkownik
Posty: 44
Rejestracja: 2004-09-09, 16:24
Lokalizacja: podbeskidzie

Re: Slackware Current eXtended Desktop

Post autor: borys »

Witam. Dawno nie używałem Slackware. A ostatnio przechodzę na łatwiznę i chciałbym używać "slapt-get.
Mam zainstalowane Slackware 11
Nie mam Current i jestem ciekaw czy mógłbym się "podłączyć" do repozytorium SCXD ?
Slackware 11.0 / KDE

largo3
Moderator
Posty: 1297
Rejestracja: 2006-06-11, 11:08

Re: Slackware Current eXtended Desktop

Post autor: largo3 »

W wielu przypadkach paczki na Current powinny działać. Należy jednak pamiętać, że w chwili obecnej różnice pomiędzy 11.0 a Current są bardzo duże (toolchain, X'y i KDE w /usr) tak, że należy brać na to poprawkę przy instalacji. W wypadku gdyby jakaś paczka nie działała zawsze można użyć dostępnego do niej SlackBuilda, w nim zmienić opcje kompilacji (najczęściej będą to prefiksy) i skompilować.
UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity.
-- Dennis Ritchie
Linux Registered User #419452

borys
Użytkownik
Posty: 44
Rejestracja: 2004-09-09, 16:24
Lokalizacja: podbeskidzie

Re: Slackware Current eXtended Desktop

Post autor: borys »

Oprócz pierwszego zdania niewiele zrozumiałem.
No cóż będę czytał i uczył się.
Oby nie na błędach.
Dziękuję.
Slackware 11.0 / KDE

largo3
Moderator
Posty: 1297
Rejestracja: 2006-06-11, 11:08

Re: Slackware Current eXtended Desktop

Post autor: largo3 »

largo3 pisze:różnice pomiędzy 11.0 a Current są bardzo duże (toolchain, X'y i KDE w /usr) tak, że należy brać na to poprawkę przy instalacji.
W Slackware 11.0 Xorg jest instalowany do /usr/X11R6 a KDE do /opt i programy kompilowane na 11.0 tam właśnie szukają X'ów i KDE. W SCXD.info programu kompilowane są do działania w Slackware Current gdzie X'y i KDE są w /usr. Z powodu tej różnicy programy z paczek dla Currenta zainstalowane na 11.0 "nie znajdą" X'ów i/lub KDE. Oczywiście nie dotyczy to wszystkich programów z SCXD, a tylko tych wymagających X'ów/KDE.
Co do SlackBuildów i tworzenia paczek to w FAQ jest kilka artykułów na ten temat: #1 #2 #3.
Pozdr.
PS: Najlepiej jest uczyć się na błędach. ;)
UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity.
-- Dennis Ritchie
Linux Registered User #419452

borys
Użytkownik
Posty: 44
Rejestracja: 2004-09-09, 16:24
Lokalizacja: podbeskidzie

Re: Slackware Current eXtended Desktop

Post autor: borys »

Tak to jest largo3 z ludźmi którzy nigdy w szkole nie mieli informatyki.
Tak. Na cudzych błedach podobno nie da się niczego nauczyć.
Należy je jednak obserwować.
Pocieszam się że może te informacje przydadzą się nie tylko mnie.
Dziękuję
Slackware 11.0 / KDE

Awatar użytkownika
k-men
Użytkownik
Posty: 49
Rejestracja: 2005-09-10, 19:50
Lokalizacja: ~/

Re: Slackware Current eXtended Desktop

Post autor: k-men »

Kod: Zaznacz cały

yakuake 2.7.5
proponuję zmienić prefix na obowiązujący w current z: /opt/kde na /usr
Kto był na morzu, ten nie będzie się bał kałuż.

Awatar użytkownika
Zielony
Użytkownik
Posty: 535
Rejestracja: 2005-03-17, 18:22
Lokalizacja: Poznań
Kontakt:

Re: Slackware Current eXtended Desktop

Post autor: Zielony »

Uruchomiliśmy RSS ChangeLoga. Więcej informacji na stronie.

Prosimy o dalsze pisanie w sprawach paczek - czy to jeśli chodzi o aktualizacje, czy o propozycje nowych. Uwierzcie, że jest to pomocne i motywujące.
Żyję - nie każdemu się zdarza - a we krwi mam chlorofil.
[url=http://scxd.info/][img]http://scxd.info/pub/scxdbar/scxd-bar.png[/img][/url]
[b]Registered User #448882[/b]
[img]http://scxd.info/say/img.php[/img]

Awatar użytkownika
branco
Użytkownik
Posty: 24
Rejestracja: 2005-11-13, 18:26
Lokalizacja: Wrocek

Re: Slackware Current eXtended Desktop

Post autor: branco »

Dwie sprawy:
  • 1) propozycja nowych paczek: libgnomeui

    2) przy instalacji wxWidgets-2.8 slapt-getem występuje problem z niespełnioną zależnością z tcpip. (Dystrybucja to Slackware 12 plus ustawione repozytorium SCXD). Po bliższym spojrzeniu na Changelog (tu na forum) okazało się, że takiego pakietu w 12 nie ma. Nie wiem jednak, co jest takiego w wxWidgets, co potrzebuje tcpip, ani w którym pakiecie tego szukać. Wydaje mi się, że wystarczy aktualizacja PACKAGES.TXT i odpowiedniego pliku slack-required, aby instalacja slapt-getem się powiodła Ręcznie zainstalowany pakiet jesk ok.

Awatar użytkownika
Zielony
Użytkownik
Posty: 535
Rejestracja: 2005-03-17, 18:22
Lokalizacja: Poznań
Kontakt:

Re: Slackware Current eXtended Desktop

Post autor: Zielony »

branco:

1) Niestety, póki co to jest niemożliwe, gdyż libgnomeui wymaga glib w wersji co najmniej 2.13.4, a w Slackware jest starsza. Jeżeli Patrick zaktualizuje glib, to wtedy się za to wezmę. Mamy taką zasadę, że nie podważamy autorytetu paczek oficjalnych.

2) wxGTK z gałęzi 2.6 i 2.8 zaktualizowane. PACKAGES.TXT jest generowane codziennie po 15 i 23.
Żyję - nie każdemu się zdarza - a we krwi mam chlorofil.
[url=http://scxd.info/][img]http://scxd.info/pub/scxdbar/scxd-bar.png[/img][/url]
[b]Registered User #448882[/b]
[img]http://scxd.info/say/img.php[/img]

Awatar użytkownika
afromat
Użytkownik
Posty: 17
Rejestracja: 2004-12-14, 21:40
Lokalizacja: Wrocław/Koszalin

Re: Slackware Current eXtended Desktop

Post autor: afromat »

Zielony:
Chodzi o paczkę OOo 2.3.0 . Po ściągnięciu jej i próbie instalacji/otworzenia wywala komunikat

Kod: Zaznacz cały

gzip: stdin: Invalid compressed data--format violated
Pisałem do Ciebie na maila, ale pomyślałem że ktoś coś na ten temat może mieć do powiedzenia.

Awatar użytkownika
Zielony
Użytkownik
Posty: 535
Rejestracja: 2005-03-17, 18:22
Lokalizacja: Poznań
Kontakt:

Re: Slackware Current eXtended Desktop

Post autor: Zielony »

Jeszcze raz dzięki za informację.

Paczka była źle wysłana. Wysłałem ją jeszcze raz i jest w porządku (suma się zgadza), a u mnie działa.
Żyję - nie każdemu się zdarza - a we krwi mam chlorofil.
[url=http://scxd.info/][img]http://scxd.info/pub/scxdbar/scxd-bar.png[/img][/url]
[b]Registered User #448882[/b]
[img]http://scxd.info/say/img.php[/img]

Awatar użytkownika
roverek
Użytkownik
Posty: 605
Rejestracja: 2007-02-22, 18:29
Lokalizacja: Szczecin

Re: Slackware Current eXtended Desktop

Post autor: roverek »

Heh a ja proponuje upgrade paczek Compiz Fusion.
[img]http://img148.imageshack.us/img148/9879/slackware1userbarzl9.gif[/img]
[img]http://img162.imageshack.us/img162/2268/barritagoogless6.jpg[/img]
[img]http://img.userbars.pl/42/8201.gif[/img]

Awatar użytkownika
darjerz
Użytkownik
Posty: 1052
Rejestracja: 2004-05-28, 18:26
Lokalizacja: Wrocław

Re: Slackware Current eXtended Desktop

Post autor: darjerz »

Compiz Fusion 0.6.0 już przecież jest :d, byłbym wdzięczy za paczki pod currenta :d Bo jakoś sie nie mogę zmobilizować do kompilacji.
Nie ma rzeczy niemożliwych dla kogoś, kto nie musi ich zrobić sam.

Awatar użytkownika
roverek
Użytkownik
Posty: 605
Rejestracja: 2007-02-22, 18:29
Lokalizacja: Szczecin

Re: Slackware Current eXtended Desktop

Post autor: roverek »

Heh może już jest ale mi chodzi o to aby zaktualizować paczki compiz fusion stworzone przez scxd.info, bo w changelogu nadal jest wersja 0.5.2 a jest już wydana wersja 0.6.0
[img]http://img148.imageshack.us/img148/9879/slackware1userbarzl9.gif[/img]
[img]http://img162.imageshack.us/img162/2268/barritagoogless6.jpg[/img]
[img]http://img.userbars.pl/42/8201.gif[/img]

Awatar użytkownika
Zielony
Użytkownik
Posty: 535
Rejestracja: 2005-03-17, 18:22
Lokalizacja: Poznań
Kontakt:

Re: Slackware Current eXtended Desktop

Post autor: Zielony »

Dzięki za informację. Zaktualizowane. Usunąłem paczkę compiz-fusion, bo to ten sam pakiet, co compiz w Slackware. Jeżeli się mylę, to mnie poprawcie.
Żyję - nie każdemu się zdarza - a we krwi mam chlorofil.
[url=http://scxd.info/][img]http://scxd.info/pub/scxdbar/scxd-bar.png[/img][/url]
[b]Registered User #448882[/b]
[img]http://scxd.info/say/img.php[/img]

Zablokowany