Strona 1 z 1

[Rozw.] Ntfs-3g i polske znaki

: 2007-12-29, 17:48
autor: kolert83
Witam

Mój problem polega na tym,że po instalacji ntfs-3g i dokonaniu wpisów do fstab:

Kod: Zaznacz cały

/dev/hdb1        /mnt/F           ntfs-3g     user,fmask=0111,dmask=0,succeed_chmod,silent,locale=pl_PL.utf8 0 0 
nie ma polskich znaków. Utrudnia mi to życie, bo nie potrafię skopiować nazw z : ą,ę itd... na partycje NTFS . Ma ktoś jakiś pomysł ??

Re: [Rozw.] Ntfs-3g i polske znaki

: 2007-12-29, 18:42
autor: largo3
Pokaż wynik

Kod: Zaznacz cały

locale -a

Re: [Rozw.] Ntfs-3g i polske znaki

: 2007-12-29, 19:16
autor: kolert83
Trochę długi ten locale :mrgreen: wiec skopiowałem tylko kawałek :

Kod: Zaznacz cały

om_ET
om_KE
om_KE.utf8
or_IN
pa_IN
pa_PK
pl_PL
pl_PL.utf8
POSIX
pt_BR
pt_BR.utf8
pt_PT
pt_PT@euro
pt_PT.utf8
ro_RO
ro_RO.utf8
ru_RU

Re: [Rozw.] Ntfs-3g i polske znaki

: 2007-12-29, 19:29
autor: slackman
to jest linijka z mojego fstaba, może tak zadziała (iocharset):

Kod: Zaznacz cały

/dev/sda1        /mnt/win_c       ntfs-3g        noauto,users,nosuid,umask=002,gid=100,iocharset=iso8859-2 0 0

Re: [Rozw.] Ntfs-3g i polske znaki

: 2007-12-29, 20:23
autor: largo3
man ntfs-3g pisze:locale=value
This option can be useful if your language specific locale environment variables are not set correctly or at all in your operating system. In such cases, the national characters can be made visible by using this option. Please see more information about this topic at http://ntfs-3g.org/support.html#locale
Na pewno masz system w UTF-8? U mnie przy lokalizacji:

Kod: Zaznacz cały

<| largo3|base ~ |> locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=en_US.UTF-8
zapis z polskimi znakami na partycji windowsowej działa bez podawania locale w /etc/fstab.

Pokaż jeszcze

Kod: Zaznacz cały

locale

Re: [Rozw.] Ntfs-3g i polske znaki

: 2007-12-29, 21:55
autor: kolert83

Kod: Zaznacz cały

locale
dało taki wynik :

Kod: Zaznacz cały

LANG=pl
LC_CTYPE="pl_PL"
LC_NUMERIC="pl_PL"
LC_TIME="pl_PL"
LC_COLLATE="pl_PL"
LC_MONETARY="pl_PL"
LC_MESSAGES="pl_PL"
LC_PAPER="pl_PL"
LC_NAME="pl_PL"
LC_ADDRESS="pl_PL"
LC_TELEPHONE="pl_PL"
LC_MEASUREMENT="pl_PL"
LC_IDENTIFICATION="pl_PL"
LC_ALL=pl_PL
Slackman, opcja z iso8859 - 2 niepomogła :sad:

Re: [Rozw.] Ntfs-3g i polske znaki

: 2007-12-29, 22:00
autor: largo3
Patrząc na wynik Twojego locale stwierdzam, że nie masz systemu w UTF-8. Spróbuj usunąć w /etc/fstab w linii dotyczącej partycji Windowsa wszystkie wpisy typu locale czy iocharset, odmontować partycję i zamontować ją ponownie.

Re: [Rozw.] Ntfs-3g i polske znaki

: 2007-12-29, 22:05
autor: kolert83
Podziałało :ok: Punkt dla Ciebie