problem z haslem

Te, które nie mieszczą się w powyższych kategoriach, a mają coś wspólnego ze Slackware.

Moderatorzy: Moderatorzy, Administratorzy

cool_beny
Użytkownik
Posty: 3
Rejestracja: 2009-03-15, 23:21

problem z haslem

Post autor: cool_beny » 2009-03-15, 23:33

Witam,

Zwyczajowo nie lubię zawracać dupy na forach bo większość odpowiedzi jest w google ale dzisiaj zgłupiałem już i nie wiem co jest nie tak albo co ja robie źle.

Dostałem serwerek jakiś czas temu (slack 2.6.11.12-Murin) Z racji upływu czasu zapomniałem hasła do niego no ale to nie problem, odpaliłem boot cd zrobiłem mount chroot potem passwd dla pewności sprawdziłem pliki czy zmieniły sie sumy kontrolne reboot a tu zonk login incorrect. no ok jeszcze raz podmontowałem wyzerowałem pliki znów reboot i dalej zonk login incorrect. zrobiłem jeszcze raz chroot dodałem nowego usera ustawiłem haslo i to samo. Co moze byc przyczyna? dlaczego shadows sie zmienia a przy logowania dostaje komunikat login incorrect.

Albo może znacie jakiś inny sposób na reset hasła ?

Awatar użytkownika
Flash
Użytkownik
Posty: 633
Rejestracja: 2004-11-09, 18:14
Lokalizacja: Myszkow
Kontakt:

Re: problem z haslem

Post autor: Flash » 2009-03-15, 23:38

Nigdy nie ustawiam pustego hasła dla roota, tworzę nowe konto i ustawiam na nim hasło i potem kopiuję hash z /etc/shadow tego usera w miejsce hasła roota i loguję się na roota za pomocą hasła usera i zmieniam je na takie jakie chce.
Nie chrootuj się tylko uruchom bootcd i z niego podmontuj partycję i dodaj usera do systemu bootcd a potem dodaj hash do pliku /punkt_montowania/etc/shadow

cool_beny
Użytkownik
Posty: 3
Rejestracja: 2009-03-15, 23:21

Re: problem z haslem

Post autor: cool_beny » 2009-03-15, 23:58

no tylko do końca nie rozumie co to zmieni? po wyzerowaniu plików zrobiłem chroot potem passwd, w shadow pojawił sie wpis jeszcze sync dla pewności ale po reboocie nic to nie zmieniło. nie mam oryginalnej płyty montuje całości linux rip cd

jacol
Przyjaciel Forum
Posty: 679
Rejestracja: 2004-06-12, 17:34

Re: problem z haslem

Post autor: jacol » 2009-03-16, 11:37

Witam.
Odpalasz slaxa z cd czy z usb. Robisz z plikiem /etc/shadow co chcesz np. podmieniasz cały plik z znanym hasłem lub robisz co proponuje Flash. Pozdrawiam jacol
PS. Czynisz system plików rw? Zdaje się że domyślnie jest tylko r.

magnusek
Użytkownik
Posty: 46
Rejestracja: 2004-10-05, 16:08

Re: problem z haslem

Post autor: magnusek » 2009-03-16, 12:18

a nie masz ustawionej flagi nosuid w fstab?
ja ostatnio miałem podobnie :D

cool_beny
Użytkownik
Posty: 3
Rejestracja: 2009-03-15, 23:21

Re: problem z haslem

Post autor: cool_beny » 2009-03-19, 09:45

System montuje w trybie rw, nie mniej jednak żadna z propozycji nie działa, stwierdziłem dzisiaj ze usunę jednak wszystko i postawie do co znam najlepiej czyli debiana. Właśnie zasysam 5.

Dzięki wszystkim za pomoc.

ODPOWIEDZ