Konsola, polskie znaki i bardzo dziwne zjawisko.

Te, które nie mieszczą się w powyższych kategoriach, a mają coś wspólnego ze Slackware.

Moderatorzy: Moderatorzy, Administratorzy

sp7foy
Użytkownik
Posty: 167
Rejestracja: 2008-02-26, 15:07
Lokalizacja: Skierniewice

Konsola, polskie znaki i bardzo dziwne zjawisko.

Post autor: sp7foy »

Witam.

Natknąłem się na bardzo dziwny problemik, taki typowo windowsowy.
Otóż mam kompa stacjonarnego i laptopa.
Na obu Slack 12.2 i konsola z FB.

Na obu robię:
loadkeys /usr/share/kbd/keymaps/i386/qwerty/pl2.map.gz
setfont /usr/share/kbd/consolefonts/lat2a-16.psfu.gz

i na obu mam poprawnie wyświetlane polskie znaki, ale ...

jeśli załaduję czcionkę lat2-10 to na jednym (stacjonarnym) jest poprawnie a na drugim jest tylko literka ó a pozostałe to znaki zapytania w inwersji.
Pliki czcionki są na pewno identyczne.


W zasadzie to jedyną różnicą jest karta graficzna (Radeon 2900 i Intel GMA950).
Ma ktoś jakiś pomysł gdzie może się kryć problem?
largo3
Moderator
Posty: 1297
Rejestracja: 2006-06-11, 11:08

Re: Konsola, polskie znaki i bardzo dziwne zjawisko.

Post autor: largo3 »

locale w obu systemach są takie same? Pokaż wyniki locale.
UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity.
-- Dennis Ritchie
Linux Registered User #419452
sp7foy
Użytkownik
Posty: 167
Rejestracja: 2008-02-26, 15:07
Lokalizacja: Skierniewice

Re: Konsola, polskie znaki i bardzo dziwne zjawisko.

Post autor: sp7foy »

largo3 pisze:locale w obu systemach są takie same? Pokaż wyniki locale.
Z rana jak przeczytałem to pytanie to byłem pewny, że będą różne.
Niestety ustawienia są identyczne. Wszystko na obu en_US. Zmieniłem na pl_PL i jest dokładnie to samo. Mówiąc wprost to na polskie znaki wprowadzane z klawiatury w konsoli te ustawienia nie robią żadnej różnicy.
ODPOWIEDZ