S12.2+libopensync=kicha :(

Te, które nie mieszczą się w powyższych kategoriach, a mają coś wspólnego ze Slackware.

Moderatorzy: Moderatorzy, Administratorzy

Awatar użytkownika
SaraniS
Użytkownik
Posty: 176
Rejestracja: 2005-08-10, 08:22
Lokalizacja: Olesno Slaskie
Kontakt:

S12.2+libopensync=kicha :(

Post autor: SaraniS »

Witam
Slackware 12.2 i nie chcę go zmieniać (znów tracić miesiące na uruchomienie podstawowych rzeczy, poza tym S13 ma już KDE4, którego również nie chcę).
Próbowałem libopensync-0.36 (z pluginami) ze Slacky.it - nierozwiązane zależności (dla właśnie pluginu syncml): libsoup, które wymaga GnuTLS 1.3; nie wiem czy nie coś jeszcze. Libsoup gdzieś znalazłem, ale właśnie zbyt nowe, korzystające z nowszego GnuTLS. Niestety, tego, w wersji odpowiedniej, nie znalazłem już nigdzie.
Następnie próba kompilacji - wersji 0.22 (ostatnia stabilna, bo te 0.3x z SVN to chyba bety? na stronie opensync opisane są jako developerskie) - nie da się w żaden sposób skompilować tegoż syncml.
Szukanie binarek 0.22 - znalazłem, owszem - tylko główną paczkę, bez pluginów :P
Kompilacja wersji 0.36 (ostatnia mająca syncml) - błędy kompilacji, nie umie znaleźć nagłówków (albo ja nie wiem, jak posługiwać się CMake).
Może ktoś ma i może mnie poratować paczuszkami: libopensync + libopensync-plugin-syncml + libopensync-plugin-kdepim + zależności w wersji dowolnej pod S12.2 ? Tudzież ten GnuTLS 1.3 albo libsoup w wersji wymagającej GnuTLS w wersji fabrycznej dla S12.2 (26.11.3) ?
Z góry dzięki

A swoją drogą, aż trudno uwierzyć, że albo wszystkim się to kompiluje/ instaluje bez problemu, albo też - że nikt nie używa synchronizacji smartphona z PIM...

Inna sprawa - po co w ogóle (w KDE 3.5) jest Kandy, skoro nie wiem, czy umie połączyć się z jakąś komórką (kilka testowałem z negatywnymi wynikami)...
Toshiba Satellite L40-14B: Cel530 1.73GHz/ 2GiB RAM/ 320GiB HDD Slackware 14.0 Linux 3.2.29, KDE 4.8.5, Opera 12, Skype 4.2, XMMS/ amarok/ MPlayer
RLU #398894

rosencrantz
Użytkownik
Posty: 67
Rejestracja: 2006-12-01, 01:57

Re: S12.2+libopensync=kicha :(

Post autor: rosencrantz »

Potrzebowałem tej biblioteki do synchronizacji mojego Blackberry za pomocą Barryego. Zalecana była instalacja wersji 0.22. Wszystkie źródła są na stronie domowej projektu, łącznie z pluginami i paroma bibliotekami. Przy konfiguracji źródeł będziesz dostawał błędy o brakujących bibliotekach. Ja musiałem doinstalować chyba z 6. Na szczęście prawie wszystko znajdziesz na slackfind.net w paczkach. Wersja 0.3x ma całkowicie inną architekturę (o ile pamiętam tak stało w opisie) i jest odradzana. Poszukaj także w projektach Gnome dla Slackware( np. GSB), tam masz paczki z bibliotekami (libsoup) dla swojej wersji Slacka.

ODPOWIEDZ