nie startuje kde:(

Te, które nie mieszczą się w powyższych kategoriach, a mają coś wspólnego ze Slackware.

Moderatorzy: Moderatorzy, Administratorzy

lamcpp
Użytkownik
Posty: 49
Rejestracja: 2006-01-21, 13:41

nie startuje kde:(

Post autor: lamcpp »

chciałem spolszyc kde z faqa który podajecie na tej stronie. do punktu 4 było dobrze

Kod: Zaznacz cały

 4.Polski układ klawiatury można wybrać w graficznym konfiguratorze (GNOME, KDE). Można też wyedytować /etc/X11/xorg.conf odnajdując i zmieniając ten fragment: 
Kod: 
Section "InputDevice" 

    Identifier "Keyboard1" 
    Driver "Keyboard" 
    Option "XkbModel" "pc105" 
    Option "XkbLayout" "pl" 
wyedytowałem te 4 opcje ale nie potrzbnie zmieniłem sterownik:/ u mnie było kbd zamiast keyboard1 i teraz mi nie chce kde wystartowac. wyswietla sie taki bład:

Kod: Zaznacz cały

Using config file: "etc/X11/xorg.conf" 
(EE) Failed to load module "keyboard1" (module does not exist,0)
(EE) No input driver matching 'keyboard1'
No core keyboard
Fatal server error:
failed to initialize core devices:(
próbowałem wejsc do pliku /etc/X11/xorg.conf za pomocą vi i edytowac to, ale nic nie mozna edytowac:( 
ktos ma jakis pomysł co zrobic? (mam kde 3.2)
[/quote]

Awatar użytkownika
Lizard
Moderator
Posty: 2607
Rejestracja: 2005-05-21, 15:48
Lokalizacja: miasto w mieście

Re: nie startuje kde:(

Post autor: Lizard »

Jeśli masz kłopoty z używaniem vi, to skorzystaj z mcedit (jeśli instalowałeś pakiet Midnight Commandera).

W razie trudności skrócona instrukcja obsługi vi:
  • przejście w tryb edycji - i
  • przejście w tryb poleceń - Esc
  • w trybie poleceń:
    • skasowanie znaku pod kursorem - dl
    • skasowanie tekstu od kursora do końca słowa w prawo - dw
    • skasowanie bieżącej linii - dd
    • zapis - :w
    • zapis pod nową nazwą: - :w nazwa_pliku
    • wyjście - :q
    • zapis i wyjście - :wq
    • wyjście bez zapisywania - :q!
Opisałem, bo jakoś w FAQ nie mogłem znaleźć, a wydawało mi się, że było. :?
Error 404 - footer not found

Awatar użytkownika
zzrock
Użytkownik
Posty: 40
Rejestracja: 2005-07-17, 15:24
Lokalizacja: Słupsk
Kontakt:

Re: nie startuje kde:(

Post autor: zzrock »

lamcpp zawsze przed edycją ważnych plikow dla systemu, rób kopię zapasową, gdy nie jest się pewnym tego co się robi

bocian
Użytkownik
Posty: 678
Rejestracja: 2005-06-15, 10:15

Re: nie startuje kde:(

Post autor: bocian »

xorg.conf nie jest ważnym plikiem systemowym. To tylko plik konfiguracyjny pewnego popularnego programu.

Awatar użytkownika
zzrock
Użytkownik
Posty: 40
Rejestracja: 2005-07-17, 15:24
Lokalizacja: Słupsk
Kontakt:

Re: nie startuje kde:(

Post autor: zzrock »

przepraszam, źle się wyraziłem, ale nie chodzi o to, chodzi o samą idee

lone_wolf

Re: nie startuje kde:(

Post autor: lone_wolf »

zzrock pisze:chodzi o samą idee
Dla samej idei to możesz walnąć xorgconfig i za 3 min masz wszystko ustawione.Jak się boisz vima to spróbuj pico, nie jest zły.Co do polskiej klawiatury to właśnie przy ustawianiu x-ów ją wybierzesz, tylko patrz co naciskasz

lamcpp
Użytkownik
Posty: 49
Rejestracja: 2006-01-21, 13:41

Re: nie startuje kde:(

Post autor: lamcpp »

dzięki za pomoc, kde juz mi startuje, choc dalej jest problem z polską czcionką, pisze teraz spod linuxa i jak widac tutaj wszystkie pl znaki są widoczne, tak samo jest na czacie, ale np w kadu, kwordzie z polskich znaków są tylko "ł" i "ć" a pozostałe wyswietlane są jako kwadraciki , w locales mam wszystko zakonczone na pl_PL ,klawiature zmienioną na polską, region na polske, wszystko zrobiłem wg faqu dostepnego na tej stronie
ps. jak sie tworzy kopie zapasową? wystarczy skopiowac plik i zapisac go gdzie indziej?

Awatar użytkownika
zzrock
Użytkownik
Posty: 40
Rejestracja: 2005-07-17, 15:24
Lokalizacja: Słupsk
Kontakt:

Re: nie startuje kde:(

Post autor: zzrock »

lone_wolf pisze:Dla samej idei to możesz walnąć xorgconfig
racja, robienie kopi zapasowej plików kluczowych jest bez sensu. Po co sobie ułatwiać życie, jak można je sobie utrudnić. Lepiej poświęcić 3 min na xorgconfig, niż 30 sekund na znalezienie kopi pliku i przeniesienie go w odpowiednie miejsce.


Kopia zapasowa polega po prostu na skopiowaniu danego pliku w jakieś bezpieczne miejsce

lone_wolf

Re: nie startuje kde:(

Post autor: lone_wolf »

zzrock pisze:racja, robienie kopi zapasowej plików kluczowych jest bez sensu. Po co sobie ułatwiać życie, jak można je sobie utrudnić. Lepiej poświęcić 3 min na xorgconfig, niż 30 sekund na znalezienie kopi pliku i przeniesienie go w odpowiednie miejsce.
Masz na myśli coś takiego jak wejście do /etc/X11 i wykonanie cp xorg.conf xorg.conf_kopia
czy tak?. Najlepsze wyjście bo nie musi szukać tej kopii po katalogach dyskietkach itp. Wystarczy oryginalny xorg.conf usunąć, później zrobić cp xorg.conf_kopia xorg.conf i się dalej bawić. Tyle tylko że on tej kopii nie miał. Teraz ma nauczkę i ją zrobi. Niepotrzebny sarkazm z twojej strony.

Awatar użytkownika
zzrock
Użytkownik
Posty: 40
Rejestracja: 2005-07-17, 15:24
Lokalizacja: Słupsk
Kontakt:

Re: nie startuje kde:(

Post autor: zzrock »

każde rozwiazanie, które działa jest dobre. Każdy problem można rozwiazać na kilka sposobów. Kolega nie mógł sobie z tym poradzić, więc odpowiedzieliśmy mu na zadane przez niego pytanie. Przepraszam jeżeli uraziłem Cię moją wypowiedzią.

Awatar użytkownika
Ciuciu
Administrator
Posty: 921
Rejestracja: 2004-05-26, 21:01
Lokalizacja: 3C17y
Kontakt:

Re: nie startuje kde:(

Post autor: Ciuciu »

lamcpp pisze:chciałem spolszyc kde z faqa który podajecie na tej stronie. do punktu 4 było dobrze

Kod: Zaznacz cały

 4.Polski układ klawiatury można wybrać w graficznym konfiguratorze (GNOME, KDE). Można też wyedytować /etc/X11/xorg.conf odnajdując i zmieniając ten fragment: 
Kod: 
Section "InputDevice" 

    Identifier "Keyboard1" 
    Driver "Keyboard" 
    Option "XkbModel" "pc105" 
    Option "XkbLayout" "pl" 
wyedytowałem te 4 opcje ale nie potrzbnie zmieniłem sterownik:/ u mnie było kbd zamiast keyboard1 i teraz mi nie chce kde wystartowac. wyswietla sie taki bład:

Kod: Zaznacz cały

Using config file: "etc/X11/xorg.conf" 
(EE) Failed to load module "keyboard1" (module does not exist,0)
(EE) No input driver matching 'keyboard1'
No core keyboard
Fatal server error:
failed to initialize core devices:(
próbowałem wejsc do pliku /etc/X11/xorg.conf za pomocą vi i edytowac to, ale nic nie mozna edytowac:( 
ktos ma jakis pomysł co zrobic? (mam kde 3.2)
[/quote]
Strzeliłeś gafę: ustawiłeś sobię klawiature o nazwie Keyboard1 - że masz i że używa takich opcji etc, ale gdzie indziej (prawdopodobnie w Profile czy gdzies niżej wczytałeś 'keyboard1' (mała literka) popraw..
[color=#888888][i][size=75]Whatever walks in my heart
Will walk alone...[/size][/i][/color]

Awatar użytkownika
Artez
Użytkownik
Posty: 24
Rejestracja: 2005-08-02, 17:40
Lokalizacja: warszawa
Kontakt:

Re: nie startuje kde:(

Post autor: Artez »

Driver "Keyboard"
Niepotrzebnie zmieniłeś tą linijke. Kożystałeś pewnie z faq w tym serwisie, a tam jest błąd. Jeżeli nikt nie poda ci rozwiązania do jutra około południa to wkleje ci mój wpis z tego pliku, ponieważ teraz nie mam czasu się na linuksa przełączyć.

maciekt
Użytkownik
Posty: 10
Rejestracja: 2006-02-08, 13:07
Kontakt:

Re: nie startuje kde:(

Post autor: maciekt »

xorgsetup
pewnie zalatwi sprawe

przemek999
Pomocnik
Posty: 1157
Rejestracja: 2005-03-04, 18:27

Re: nie startuje kde:(

Post autor: przemek999 »

Wystarczy:

Kod: Zaznacz cały

X -configure
i wlasnoreczne dopieszczenie configu z manualem xorg.conf !
Tak wygenerowany config jest wolny od komentarzy i zawiera tylko konieczne wpisy.

Awatar użytkownika
Artez
Użytkownik
Posty: 24
Rejestracja: 2005-08-02, 17:40
Lokalizacja: warszawa
Kontakt:

Re: nie startuje kde:(

Post autor: Artez »

Obiecałem wkleić to wklejam, ale pewnie ci się już nie przyda:
Identifier "Keyboard1"
Driver "kbd"
Co do czcionki, wejdź w centrum sterowania->wygląd i motywy i ustaw sobie wszystkie czcionki na Luxi Sans(jeżeli chodzi o wyświetlania). Jeżeli o układ klawiatury to przechodzisz do odpowiedniego działu i również zmieniasz.

ODPOWIEDZ