[ROZW]Problem z kodowaniem

Problemy dotyczące programowania.

Moderatorzy: Moderatorzy, Administratorzy

Awatar użytkownika
chevy
Użytkownik
Posty: 138
Rejestracja: 2005-02-06, 15:51
Lokalizacja: Tarnowskie Góry
Kontakt:

[ROZW]Problem z kodowaniem

Post autor: chevy »

Witam!
Nie wiem w jaki miejscu zamieścić temat wiec jak to nie to miejsce to sorry :)

Problem polega na tym że wysyłam sobie maila ze skryptu PHP i gdy wysyłam z jednego serwera to mail jest załadowany z nagłówkami i jest czytelny.
A gdy wysyłam z drugiego serwera to mail jest wysyłany ze znacznikami i jest nie czytelny.

Nie wiem czy wina leży w konfiguracji Apache lub PHP czy błąd ukryty całkiem gdzie indziej.

Pozdrawiam
Ostatnio zmieniony 2009-12-02, 12:01 przez chevy, łącznie zmieniany 1 raz.
Awatar użytkownika
mina86
Moderator
Posty: 3338
Rejestracja: 2004-06-14, 21:58
Lokalizacja: Linux 5.x x86_64
Kontakt:

Re: [ROZW]Problem z kodowaniem

Post autor: mina86 »

(Przenoszę do Programowanie).

Podaj przykład.
Zastrzegam sobie prawo nieanalizowania postów pisanych niepoprawną polszczyzną.
Post generated automatically by A.I. system code name ‘mina86’ in response to the previous one.
Awatar użytkownika
chevy
Użytkownik
Posty: 138
Rejestracja: 2005-02-06, 15:51
Lokalizacja: Tarnowskie Góry
Kontakt:

Re: [ROZW]Problem z kodowaniem

Post autor: chevy »

Z pierwszego serwerka wszystko ladnie pieknie:

Kod: Zaznacz cały

Wiadomość z dnia: 01-10-2009 godzina: 11:30 

Imię i Nazwisko: eeee
Adres w Irlandi: eeee
Nr telefonu: eee
E-mail: ee
Dodatkowa tresc: eee
pytanie 1: TAK
pytanie 2: TAK 
pytanie 3: TAK
Jak mamy się z Tobą kontaktować: telefonicznie
pytanie 4: TAK
pytanie 5: : TAK
natomiast ten sam skrypt na innym serwerze (na moim) wysyla maila jakby bez naglowkow:

Kod: Zaznacz cały

Content-type: text/html; charset=iso-8859-2
From: dfrfe <erferf@moj.serwer.pl>
Message-Id: <20091001103320.CC87813AC1@moj.serwer.pl>
Date: Thu,  1 Oct 2009 12:33:20 +0200 (CEST)
X-Antivirus: AVG for E-mail 8.5.420 [270.13.115/2404]



Wiadomość z dnia: 01-10-2009 godzina: 12:33 <br /><br />
Imię i Nazwisko: <b>dfrfe</b><br />
Adres w Irlandi: <b>referf</b><br />
Nr telefonu: <b>efer</b><br />
E-mail: <b>erferf</b><br />
info: <b>erfer</b><br />
pytanie 1: <b>TAK</b><br />
pytanie 2: <b>TAK</b> </br />
pytanie 3: <b>TAK</b><br />
pytanie 4: <b>telefonicznie</b><br />
pytanie 5: <b>TAK</b><br />
w czym lezy problem ??

pozdrawiam
Awatar użytkownika
Hannibal
Moderator w st. spocz.
Posty: 1644
Rejestracja: 2004-06-08, 16:03
Lokalizacja: Łódź
Kontakt:

Re: [ROZW]Problem z kodowaniem

Post autor: Hannibal »

Zapewne zbyt długi temat. I nieszczęśliwy zbieg okoliczności.

Przy łamaniu lini php zawsze dodaje \r\n do tematu, ale inne linie są kończone na \r. Wejściowy postfix traktuje w tym wypadku \r jako zwykły znak i dodaje do maila.

Jeżeli taką wiadomość dostanie exim to to dodatkowe \r traktuje jako nową linie. W efekcie jest przerwa w nagłówkach co jest traktowane jako ich koniec.

Zobacz moje zignorowane zgłoszenie na bugtrackerze PHP: http://bugs.php.net:80/bug.php?id=47983.
[size=75]Hannibal@current@2.6.X[/size]
Awatar użytkownika
chevy
Użytkownik
Posty: 138
Rejestracja: 2005-02-06, 15:51
Lokalizacja: Tarnowskie Góry
Kontakt:

Re: [ROZW]Problem z kodowaniem

Post autor: chevy »

Hannibal pisze:Przy łamaniu lini php zawsze dodaje \r\n do tematu, ale inne linie są kończone na \r
W tym przypadku u mnie wiadomości były czytelne ale pozycja "OD: ...." dalej była pokręcona i nie czytlena.

Metoda prób i błędów dodałem do każdej linii tylko "\n" w efekcie nagłówki wyglądają jak poniżej:

Kod: Zaznacz cały

$subject = "Nowe hasło EnterBIT\n";
$headers =  "From: Chevy <chevy@horsemotor.com>\n";
$headers .= "Content-type: text/html; charset=utf-8\n"; 
$headers .= "MIME-Version: 1.0\n";
Proszę zwrócić uwagę na temat ($subject) na końcu linii dodano właśnie znak nowej linii "/n" i to jest ten moment na który naprowadził mnie Hannibal za co oczywiście punkcior!!! Bo bym w życiu nie wpadł żeby w temacie szukać problemu z czytaniem nagłówków.

pozdro
ODPOWIEDZ