mplyer źle odtwarza pliki

Jak dostosować Slackware w tych dziedzinach.

Moderatorzy: Moderatorzy, Administratorzy

chudy_dzik
Użytkownik
Posty: 32
Rejestracja: 2006-04-22, 07:57
Lokalizacja: mmz
Kontakt:

mplyer źle odtwarza pliki

Post autor: chudy_dzik »

Problem jest z plikami rm, rmvb, wmv, qt (możliwe, że jest ich więcej, ale te spotykam najczęściej i to na nich obraz się wysypuje), jeśli chodzi o pliki avi, mp4 itd wszystko gra pięknie.

mplyer: 1.0rc1-3.3.6
kodeki: all-20060611

a tak to wygląda
Obrazek
plik grany to jakieś newsy w formacie wmv. Tak samo psrwa wygląda z rmvb, rm, qt

Powiem odraz że zmiana wersji mplayera nie pomaga. Miałem kiedyś starszą wersję i było to same, problem znikał przy wyborze -vo sdl, ale wtedy włączał się wygaszacz ekranu więc było to rozwiązanie połowiczne... W mojej obecnej wersji mplayera zmiana wyjścia video nie zmienia nic i obraz nadal pozostaje taki jak na screenie.

Przeglądałem google, ale chyba nie umiem sformułować pytania, gdyż nic nie znalazłem :/

Spotkał się kiedyś ktoś z podobnym problemem i wie jak go rozwiązać?
Ostatnio zmieniony 2007-05-01, 12:41 przez chudy_dzik, łącznie zmieniany 1 raz.
http://daro.blogu.pl

Awatar użytkownika
qpalzm
Użytkownik
Posty: 172
Rejestracja: 2006-12-10, 18:07
Lokalizacja: Zabrze
Kontakt:

Re: mplyer źle odtwarza pliki

Post autor: qpalzm »

są może jakies logi?
czy tak samo dzieje sie pod innymi odtwarzaczami/w konsoli/z uprawnieniami roota ?
jak dla mnie to wina kodekow - sciagnij sobie jakies nowsze/starsze.
www.xfce.daxa.pl

banita
Użytkownik
Posty: 147
Rejestracja: 2006-12-15, 23:43

Re: mplyer źle odtwarza pliki

Post autor: banita »

mialem kiedys to samo, rozwiazanie pryniosla zmiana w configu. oto moj config

Kod: Zaznacz cały

# Write your default config options here!
subcp = cp1250
fs=no
subfont-text-scale = 4
#subfont-osd-scale = 4
#sub-bg-alpha=150	#przezroczyste OSD
#vop=expand=0:-60:0:0
#zoom=yes
vf=pp,expand=0:-140:0	#napisy pod filmem
font=/home/banita/.mplayer/arial.ttf
ao=alsa
na tym configu wszystko mi pieknie chodzi. podalem pelny cfg bo nie pamietam o ktory konkretnie wpis chodzi ale mozliwe ze o

Kod: Zaznacz cały

vf=pp,expand=0:-140:0
ps: to cfg jest dla mplayera konsolowego. tego z gui nie uzywam
Ostatnio zmieniony 2007-05-01, 12:58 przez banita, łącznie zmieniany 1 raz.

chudy_dzik
Użytkownik
Posty: 32
Rejestracja: 2006-04-22, 07:57
Lokalizacja: mmz
Kontakt:

Re: mplyer źle odtwarza pliki

Post autor: chudy_dzik »

sorki za brak log, na śmierć zapomniałem... :(

Kod: Zaznacz cały

MPlayer 1.0rc1-3.3.6 (C) 2000-2006 MPlayer Team
CPU: AMD Athlon(tm) 64 Processor 2800+ (Family: 15, Model: 4, Stepping: 8)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2
Cannot load bitmap font: /home/pawel/.mplayer/font/subfont.ttf

Playing prison_break_11-I_wtedy_byl_7.rmvb.
REAL file format detected.
Stream description: Audio Stream
Stream mimetype: audio/x-pn-realaudio
Stream description: Video Stream
Stream mimetype: video/x-pn-realvideo
Stream mimetype: logical-fileinfo
VIDEO:  [RV40]  624x352  24bpp  30.000 fps    0.0 kbps ( 0.0 kbyte/s)
Clip info:
 comment: 
SUB: Detected subtitle file format: microdvd
SUB: Read 577 subtitles.
SUB: Added subtitle file (1): ./prison_break_11-I_wtedy_byl_7.txt
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
Opening video filter: [expand w=0 h=-60 x=0 y=0]
Expand: 0 x -60, 0 ; 0, osd: 0, aspect: 0.000000, round: 1
==========================================================================
Opening video decoder: [realvid] RealVideo decoder
Selected video codec: [rv3040] vfm: realvid (Linux RealPlayer 10 RV30/40 decoder)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, s16le, 64.1 kbit/4.54% (ratio: 8010->176400)
Selected audio codec: [ffcook] afm: ffmpeg (FFmpeg COOK audio decoder)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 624 x 352 (preferred colorspace: Planar I420)
VDec: using Planar I420 as output csp (no 0)
Movie-Aspect is 1.77:1 - prescaling to correct movie aspect.
VO: [xv] 624x412 => 624x412 Planar I420  [fs] [zoom]
A:   3.3 V:   3.3 A-V:  0.020 ct:  0.013  78/ 78 13%  1%  1.6% 0 0 [J
A:   3.3 V:   3.3 A-V: -0.001 ct:  0.013  79/ 79 13%  1%  1.6% 0 0 [J
A:   3.4 V:   3.4 A-V:  0.021 ct:  0.014  80/ 80 13%  1%  1.6% 0 0 [J
A:   3.4 V:   3.4 A-V:  0.001 ct:  0.014  81/ 81 13%  1%  1.6% 0 0 [J
A:   3.5 V:   3.5 A-V:  0.002 ct:  0.013  82/ 82 13%  1%  1.6% 0 0 [J
Exiting... (Quit)
jak już mówiłem na każdym wyjściu zaproponowanym przez mplayer -vo help, obraz wygląda tak samo.

odnośnie innych playerów to nie wiem, gdyż nie mam teraz możliwości sprawdzić :/
ale jestem już przyzwyczajony do mplayera ;)


mialem kiedys to samo, rozwiazanie pryniosla zmiana w configu. oto moj config

Kod: Zaznacz cały

# Write your default config options here!
subcp = cp1250
fs=no
subfont-text-scale = 4
#subfont-osd-scale = 4
#sub-bg-alpha=150    #przezroczyste OSD
#vop=expand=0:-60:0:0
#zoom=yes
vf=pp,expand=0:-140:0    #napisy pod filmem
font=/home/banita/.mplayer/arial.ttf
ao=alsa
na tym configu wszystko mi pieknie chodzi. podalem pelny cfg bo nie pamietam o ktory konkretnie wpis chodzi ale mozliwe ze o
Kod:

Kod: Zaznacz cały

vf=pp,expand=0:-140:0

ps: to cfg jest dla mplayera konsolowego. tego z gui nie uzywam
Pomogło :D
tak jak napisałeś chodzi o opcję:

Kod: Zaznacz cały

vf=pp,expand=0:-140:0
Teraz już wszystko działa tak jak potrzeba, nie do końca wiem jeszcze co ta opcja robi bo opisu z manuala nie do końca rozumiem, ale grunt że nareszcie mam dobry obraz :D
Ostatnio zmieniony 2007-05-01, 13:12 przez chudy_dzik, łącznie zmieniany 1 raz.
http://daro.blogu.pl

banita
Użytkownik
Posty: 147
Rejestracja: 2006-12-15, 23:43

Re: mplyer źle odtwarza pliki

Post autor: banita »

chodzi o to zeby napisy wyswietlaly sie pod filmem a nie na samym filnie. w przypadku rmvb jak napisy maja pokazywac sie na filmie a nie pod nim to sie tak obraz psuje

chudy_dzik
Użytkownik
Posty: 32
Rejestracja: 2006-04-22, 07:57
Lokalizacja: mmz
Kontakt:

Re: mplyer źle odtwarza pliki

Post autor: chudy_dzik »

Jeśli dobrze zrozumiałem...
po dodaniu tej opcji obraz jest naprawiony, a napisy nadal pod filmem.

A czy do ustawienia napisów pod filmem nie służyła opcja:

Kod: Zaznacz cały

vop=expand=0:-60:0:0
czy już wszystko mi się pomyliło?
http://daro.blogu.pl

banita
Użytkownik
Posty: 147
Rejestracja: 2006-12-15, 23:43

Re: mplyer źle odtwarza pliki

Post autor: banita »

ta opcja tez umieszcza napisy pod filmem ale obraz przy niektorych formatach nadal pozostaje znieksztalcony, nie wiem dlaczego sie tak dziejej...jak widzisz mam ta opcje zahaszowana.
zauwazylem tez ze opcja

Kod: Zaznacz cały

vf=pp,expand=0:-140:0
powoduje lepsze rozmieszczenie obrazu na pelnym ekranie, a napisy sa pod obrazem co ulatwia ogladanie i nie zniekszatalca samego obrazu

chudy_dzik
Użytkownik
Posty: 32
Rejestracja: 2006-04-22, 07:57
Lokalizacja: mmz
Kontakt:

Re: mplyer źle odtwarza pliki

Post autor: chudy_dzik »

thx za pomoc i wyjaśnienie :)

Sam bym chyba w życiu na to nie wpadł, config byłby ostatnim miejscem do którego bym zajrzał ;)

Kod: Zaznacz cały

vf=pp,expand=0:-140:0
no fakt nie zwróciłem uwagi, ale obraz rzeczywiście trochę lepiej leży (tzn u mnie jest na środku a napisy są jakby wyrównane do dołu), a z opcją

Kod: Zaznacz cały

vop=expand=0:-60:0:0
obraz przesunięty jest ciut do góry a napisy pozostają na swoim miejscu...
http://daro.blogu.pl

Awatar użytkownika
Nightwalker
Użytkownik
Posty: 545
Rejestracja: 2006-01-02, 01:23
Lokalizacja: Bytom
Kontakt:

Re: mplyer źle odtwarza pliki

Post autor: Nightwalker »

Najprościej nie ściągać plików rmvb... przecież tego się oglądać nie da...
Na górze fiołki, na dole las, all your base are belong to us

[ [url=http://forum.slackware.pl/viewtopic.php?p=142666]Darmowy shell[/url] ]

Javaanse

Re: mplyer źle odtwarza pliki

Post autor: Javaanse »

Ale zajmują mniej m-sca

chudy_dzik
Użytkownik
Posty: 32
Rejestracja: 2006-04-22, 07:57
Lokalizacja: mmz
Kontakt:

Re: mplyer źle odtwarza pliki

Post autor: chudy_dzik »

Najprościej nie ściągać plików rmvb... przecież tego się oglądać nie da...
ale to omijanie problemu :P i tak długo tak robiłem ;] ale czasem to wkurza, tym bardziej że na Linuksie nie działa, a na Windowsie śmiga, było to co najmniej motywujące ;)
http://daro.blogu.pl

Awatar użytkownika
Nightwalker
Użytkownik
Posty: 545
Rejestracja: 2006-01-02, 01:23
Lokalizacja: Bytom
Kontakt:

Re: mplyer źle odtwarza pliki

Post autor: Nightwalker »

Javaanse pisze:Ale zajmują mniej m-sca
To rzeczywiście żelazny argumenty, przy aktualnych cenach dysków twardych i nośników DVD-R...
Ostatnio zmieniony 2007-05-01, 20:39 przez Nightwalker, łącznie zmieniany 1 raz.
Na górze fiołki, na dole las, all your base are belong to us

[ [url=http://forum.slackware.pl/viewtopic.php?p=142666]Darmowy shell[/url] ]

Trurl
Użytkownik
Posty: 159
Rejestracja: 2006-08-02, 22:31
Lokalizacja: LinuxWeb

Re: mplyer źle odtwarza pliki

Post autor: Trurl »

chudy_dzik pisze: mplyer: 1.0rc1-3.3.6
kodeki: all-20060611
Czy w końcu ktoś mi przyzna rację, że mplayer jest do dupy, czy musi się pojawić więcej uzytkowników, których mplayer zawiódł?
chudy_dzik pisze: Spotkał się kiedyś ktoś z podobnym problemem i wie jak go rozwiązać?
Zainstaluj sobie Ubuntu, do tego program xine-ui, do tego libxine-extracodecs oraz w32codecs. Bedzie działało.

No chyba, że dla Ciebie wazniejsze jest używanie Slackware niż działanie komputera.

Awatar użytkownika
Nightwalker
Użytkownik
Posty: 545
Rejestracja: 2006-01-02, 01:23
Lokalizacja: Bytom
Kontakt:

Re: mplyer źle odtwarza pliki

Post autor: Nightwalker »

Trurl pisze:Czy w końcu ktoś mi przyzna rację, że mplayer jest do dupy, czy musi się pojawić więcej uzytkowników, których mplayer zawiódł?
Cóż, jak prawie każdy program dla Linuksa (i nie tylko), tak i MPlayer nie jest doskonały, jedyna alternatywa to chyba VLC, ale on znowu sobie nie radzi z S/PDiF Passtrough :( Xine-ui ma tak toporny interfejs i pogmatwana konfiguracje, że zniechęciłem się od pierwszego użytkowania.

Powtórze to, co kiedyś pisałem: multimedia pod Linuksem jeszcze kuleje.

Druga sprawa, zmiana Slackware na Ubuntu to dobre rozwiązanie, jeśli mamy mało czasu i chcemy żeby po prostu działało. Zrobiłem tak w styczniu, byłem pod wrażeniem tego, jak ten system jest spójny i dopracowany, niestety ma on też spory minus, jest ociężały przez co mało wydajny.

Oopss, ale się OT zrobił :roll: Proszę o przeniesienie tego do Slackware Advocacy - dzięki.
Ostatnio zmieniony 2007-05-02, 12:50 przez Nightwalker, łącznie zmieniany 2 razy.
Na górze fiołki, na dole las, all your base are belong to us

[ [url=http://forum.slackware.pl/viewtopic.php?p=142666]Darmowy shell[/url] ]

Trurl
Użytkownik
Posty: 159
Rejestracja: 2006-08-02, 22:31
Lokalizacja: LinuxWeb

Re: mplyer źle odtwarza pliki

Post autor: Trurl »

Nightwalker pisze:
Trurl pisze:Czy w końcu ktoś mi przyzna rację, że mplayer jest do dupy, czy musi się pojawić więcej uzytkowników, których mplayer zawiódł?
Cóż, jak prawie każdy program dla Linuksa (i nie tylko), tak i MPlayer nie jest doskonały, jedyna alternatywa to chyba VLC, ale on znowu sobie nie radzi z S/PDiF Passtrough :( Xine-ui ma tak toporny interfejs i pogmatwana konfiguracje, że zniechęciłem się od pierwszego użytkowania.
Xine nie ma topornego interfejsu. Gui (dostepne pod klawiszem G) jest bardzo ładne. Konfiguracja? jaka konfiguracja? "apt-get install xine-ui libxine-extracodecs w32codecs libdvdcss2" i wszystko działa, w ogóle o żadnej konfiguracji nawet przez moment nie pomyślałem. Co do mplayera- tego szajsu to się w ogóle nie da używać w sensowny sposób. Zrobili już możliwość zmiany napisów bez restartowania całego filmu? Nie? Tak myślałem.
Nightwalker pisze: Druga sprawa, zmiana Slackware na Ubuntu to dobre rozwiązanie, jeśli mamy mało czasu i chcemy żeby po prostu działało. Zrobiłem tak w styczniu, byłem pod wrażeniem tego, jak ten system jest spójny i dopracowany, niestety ma on też spory minus, jest ociężały przez co mało wydajny.
Ja mam komputer sprzed 4 lat (Athlon 2000+, 1GB pamięci) i u mnie ubuntu działa szybciej niż jakikolwiek inny system operacyjny.
Nightwalker pisze: Oopss, ale się OT zrobił :roll: Proszę o przeniesienie tego do Slackware Advocacy - dzięki.
Ja proszę, żeby moderatorzy po prostu nie przeszkadzali nam w dyskusji. Najlepiej, jak nie będą w ogóle dotykac tego wątku, gdyż moderatorzy tutaj czego się dotkną to spieprzą.

ODPOWIEDZ