Strona 1 z 1

Dzwięk

: 2008-06-06, 20:40
autor: kolert83
Witam

Od kilku dni walcze z kartą dźwiękową (zintegrowana VIA vt8233a) aby mieć sprzętowe mixowanie , i jak narazie nie moge sobie z tym poradzić . Jak gra mi audacious , to innego dzwięku nie wydobęde. Szukałem juz na forum http://forum.slackware.pl/viewtopic.php ... t=dzwi%EAk , nie pomogło ,googlowałem i tez nie bardzo pomogło. Kombinowałem z ArchWiki też nic. Jak słucham audaciousa i chce mplayera puscić to dostaje taki komunikat:

Kod: Zaznacz cały

[AO_ALSA] alsa-lib: pcm_hw.c:1242:(snd_pcm_hw_open) open /dev/snd/pcmC0D2p failed: No such file or directory
[AO_ALSA] Playback open error: No such file or directory
Could not open/initialize audio device -> no sound.

Ma ktoś może pomysł na rozwiązanie tego problemu ?

[ Komentarz dodany przez: largo3: 2008-06-06, 22:21 ]
Używaj Code!

Re: Dzwięk

: 2008-06-06, 20:45
autor: wojtekor
kolert83 pisze: [AO_ALSA] alsa-lib: pcm_hw.c:1242:(snd_pcm_hw_open) open /dev/snd/pcmC0D2p failed: No such file or directory
a w ustwieniach dziwku mplayera przykladowa kombinowales zeby pcm czy alsa zmienic na jack czy co tam jeszcze jest na liscie tego menu?

Re: Dzwięk

: 2008-06-06, 21:15
autor: kolert83
Próbowałem juz różnych kombinacji na mplayerze ,ale nic nie pomaga . Jak słucham Audaciousa to blokuje dostęp do urządzenia i koniec. Jedno gra , drugie juz nie zagra .

Re: Dzwięk

: 2008-06-06, 22:43
autor: wojtekor
kolert83 pisze:Jak słucham Audaciousa to blokuje dostęp do urządzenia i koniec.
a w innej kombinacji? ze np najpierw zagra audacious a dopiero potem mplayer? albo np mplayer i xmms? jesli te dwa zagraja razem to potem zobacz jak zachowuje sie xmms z audaciousem...
bo wg. mnie to w konfiguracji audaciousa musisz pogrzebac bo on blokuje urzadzenie... a poza tym wylaczylbym dzwieki systemowe bo np KDE tez na stale blokuje dla siebie urzedzenia dzwieku i wtedy np w niektorych grach czy programach tez nie ma dzwieku.

Re: Dzwięk

: 2008-06-07, 13:59
autor: Alistra
Pokombinuj ze sterami - na początku na defaultowych też miałem jeden kanał outputu, ale jak installnałem stery nowsze to już wszystko śmiga :>

Re: Dzwięk

: 2008-06-07, 15:38
autor: kolert83
Próbowałem z Alsaconf i dostaje taki komunikat :

Kod: Zaznacz cały

NO supported PnP or PCI card found.
Dodatkowo, mam niezaładowane moduły , alsa-lib, alsa-oss, alsa-utils i nijak nie moge ich załadować , a zaktualizowałem je do nowszej wersji .

[ Dodano: 2008-06-16, 17:46 ]
Wypróbowałem już wiele sposobów i dalej nic , nie potrafie uruchomić miksowania dzwięku :sad: . Poradziłem sobie z alsaconf (wykrywa mi karte). Ale reszta za nic nie ruszy , jak ma audaciousa włączonego to mplayer sie pluje o brak dostępu , albo na odwrót. Próbowałem z asoundrc , /etc/sound.conf i nic nie pomaga , przejrzałem całe forum i żadna metoda z forum nie pomogła. Odpowiednie moduły mam załadowane . Może ktoś ma jeszcze pomysł ?