[Rozw.] Pliki 3gp - brak mp4v i samr

Jak dostosować Slackware w tych dziedzinach.

Moderatorzy: Moderatorzy, Administratorzy

addos
Użytkownik
Posty: 158
Rejestracja: 2007-09-17, 13:50

[Rozw.] Pliki 3gp - brak mp4v i samr

Post autor: addos »

Mam telefon Samsung GT-i5700 Galaxy Spice i nie mogę sobie poradzić z poprawnym odtwarzaniem filmików przez niego nakręconych.
Próbowałem to odtwarzać wszystkim co jest wbudowane w Slacka 13.1 oraz dodatkowo SMPlayer 0.6.9 oraz VLC 1.1.0

Gdy robię to przez SMPlayera to sytuacja wygląda tak:
1. Obraz jest rozciągnięty w poziomie prawie na cały ekran (tak gdzieś ok. na 80% całego monitora czyli u mnie 1680x1050)
W pionie jest OK ale w poziomie powinno być 352 pikseli a nie jakieś 1300-1400.
Jeżeli ustawię współczynnik proporcji na sztywno na 4:3 w opcjach SMPlayera to zmienia się tylko sam obszar filmiku na poprawnie czyli 352 ale samo okno pozostaje rozciągnięte na 80% monitora a po bokach mam wielkie czarne pasy

2. Dźwięku w ogóle brak.

3. Info spod SMPlayera na temat odtwarzanego filmiku:

Kod: Zaznacz cały

video-2010-06-18-13-39-03.3gp

Ogólne
Plik   /mnt/Magazyn/Filmy/video-2010-06-18-13-39-03.3gp
Rozmiar   868 KB (0 MB)
Długość   00:00:20
Demuxer   lavfpref

Wideo
Rozdzielczość   352 x 288
Współczynnik proporcji   4.8889
Format   MP4V
Bitrate   338 kbps
Ramek na sekundę   15.000
Użyty dekoder   ffodivx

Początkowy strumień audio
Format   samr
Bitrate   5 kbps
Tempo   8000 Hz
Kanały   1
Użyty dekoder 
4. Gdy robię to przez VLC to zgłasza on coś takiego:

Kod: Zaznacz cały

Moduł dekodera nie nadaje się:
VLC nie wspiera formatu audio lub wideo "mp4v". Niestety nie ma sposobu, aby to naprawić.
Moduł dekodera nie nadaje się:
VLC nie wspiera formatu audio lub wideo "samr". Niestety nie ma sposobu, aby to naprawić.
Da się to odtwarzać normalnie na Linuksie?
Ostatnio zmieniony 2010-06-28, 20:45 przez addos, łącznie zmieniany 1 raz.
Awatar użytkownika
dienet
Moderator
Posty: 2106
Rejestracja: 2007-07-24, 18:58
Lokalizacja: Racibórz/Rybnik
Kontakt:

Re: Pliki 3gp - brak mp4v i samr

Post autor: dienet »

A na czystym mplayerze odpalałeś? Może daj jakiś sample co sprawdzę u siebie.
Pozdr0
dienet
[img]http://i164.photobucket.com/albums/u19/slawek15/kotekeo0lq3.jpg[/img]
jacol
Przyjaciel Forum
Posty: 680
Rejestracja: 2004-06-12, 17:34

Re: Pliki 3gp - brak mp4v i samr

Post autor: jacol »

Witam!
Rozumiem że slack 32 bity. Czy masz zainstalowane kodeki windosowe dla mplayera? Można jeszcze spróbować skompilować najnowszą wersję mplayera. Jest z 30 maja 2010 roku... lub nowszej. Mplayer
jest uaktualniany z tego co sobie przypominam codziennie.Pozdrawiam jacol
addos
Użytkownik
Posty: 158
Rejestracja: 2007-09-17, 13:50

Re: Pliki 3gp - brak mp4v i samr

Post autor: addos »

Poprawka z mojej strony: Dragon Player odtwarza sam obraz poprawnie: proporcje są OK.

Czysty MPlayer w konsoli daje takie coś:

Kod: Zaznacz cały

mplayer video-2010-06-18-13-39-03.3gp 
MPlayer 20100218-4.4.3 (C) 2000-2010 MPlayer Team

Playing video-2010-06-18-13-39-03.3gp.
libavformat file format detected.
[mpeg4 @ 0x9052d10]warning: first frame is no keyframe
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x9051870]max_analyze_duration reached
[lavf] Video stream found, -vid 0
[lavf] Audio stream found, -aid 1
VIDEO:  [MP4V]  352x288  24bpp  15.000 fps  338.0 kbps (41.3 kbyte/s)
Clip info:
 major_brand: 3gp4
 minor_version: 768
 compatible_brands: 3gp43gp6
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
Cannot find codec 'libopencore_amrnb' in libavcodec...
ADecoder init failed :(
ADecoder init failed :(
Cannot find codec for audio format 0x726D6173.
Audio: no sound
Starting playback...
Movie-Aspect is 4.89:1 - prescaling to correct movie aspect.
VO: [xv] 352x288 => 1408x288 Planar YV12 
[mpeg4 @ 0x8a1c980]warning: first frame is no keyframe
V:   7.5   0/  0  2%  0%  0.0% 0 0 
Exiting... (Quit)

No i wszystko jasne :D
Coś mi się pokręciło bo myślałem, że mam zainstalowanego najnowszego MPlayera (2010-05-30) a był domyślny (2010-02-18).
Po wgraniu najnowszego wszystko gra.

Mój błąd ale mimo wszystko dziękuję
ODPOWIEDZ