Filmy 1080p - brak płynności (sprzęt OK)

Jak dostosować Slackware w tych dziedzinach.

Moderatorzy: Moderatorzy, Administratorzy

addos
Użytkownik
Posty: 158
Rejestracja: 2007-09-17, 13:50

Filmy 1080p - brak płynności (sprzęt OK)

Post autor: addos »

Nie rozumiem dlaczego filmy 720p idą płynnie ale 1080p już nie, tzn. czasami przez kilkanaście sekund potrafi iść w miarę płynnie ale później znowu szarpie... i tak w kółko.

Sprzęt dosyć mocny:
CPU Core 2 Duo E8400 3GHz
RAM 2 GB
GF 9600GT DDR3
HDD 1TB 7200obr/min 32MB cache
Dla uściślenia chodzi mi o prawdziwe BluRay a nie AVI czy MKV.
Odtwarzacz to SMPlayer 0.6.9
Sterowniki do GF w wersji 256.33 ale nie pamiętam dokładnie co jest po "33"..... jak to sprawdzić?
Próbowałem w opcjach SMPlayera zmieniać xv / gl / vdpau ale albo nie ma różnicy (xv, gl) albo brak obrazu (vdpau).

Jakieś pomysły?
Awatar użytkownika
marco70
Moderator
Posty: 1110
Rejestracja: 2006-10-26, 19:03
Lokalizacja: K...l
Kontakt:

Re: Filmy 1080p - brak płynności (sprzęt OK)

Post autor: marco70 »

Jaka wersja MPlayer ? Sprawdź jak sobie radzi MPlayer
Miałem podobny objaw aktualizacja do tej wersji pomogła MPlayer SVN-r31826 20100726
slackware64-current
i5-9600K CPU @ 3.70GHz
Awatar użytkownika
dienet
Moderator
Posty: 2106
Rejestracja: 2007-07-24, 18:58
Lokalizacja: Racibórz/Rybnik
Kontakt:

Re: Filmy 1080p - brak płynności (sprzęt OK)

Post autor: dienet »

addos, może jeszcze cache większy?
Pozdr0
dienet
[img]http://i164.photobucket.com/albums/u19/slawek15/kotekeo0lq3.jpg[/img]
addos
Użytkownik
Posty: 158
Rejestracja: 2007-09-17, 13:50

Re: Filmy 1080p - brak płynności (sprzęt OK)

Post autor: addos »

MPlayer SVN-r31276-4.4.4 (C) 2000-2010 MPlayer Team
154 audio & 339 video codecs
Jeżeli chodzi o wersję wyższą to nigdzie jej nie widzę do pobrania w paczce a kompilacja tego programu to mi się nigdy nie udaje, więc odpuszczę sobie i poczekam.

Co do cache to pisze, że będą problemy z DVD przy przewijaniu oraz przy menu dla płyt DVD... więc chyba zrezygnuję z tego.

Natomiast sporą poprawę dało ustawienie opcji:
Ustawienia - Wydajność - Filtr loop - Pomiń tylko przy wideo DVD
Nie jest to może całkowicie płynne ale już do zaakceptowania.

Nie wiem czy coś tu jeszcze może pomóc...
Awatar użytkownika
dienet
Moderator
Posty: 2106
Rejestracja: 2007-07-24, 18:58
Lokalizacja: Racibórz/Rybnik
Kontakt:

Re: Filmy 1080p - brak płynności (sprzęt OK)

Post autor: dienet »

http://www.mplayerhq.hu/design7/news.html i news z 2009-02-20, Friday :: Video Acceleration and You
Pozdr0
dienet
[img]http://i164.photobucket.com/albums/u19/slawek15/kotekeo0lq3.jpg[/img]
jacol
Przyjaciel Forum
Posty: 680
Rejestracja: 2004-06-12, 17:34

Re: Filmy 1080p - brak płynności (sprzęt OK)

Post autor: jacol »

Witam.
Pytanko: Czy mplayer pobierany z svn obsługuje wielowątkowość? Bo jak nie to masz odpowiedź czemu tak się dzieje i możesz mieć 10 rdzeni to i tak nic nie pomoże . Może mplayerxp z obsługą wielowątkowości da to o co czego brakuje zwykłemu? No i jeszcze jedno rozumiem że to slackware 64 bity! Pozdrawiam jacol
addos
Użytkownik
Posty: 158
Rejestracja: 2007-09-17, 13:50

Re: Filmy 1080p - brak płynności (sprzęt OK)

Post autor: addos »

Tak jak wcześniej wspomniałem, nie mam MPlayera z SVN tylko gotowego z paczki.
Slackware 32-bit
We wcześniejszym poście napisałem co mi prawie w 100% pomogło. Jest prawie idealnie - mam na myśli płynność.
Niestety obciąża CPU dość mocno zamiast GPU. No i nie umiem sobie poradzić z VDPAU... nie wiem może jestem za cienki...
jacol
Przyjaciel Forum
Posty: 680
Rejestracja: 2004-06-12, 17:34

Re: Filmy 1080p - brak płynności (sprzęt OK)

Post autor: jacol »

Witam.
MPlayera kompiluje się dla własnego procesora wtedy jest optymalny. Ja sobie skompilowałem mplayera 1.0rc3 dla swojego procesora biega bez zarzutu...Oczywiście dotyczy to plików dobrych. Procesor kolegi ma 64 bity (tak znalazłem w necie) więc czemu nie ma kolega zainstalowanego slacka 64 bity to jednak daje dopalenie około 10% a to dużo. Dla wine? Pozdrawiam jacol
Brodi81
Użytkownik
Posty: 10
Rejestracja: 2009-11-15, 20:08

Re: Filmy 1080p - brak płynności (sprzęt OK)

Post autor: Brodi81 »

Co pokazuje top podczas odtwarzania 720p i 1080p ?
pigmaster
Użytkownik
Posty: 13
Rejestracja: 2006-04-22, 18:26

Re: Filmy 1080p - brak płynności (sprzęt OK)

Post autor: pigmaster »

A próbowałeś z direct rendering w opcjach wideo albo włączyć wielowątkowość dla h.264
ODPOWIEDZ