vlc i brak wsparcia dla mp4v - proszę o pomoc.

Jak dostosować Slackware w tych dziedzinach.

Moderatorzy: Moderatorzy, Administratorzy

adamek30
Użytkownik
Posty: 14
Rejestracja: 2011-11-24, 20:31

vlc i brak wsparcia dla mp4v - proszę o pomoc.

Post autor: adamek30 » 2014-01-15, 13:36

witam wszystkich. Zainstalowałem odtwarzacz vlc i pojawił się problem.Dźwięk jest ale nie ma obrazu.Gdy chcę uruchomić jakiś film to dostaje informację

Kod: Zaznacz cały

 "VLC nie wspiera formatu audio lub wideo "mp4v". Niestety nie ma na to sposobu naprawy."
Dźwięk filmu jest a obrazu brak. Doinstalowałem najnowsze kodeki, fmppeg i to co poptrzebował do działania ale nic to nie dało.Reinstalowałem, a to z paczki, a to ze slackbuidów i cały czas ten sam błąd.Nie wiecie co moze mu jeszcze brakować? może jakieś ustawienia video nie ten tego itp? Mplayer działa, xine też.
Uruchomiłem program z konsoli i dostałem takie informacje

Kod: Zaznacz cały

 VLC media player 2.1.1 Rincewind (revision 2.1.0-207-g89c9520)
[0x98a3b50] main libvlc warning: cannot load module `/usr/lib/vlc/plugins/access/libaccess_avio_plugin.so' (libx264.so.138: nie można otworzyć pliku obiektu dzielonego: Nie ma takiego pliku ani katalogu)
[0x98a3b50] main libvlc warning: cannot load module `/usr/lib/vlc/plugins/codec/libavcodec_plugin.so' (libx264.so.138: nie można otworzyć pliku obiektu dzielonego: Nie ma takiego pliku ani katalogu)
[0x98a3b50] main libvlc warning: cannot load module `/usr/lib/vlc/plugins/demux/libavformat_plugin.so' (libx264.so.138: nie można otworzyć pliku obiektu dzielonego: Nie ma takiego pliku ani katalogu):
doinstalowałem te brakujące niby biblioteki ale nic to nie dało, i dalej te same komunikaty.Wie ktoś jak zmusić vlc do działania? Porady i uwagi (bo może ja coś robie nie tak) będą mile widziane.W sumie 1-szy raz stykam się z tym odtwarzaczem, zachęcony bo ponoć znakomity i zwłaszcza do strumieni i sopcastów niezbędny.Pozdrawiam i proszę o pomoc.
System to Slackware 14.1 + lxde.

Awatar użytkownika
elesmod
Użytkownik
Posty: 47
Rejestracja: 2012-08-30, 13:00

Re: vlc i brak wsparcia dla mp4v - proszę o pomoc.

Post autor: elesmod » 2014-01-15, 21:40

Spróbuj zainstalować paczkę zrobioną przez AlienBob-a.

Nie podałeś architektury, dlatego nie podam Ci bezpośredniego linka; musisz sam sobie wejść do katalogu pkg lub pkg64.

http://taper.alienbase.nl/mirrors/peopl ... uilds/vlc/

adamek30
Użytkownik
Posty: 14
Rejestracja: 2011-11-24, 20:31

Re: vlc i brak wsparcia dla mp4v - proszę o pomoc.

Post autor: adamek30 » 2014-01-15, 22:18

Dzięki za pomoc.Zainstalowanie tej paczki z podanej przez Ciebie strony pomogło i wszystko teraz działa.Sopcast-player przy okazji też się naprawił tak jak przypuszczałem.A więc problem rozwiązany!

ODPOWIEDZ