Instalacja dvd::rip - problem przy GTK-Perl

Jak dostosować Slackware w tych dziedzinach.

Moderatorzy: Moderatorzy, Administratorzy

Awatar użytkownika
Minder
Użytkownik
Posty: 540
Rejestracja: 2004-08-08, 15:12
Lokalizacja: Bielsko-Biała
Kontakt:

Instalacja dvd::rip - problem przy GTK-Perl

Post autor: Minder »

Ma ktoś praktyczną wiedzę jak przymusić dvd::rip do współpracy ze Slackiem 10?
Ja utknąłem na instalowaniu GTK-Perl. Ni cholery nie wiem jak to ugryźć. Na linuxpackages tego nie ma (albo swaret nie widzi).
Ewentualnie polećcie zestaw do ripowania/kompresowania DVD, który da efekty nie gorsze niż wyśrubowany GordianKnot. "Tabela zamienników" niewiele mi mówi, wolałbym opinie żywych ludzi na temat użytkowania :)
[url=http://Polish-30642126344.SpamPoison.com][img]http://pics2.inxhost.com/images/sticker.gif[/img][/url] [url=http://www.bykom-stop.avx.pl][img]http://www.bykom-stop.avx.pl/bannery/80x15.png[/img][/url]

tadziu
Użytkownik
Posty: 325
Rejestracja: 2004-05-23, 18:21
Lokalizacja: Gdańsk
Kontakt:

Re: Instalacja dvd::rip - problem przy GTK-Perl

Post autor: tadziu »

Uruchom jako root 'cpan' i wpisz 'install Gtk'. Powinno pomoc, bo wczoraj wlasnie odpalilem dzieki temu dvd::rip ;)
Linux registered user #325402

Awatar użytkownika
Minder
Użytkownik
Posty: 540
Rejestracja: 2004-08-08, 15:12
Lokalizacja: Bielsko-Biała
Kontakt:

Re: Instalacja dvd::rip - problem przy GTK-Perl

Post autor: Minder »

Can't exec "gnome-config": Nie ma takiego pliku ani katalogu at Makefile.PL line 141.
Can't exec "libglade-config": Nie ma takiego pliku ani katalogu at Makefile.PL line 141.
Submodule gnome is needed to build applets but it appears
it's misdetected or not selected for compilation.
Available modules: gtk gtkglarea gdkimlib gdkpixbuf gtkhtml gtkxmhtml gnome glade applets gnomeprint.
Czy to znaczy, że spod cpan mam próbować zainstalować moduł 'gnome'?

edit:
Ech te wielkie literki :wink:
Mam niestety poważniejszy problem. Chyba coś sknociłem podczas konfiguracji cpan i teraz faza "make install" (kompilacja bez problemów) wywala mi taki oto błąd:
(...)
cc: Gtk/GdkTypes.o: Nie ma takiego pliku ani katalogu
cc: Gtk/GtkTypes.o: Nie ma takiego pliku ani katalogu
cc: Gtk/MiscTypes.o: Nie ma takiego pliku ani katalogu
cc: Gtk/Derived.o: Nie ma takiego pliku ani katalogu
make: *** [blib/arch/auto/Gtk/Gtk.so] Błąd 1
/usr/bin/make -- NOT OK
Running make test
Can't test without successful make
Running make install
make had returned bad status, install seems impossible
Może jakaś dobra dusza podpowie jak moge poprawić ten błąd?

[ Dodano: 2004-08-27, 11:18 ]
Żeby dodać sprawie pikanterii: niektóre moduły instalują się bez zająknięcia
Writing /usr/lib/perl5/5.8.5/i486-linux/auto/Time/HiRes/.packlist
Appending installation info to /usr/lib/perl5/5.8.5/i486-linux/perllocal.pod
/usr/bin/make install -- OK
Inne (jak wspomniałem wyżej) mają jakieś wonty. Od czego to może zależeć? Już wiem, że to razcej nie błąd podczas konfiguracji (ale lokalizacja pliku .conf się przyda).
[url=http://Polish-30642126344.SpamPoison.com][img]http://pics2.inxhost.com/images/sticker.gif[/img][/url] [url=http://www.bykom-stop.avx.pl][img]http://www.bykom-stop.avx.pl/bannery/80x15.png[/img][/url]

tadziu
Użytkownik
Posty: 325
Rejestracja: 2004-05-23, 18:21
Lokalizacja: Gdańsk
Kontakt:

Re: Instalacja dvd::rip - problem przy GTK-Perl

Post autor: tadziu »

Aha, ja zaisntalowalem jeszcze przedtem przez cpan Glade::Two::Gtk, tylko nie wiedzialem zbytnio czy to potrzebne czy nie, wiec dlatego nie pisalem :P
Czyli po:
install Glade::Two::Gtk
install Gtk
powinno byc ok ;)
Linux registered user #325402

Awatar użytkownika
Minder
Użytkownik
Posty: 540
Rejestracja: 2004-08-08, 15:12
Lokalizacja: Bielsko-Biała
Kontakt:

Re: Instalacja dvd::rip - problem przy GTK-Perl

Post autor: Minder »

No niestety :(
Gldae::Two::Gtk i s up to date
i efekt install Gtk nadal taki sam
CPAN.pm: Going to build M/ML/MLEHMANN/Gtk-Perl-0.7009.tar.gz

Can't exec "gnome-config": Nie ma takiego pliku ani katalogu at Makefile.PL line 141.
Can't exec "gnome-config": Nie ma takiego pliku ani katalogu at Makefile.PL line 141.
Can't exec "gnome-config": Nie ma takiego pliku ani katalogu at Makefile.PL line 141.
Can't exec "libglade-config": Nie ma takiego pliku ani katalogu at Makefile.PL line 141.
Submodule gnome is needed to build applets but it appears
it's misdetected or not selected for compilation.
Available modules: gtk gtkglarea gdkimlib gdkpixbuf gtkhtml gtkxmhtml gnome glade applets gnomeprint.

You can disable the inclusion of a module using --without-pkgname.
If a package is misdetected and you still want it to compile
use --with-pkgname-force.
To disable autodetection of modules use --without-guessing.
Running make test
Make had some problems, maybe interrupted? Won't test
Running make install
Make had some problems, maybe interrupted? Won't install
:cry:

Nie wiem czy to ma jakieś znaczenie, ale używam Dropline-Gnome.
Łapki mi już odpadają, bo przeszukuję "górę i dół" żeby dependencje rozwiązać i ciągle bez efektów :(

Jak poza tym mam zapodać opcję --with-gnome-force? cpan zaczyna szukać takiego pakietu zamiast zapodać argument. Nie bardzo wiem co gdzie pozmieniać...
[url=http://Polish-30642126344.SpamPoison.com][img]http://pics2.inxhost.com/images/sticker.gif[/img][/url] [url=http://www.bykom-stop.avx.pl][img]http://www.bykom-stop.avx.pl/bannery/80x15.png[/img][/url]

tadziu
Użytkownik
Posty: 325
Rejestracja: 2004-05-23, 18:21
Lokalizacja: Gdańsk
Kontakt:

Re: Instalacja dvd::rip - problem przy GTK-Perl

Post autor: tadziu »

Moze sproboj w cpan zrobic 'clean', ale nie wiem czy to cos pomoze... U mnie wystarczylo tego Glade::Two::Gtk zainstalowac i Gtk juz poszlo normalnie
Linux registered user #325402

Awatar użytkownika
Minder
Użytkownik
Posty: 540
Rejestracja: 2004-08-08, 15:12
Lokalizacja: Bielsko-Biała
Kontakt:

Re: Instalacja dvd::rip - problem przy GTK-Perl

Post autor: Minder »

Pierwszą rzeczą, którą robię już od dłuższego czasu jest odinstalowanie Dropline. W praktyce sprowadza się to do reinstalacji systemu (po moich eksperymentach już tylko to mi zostało) ;/ Jeśli na świeżym systemie, bez Dropline, też nie będzie działać, to wtedy zacznę się denerwować...

[ Dodano: 2004-08-28, 11:59 ]
Przeinstalowałem Slacka. Jest teraz tak świeży, jak slackware-current na serwerach :)
Niestety - błąd nadal występuje :evil: O ile sobie przypominam, to takie utilsy jak 'gnome-config' były za czasów Gtk1, a nowy Gnome chodzi na Gtk2, no nie? Jak to rozwiązać, względnie obejść? Instalacja pakietów Gtk1 nie pomogła.
[url=http://Polish-30642126344.SpamPoison.com][img]http://pics2.inxhost.com/images/sticker.gif[/img][/url] [url=http://www.bykom-stop.avx.pl][img]http://www.bykom-stop.avx.pl/bannery/80x15.png[/img][/url]

ODPOWIEDZ