[Rozw.]Access point, dhcp, utrata połączenia

Serwery i sieci oparte na Slackware, wszelkiego rodzaju usługi, troubleshooting.

Moderatorzy: Moderatorzy, Administratorzy

Awatar użytkownika
sectt
Użytkownik
Posty: 139
Rejestracja: 2006-06-04, 12:15
Lokalizacja: Kraków
Kontakt:

[Rozw.]Access point, dhcp, utrata połączenia

Post autor: sectt »

Witam,

Mam dziwny problem, mianowicie przerywa mi połączenie przez WIFI przy ściąganiu torrentów.
Jest to sieć osiedlowa która jest podłączona do serwera na Slackware i przez drugą karte sieciową idzie do Access Pointa. IP z access point'a jest przydzielany przez dhcp. Po zerwaniu połączenia nie moge ponownie sie połączyć, nie przydziela mi IP. Próbowałem zmniejszyć upload w kliencie torrent, jak i dać statyczne IP - to samo, restartuje skrypty od internetu - nic. Tylko po restarcie komputera dostaje IP.
Czy ktoś może wie dlaczego sie tak dzieje? Lub w jakich logach szukać przyczyny? Nie znam sie zbytnio na sieciach, bo mnie to nie interesuje, byłbym wdzięczny za nakierowanie mnie gdzie szukać przyczyny.

Pozdrawiam
Jurek
Ostatnio zmieniony 2008-05-19, 13:26 przez sectt, łącznie zmieniany 2 razy.

Awatar użytkownika
Flash
Użytkownik
Posty: 633
Rejestracja: 2004-11-09, 18:14
Lokalizacja: Myszkow
Kontakt:

Re: [Rozw.]Access point, dhcp, utrata połączenia

Post autor: Flash »

Za słaby AP i nie wytrzymuje dużo połączeń.
Jaki system masz u siebie i napisz bardziej konkretnie bo dużo nieścisłości masz w poście.
Po zerwaniu połączenia nie moge ponownie sie połączyć, nie przydziela mi IP. Próbowałem zmniejszyć upload w kliencie torrent, jak i dać statyczne IP - to samo, restartuje skrypty od internetu - nic. Tylko po restarcie komputera dostaje IP.
Restart jakiego komputera serwera czy twojego, skrypty gdzie serwer czy twoja stacja?
Przerywa tylko przy ściąganiu torrentów, czym ściągasz, jaki klient sieci torrent, ogranicz ilość połączeń, prędkość wysyłania i pobierania i zobacz co się dzieje z siecią.

Awatar użytkownika
sectt
Użytkownik
Posty: 139
Rejestracja: 2006-06-04, 12:15
Lokalizacja: Kraków
Kontakt:

Re: [Rozw.]Access point, dhcp, utrata połączenia

Post autor: sectt »

Witam,
AP dostarcza internet tylko 3 komputerom :) Internet na serwerze jest cały czas. Więc tam nic nie restaruje, restartuje skrypty na swoim laptopie i to nie pomaga, dopiero restart laptopa pomaga. Przerywa tylko gdy ściągam torrenty, używam azureusa, pisałem że próbowałem zmniejszyć upload, jak zmniejsze liczbe połączeń to jest to samo. Acha i karte wifi mam na sterowniku ndiswrapper.

P.S. Dzisiaj jak wróciłem z pracy, to ten sam efekt był, net'a nie było. Wyłączyłem moduł ndiswrapper'a i załadowałem go ponownie, następnie zrestartowałem skrypt rc.inet1 i internet przywróciło, co nie rozwiązuje problemu z rozłączaniem :) - strasznie dziwne.... Byłbym wdzięczny za wszelkie wskazówki.

Pozdrawiam
Jurek

tomtom
Użytkownik
Posty: 74
Rejestracja: 2007-10-29, 10:13
Kontakt:

Re: [Rozw.]Access point, dhcp, utrata połączenia

Post autor: tomtom »

Jaka masz karte? Mam taki przypadek: AP Dlinka i trzy komputery z kartami DLink G520 na acx (puszczone przez ndiswrappera) - dwa chodza bez klopotu, trzeci co chwile traci polaczenie. Pomogla zmiana maca karty w trzecim...

Awatar użytkownika
sectt
Użytkownik
Posty: 139
Rejestracja: 2006-06-04, 12:15
Lokalizacja: Kraków
Kontakt:

Re: [Rozw.]Access point, dhcp, utrata połączenia

Post autor: sectt »

Karte mam:

Kod: Zaznacz cały

root@Slackware:/home/jurek$ lspci | grep Atheros
07:00.0 Ethernet controller: Atheros Communications, Inc. AR5006EG 802.11 b/g Wireless PCI Express Adapter (rev 01)
Spróbuje z tym mac'kiem.
Ostatnio zmieniony 2008-05-15, 18:24 przez sectt, łącznie zmieniany 1 raz.

Awatar użytkownika
Flash
Użytkownik
Posty: 633
Rejestracja: 2004-11-09, 18:14
Lokalizacja: Myszkow
Kontakt:

Re: [Rozw.]Access point, dhcp, utrata połączenia

Post autor: Flash »

Sprawdź komendą lspci -nn ID karty. Jeżeli będziesz miał 168c:001c to znaczy że karta jest na chpsecie AR5007G.
Spróbuj tego: http://snapshots.madwifi.org/special/ma ... 007.tar.gzMadWifi ar5007

Awatar użytkownika
sectt
Użytkownik
Posty: 139
Rejestracja: 2006-06-04, 12:15
Lokalizacja: Kraków
Kontakt:

Re: [Rozw.]Access point, dhcp, utrata połączenia

Post autor: sectt »

Ok, spróbuje ale dopiero po weekendzie, także dam znać po weekendzie, dzięki wszystkim za zainteresowanie sie tematem.

[ Dodano: 2008-05-19, 14:25 ]
Problem nie wystąpił na sterownikach madwifi. Narazie wszystko działa poprawnie.
Dzięki jeszcze raz, za zainteresownie sie tematem.
Pozdrawiam
Jurek

ODPOWIEDZ