postfix problem

Serwery i sieci oparte na Slackware, wszelkiego rodzaju usługi, troubleshooting.

Moderatorzy: Moderatorzy, Administratorzy

Awatar użytkownika
olek
Moderator
Posty: 63
Rejestracja: 2004-05-22, 00:37
Lokalizacja: Warszawa
Kontakt:

postfix i quoted-printable

Post autor: olek » 2004-05-23, 12:50

w sendmailu jest z automatu zmiana pola Content-Transfer-Encoding: w mailach pojawia sie cos takiego w naglowku
X-MIME-Autoconverted: from quoted-printable to 8bit by xxx.xx
jak taka konwersje zrobic w postfixie lub amavisie bo nie usmiech mi sie stawiac sendmaila i od nowa wszystko konfigurowac, Grucha moze Ty wiesz

Awatar użytkownika
Corvin
Administrator
Posty: 1143
Rejestracja: 2004-05-21, 15:04
Lokalizacja: Gdańsk

postfix problem

Post autor: Corvin » 2004-05-25, 02:06

Stawiam po raz pierwszy w życiu postfixa, juz prawie stoi, ale
są problemy, do tego ściągnałem tequilę zwraca ona


---> mail: Please install the software package 'Mailx'!


Missing Perl modules:

---> Compress::Zlib (standalone module)
---> Date::Calc (standalone module)
---> HTTP::Daemon (contained in archive 'libwww-perl')
---> HTTP::Date (contained in archive 'libwww-perl')
---> HTTP::Request (contained in archive 'libwww-perl')
---> IO::Scalar (contained in archive 'IO-stringy')
---> IPC::Shareable (standalone module)
---> MD5 (standalone module)
---> MIME::Lite (standalone module)
---> Net::SSLeay (standalone module)


Skąd to wziąść i jak zainstalować ( tu mowa o modułach perl) :) help :D
"Spróbuj zapalić maleńką świeczkę zamiast przeklinać ciemność."
Konfucjusz


Sajmon
Moderator
Posty: 1144
Rejestracja: 2004-05-22, 23:19
Lokalizacja: Graz
Kontakt:

Re: postfix problem

Post autor: Sajmon » 2004-05-25, 12:47

[url=http://polish-32053322658.spampoison.com][img]http://pics8.inxhost.com/images/sticker.gif[/img][/url]
perl -e 'print $i=pack(c5,(41*2),sqrt(7056),(unpack(c,H)-2),oct(115),10);'

Awatar użytkownika
Corvin
Administrator
Posty: 1143
Rejestracja: 2004-05-21, 15:04
Lokalizacja: Gdańsk

Re: postfix problem

Post autor: Corvin » 2004-05-25, 12:57

dzięki o 3 rano przestałem już racjonalnie myśleć :oops:
"Spróbuj zapalić maleńką świeczkę zamiast przeklinać ciemność."
Konfucjusz

Awatar użytkownika
olek
Moderator
Posty: 63
Rejestracja: 2004-05-22, 00:37
Lokalizacja: Warszawa
Kontakt:

Re: postfix problem

Post autor: olek » 2004-05-25, 18:18

a moze tak:

perl -MCPAN -e shell
> install Jakis::Modul

chyba ze mowimy o czym innym
Olek
slackware 7.1, 8.1, 9.1, 10.1, 11.1, 12.2 | www.olek.waw.pl | sklep.12a.pl

Awatar użytkownika
Corvin
Administrator
Posty: 1143
Rejestracja: 2004-05-21, 15:04
Lokalizacja: Gdańsk

Re: postfix problem

Post autor: Corvin » 2004-05-25, 18:57

olek pisze:a moze tak:

perl -MCPAN -e shell
> install Jakis::Modul

chyba ze mowimy o czym innym
Racja :) dzięki zapomniałem o tym, po co się ręcznie mordować, skoro są dostępne tak poyężne narzędzia :)
"Spróbuj zapalić maleńką świeczkę zamiast przeklinać ciemność."
Konfucjusz

Awatar użytkownika
Corvin
Administrator
Posty: 1143
Rejestracja: 2004-05-21, 15:04
Lokalizacja: Gdańsk

Re: postfix problem

Post autor: Corvin » 2004-05-25, 20:25

Wciąż nie potrafię sobie poradzić (Tequila) z tymi trzema modułami Perl:

Missing Perl modules:

---> HTTP::Daemon (contained in archive 'libwww-perl')
---> IPC::Shareable (standalone module)
---> Net::SSLeay (standalone module)

Pierwszy na pewno jest zainstalowany w systemie CPAN
to potwierdza,

Z dwoma kolejnymi jest następujący problem, poniżej cytat z SSLeay

Kod: Zaznacz cały

ok 18 www.ubs.com (Netscape-Enterprise/3.6 SP3)
*** WARNING: There were 2 errors in the tests.
make: *** [test_dynamic] Błąd 255
  /usr/bin/make test -- NOT OK
Running make install
  make test had returned bad status, won't install without force
Poradzicie proszę co zrobić, pozdrawiam
:cry:
"Spróbuj zapalić maleńką świeczkę zamiast przeklinać ciemność."
Konfucjusz

Awatar użytkownika
olek
Moderator
Posty: 63
Rejestracja: 2004-05-22, 00:37
Lokalizacja: Warszawa
Kontakt:

Re: postfix problem

Post autor: olek » 2004-05-25, 23:39

Corvin pisze: ---> Net::SSLeay (standalone module)
Z dwoma kolejnymi jest następujący problem, poniżej cytat z SSLeay

Kod: Zaznacz cały

*** WARNING: There were 2 errors in the tests.
make: *** [test_dynamic] Błąd 255
Poradzicie proszę co zrobić, pozdrawiam
tutaj juz dokladnie nie wiem ale wydajse mi sie ze brakuje jakiegos innego modulu poczytaj czego potrzebuje Net::SSLeay i moze sciagnij, a moze nie wspolpracuje z twoja wersja openssl lub gcc

http://symlabs.com/Net_SSLeay/
http://symlabs.com/Net_SSLeay/README

nie mam wiecej pomyslow, musisz sie wczytac w dokumentacje
Olek
slackware 7.1, 8.1, 9.1, 10.1, 11.1, 12.2 | www.olek.waw.pl | sklep.12a.pl

Awatar użytkownika
Corvin
Administrator
Posty: 1143
Rejestracja: 2004-05-21, 15:04
Lokalizacja: Gdańsk

Re: postfix problem

Post autor: Corvin » 2004-05-25, 23:42

olek pisze:
Corvin pisze:
http://symlabs.com/Net_SSLeay/
http://symlabs.com/Net_SSLeay/README

nie mam wiecej pomyslow, musisz sie wczytac w dokumentacje
Serwer juz stoi :D, bez Tequili :)
"Spróbuj zapalić maleńką świeczkę zamiast przeklinać ciemność."
Konfucjusz

Awatar użytkownika
olek
Moderator
Posty: 63
Rejestracja: 2004-05-22, 00:37
Lokalizacja: Warszawa
Kontakt:

Re: postfix problem

Post autor: olek » 2004-05-25, 23:47

Corvin pisze:Serwer juz stoi :D, bez Tequili :)
i dobrze na co ona byla :wink:
Olek
slackware 7.1, 8.1, 9.1, 10.1, 11.1, 12.2 | www.olek.waw.pl | sklep.12a.pl

Awatar użytkownika
Corvin
Administrator
Posty: 1143
Rejestracja: 2004-05-21, 15:04
Lokalizacja: Gdańsk

Re: postfix problem

Post autor: Corvin » 2004-05-25, 23:54

olek pisze: i dobrze na co ona byla :wink:
no :cry: ;/ :oops: :twisted: :D nie potrzebna na szczęscie czasami jednak warto się przegryść przez pare plików konfiguracyjnych i już jest ok, w sumie była nieco inna konfiguracja niz przewidzieli w makefile a configure nie bylo, ale drobiazg aliases.db w innej lokalizacji /etc/mail zamiast w /etc/postfix i już jest dobrze
"Spróbuj zapalić maleńką świeczkę zamiast przeklinać ciemność."
Konfucjusz

Awatar użytkownika
Grucha
Administrator
Posty: 1679
Rejestracja: 2004-05-21, 14:24
Lokalizacja: Wrocław
Kontakt:

Re: postfix problem

Post autor: Grucha » 2004-05-27, 10:46

A ja mam 2 problemy z postfixem.
- Nie wiem jak dodać 2 domene żeby obsługiwał 2 lub więcej
- Wszystkie odbierane wiadomości lądują w jakiejś kolejce i nie są "rozsyłane" po userach lokalnych.
"Touch my car and i will touch your girl"

Awatar użytkownika
Corvin
Administrator
Posty: 1143
Rejestracja: 2004-05-21, 15:04
Lokalizacja: Gdańsk

Re: postfix problem

Post autor: Corvin » 2004-05-27, 10:55

Grucha pisze:A ja mam 2 problemy z postfixem.
- Nie wiem jak dodać 2 domene żeby obsługiwał 2 lub więcej
- Wszystkie odbierane wiadomości lądują w jakiejś kolejce i nie są "rozsyłane" po userach lokalnych.
Postfix jest serwerem smtp, poszukaj serwa pop3, jak się wyrobię z robotą to Ci pomogę, ale to może być bardzo trudne czasowo :( ;/
"Spróbuj zapalić maleńką świeczkę zamiast przeklinać ciemność."
Konfucjusz

toka
Użytkownik
Posty: 3
Rejestracja: 2004-05-27, 12:41

Re: postfix problem

Post autor: toka » 2004-05-31, 11:02

Grucha pisze:A ja mam 2 problemy z postfixem.
- Nie wiem jak dodać 2 domene żeby obsługiwał 2 lub więcej
- Wszystkie odbierane wiadomości lądują w jakiejś kolejce i nie są "rozsyłane" po userach lokalnych.
Jeśli chcesz by postfix obslugiwal druga domene to nic prostszego oddeleguj taka, a w main.cf musisz dodac ja do destination (wtedy to wszyscy beda mogli z niej korzystac), jesli chcesz miec ja natomiast tylko dla wybranych userow to musisz zrobic to na virtualkach.

Co do drugiej czesci twojego pytania to nie bardzo wiem o co ci chodzi, (napisz wiecej szczegółów). ;)
--
M.Tokarski aka toka
toka at ipv.ath.cx

ODPOWIEDZ